X
點擊此處開啟此網站的行動版。

技術支援討論區

Wav files won't play in Firefox 22

已張貼

Wav files won't play in Firefox 22. Previous versions of Firefox are fine. Other sound is fine. I have the latest mac OS X. Quicktime is set to play wav files. I have the latest version of it.

Is there a fix for this?

Is there any other plugins I can install which will play the wav files?

Wav files won't play in Firefox 22. Previous versions of Firefox are fine. Other sound is fine. I have the latest mac OS X. Quicktime is set to play wav files. I have the latest version of it. Is there a fix for this? Is there any other plugins I can install which will play the wav files?

由 Sun-flower 於 修改

被選擇的解決方法

I found the following bug (looks like it will be fixed in Firefox 23)

  • Bug 890516 - Embedded audio stopped working after installing FF 22
從原來的回覆中察看解決方案 4

額外的系統細節

已安裝的外掛程式

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.7 r700
  • Picasa plugin.
  • iPhoto6

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20100101 Firefox/22.0

更多資訊

提出問題者

I tried each of these as suggested. Nothing was found.

I tried each of these as suggested. Nothing was found.

提出問題者

The replies seem to have got mixed up.

In answer to cor-el's message:

You can try to search (Command+F) for each of these: object and embed and audio (one at the time) to see if anything comes up that is related to playing this notification.


My response is:

I tried each of these as suggested. Nothing was found.

The replies seem to have got mixed up. In answer to cor-el's message: You can try to search (Command+F) for each of these: object and embed and audio (one at the time) to see if anything comes up that is related to playing this notification. My response is: I tried each of these as suggested. Nothing was found.

由 Sun-flower 於 修改

AliceWyman
  • Moderator
240 個解決方法 2607 個答案

I was looking through the Firefox 22 release notes to see what might have changed and it listed New Web Notifications API implemented. I then found Bug 782211 - Implement notification API spec which mentions "Permissions Management" and this softpedia article which says,


Sites can now display desktop notifications, useful for things like social networks, webmail clients and so on and so forth. Users must allow sites to display the notifications, on a site-by-site basis ...


In other words, go to your webmail site, then open the Page Info window by clicking the Site Identity Button (the website’s icon to the left of its address) and click the More information... button in the prompt, the go to Permissions and make sure Show Notifications is not blocked.

Hope that helps.

I was looking through the [http://www.mozilla.org/firefox/22.0/releasenotes/ Firefox 22 release notes] to see what might have changed and it listed ''New Web Notifications API implemented''. I then found [https://bugzilla.mozilla.org/show_bug.cgi?id=782211 Bug 782211 - Implement notification API spec] which mentions "Permissions Management" and [http://news.softpedia.com/news/Firefox-22-Aurora-Adds-Support-for-HTML5-Desktop-Notifications-344220.shtml this softpedia article] which says, ----- ''Sites can now display desktop notifications, useful for things like social networks, webmail clients and so on and so forth. Users must allow sites to display the notifications, on a site-by-site basis ...'' ----- In other words, go to your webmail site, then open the [[Page Info window - View technical details about the page you are on|Page Info window]] by clicking the Site Identity Button (the website’s icon to the left of its address) and click the More information... button in the prompt, the go to Permissions and make sure '''Show Notifications''' is not blocked. Hope that helps.
AliceWyman
  • Moderator
240 個解決方法 2607 個答案

Also, do you see a "bullhorn" icon in the address bar when you go to the webmail site, as shown in the softpedia article? If so, click on it to allow permission for the session (use the drop-down menu to choose the option to make it permanent).

Also, do you see a "bullhorn" icon in the address bar when you go to the webmail site, as shown in the [http://news.softpedia.com/news/Firefox-22-Aurora-Adds-Support-for-HTML5-Desktop-Notifications-344220.shtml softpedia article]? If so, click on it to allow permission for the session (use the drop-down menu to choose the option to make it permanent).

提出問題者

Thank you for checking through the Firefox 22 release notes for me, Alice, to see what had changed. The bug for the New Web Notifications API sounded like it could have been the cause of my problem. When I went into the Site Identification Button, Permissions I found that Show Notifications was blocked so I unblocked it but, sadly, to no avail. The sound still did not play.

There was no bullhorn icon in the address bar when I went on the webmail site. Maybe that is just on Firefox 22 Aurora. However this seems to be about showing and displaying notifications. It does not appear to be about playing a sound.

But certainly this sounded like it was going along the right lines and I feel more hopeful now that this might get fixed in the end as I had all but given up with it. I very much appreciate the time and effort you are putting in to trying to fix this for me. Thank you very much. Hopefully there will be joy in the end.

Thank you for checking through the Firefox 22 release notes for me, Alice, to see what had changed. The bug for the New Web Notifications API sounded like it could have been the cause of my problem. When I went into the Site Identification Button, Permissions I found that Show Notifications was blocked so I unblocked it but, sadly, to no avail. The sound still did not play. There was no bullhorn icon in the address bar when I went on the webmail site. Maybe that is just on Firefox 22 Aurora. However this seems to be about ''showing'' and ''displaying'' notifications. It does not appear to be about ''playing'' a sound. But certainly this sounded like it was going along the right lines and I feel more hopeful now that this might get fixed in the end as I had all but given up with it. I very much appreciate the time and effort you are putting in to trying to fix this for me. Thank you very much. Hopefully there will be joy in the end.

由 Sun-flower 於 修改

AliceWyman
  • Moderator
240 個解決方法 2607 個答案

Sorry it didn't help (I figured it was a long shot since the webmail site only got a complaint from one person, you). You could try creating a second, new Firefox profile for testing or go through the rest of the Basic Troubleshooting steps (Tyler Downer suggested a Firefox Reset in your other thread). Other than that, I'm out of ideas. Hopefully the problem will get resolved in a future Firefox release. You can also file a bug report about this Firefox 22 issue at Bugzilla.

I just wanted to add that you really shouldn't continue using Firefox 21, for security reasons. If Apple's Safari browser is working, you should use that. Another option is to install a different email program that you can run alongside Firefox 22 that includes email sound notifications, such as Mozilla Thunderbird (here's a reference on its new mail sound).

Sorry it didn't help (I figured it was a long shot since the webmail site only got a complaint from one person, you). You could try [[Managing profiles|creating a second, new Firefox profile for testing]] or go through the rest of the [[Basic Troubleshooting|Basic Troubleshooting steps]] (Tyler Downer suggested a Firefox Reset in your [/questions/965279 other thread]). Other than that, I'm out of ideas. Hopefully the problem will get resolved in a future Firefox release. You can also file a bug report about this Firefox 22 issue at [https://bugzilla.mozilla.org Bugzilla]. I just wanted to add that you really shouldn't continue using Firefox 21, for security reasons. If Apple's Safari browser is working, you should use that. Another option is to install a different email program that you can run alongside Firefox 22 that includes email sound notifications, such as [http://www.mozilla.org/en-US/thunderbird/ Mozilla Thunderbird] (here's a [https://support.mozillamessaging.com/kb/how-customize-new-mail-sound reference] on its new mail sound).

提出問題者

The prospect of following your advice this time, Alice, was rather daunting to me as I have never done these things before but I successfully managed it. I created a new profile but the wav sound still did not play from that profile.

I then filed a bug report so hopefully, indeed, it is a bug that can be rectified.

I have also followed your other advice and will now stick with using Firefox 22 along with Safari which will now alert me of my new emails.

Thank you very much for all your help and advice. Also from everybody else.

The prospect of following your advice this time, Alice, was rather daunting to me as I have never done these things before but I successfully managed it. I created a new profile but the wav sound still did not play from that profile. I then filed a bug report so hopefully, indeed, it ''is'' a bug that can be rectified. I have also followed your other advice and will now stick with using Firefox 22 along with Safari which will now alert me of my new emails. Thank you very much for all your help and advice. Also from everybody else.
AliceWyman
  • Moderator
240 個解決方法 2607 個答案

選擇的解決方法

I found the following bug (looks like it will be fixed in Firefox 23)

  • Bug 890516 - Embedded audio stopped working after installing FF 22
I found the following bug (looks like it will be fixed in Firefox 23) *[https://bugzilla.mozilla.org/show_bug.cgi?id=890516 Bug 890516] - Embedded audio stopped working after installing FF 22

提出問題者

Goodness gracious me, that is FANTASTIC news. I thought I was going out of my mind. I thought I was the only one who had this problem. I am so pleased that it is a recognised bug and that it will be sorted soon. I will inform my webmail company.

Thank you for letting me know about that. It has eased my mind. I thought I was going to have to learn to live with it.

Thanks for all the work you have put into helping me. I certainly learned a lot in the process.

Cheers, Alice :-)

Goodness gracious me, that is FANTASTIC news. I thought I was going out of my mind. I thought I was the only one who had this problem. I am so pleased that it is a recognised bug and that it will be sorted soon. I will inform my webmail company. Thank you for letting me know about that. It has eased my mind. I thought I was going to have to learn to live with it. Thanks for all the work you have put into helping me. I certainly learned a lot in the process. Cheers, Alice :-)
AliceWyman
  • Moderator
240 個解決方法 2607 個答案

You're welcome, Sun-flower.

I'll mark my last reply with the embedded audio bug report as the "solution", so that others with the same problem can find it more easily.

You're welcome, Sun-flower. I'll mark my last reply with the embedded audio bug report as the "solution", so that others with the same problem can find it more easily.

提出問題者

You're a star :-)

You're a star :-)
cor-el
  • Top 10 Contributor
  • Moderator
17694 個解決方法 160093 個答案

有幫助的回覆

This bug is about embed tags that have a hidden attribute.

Did you try the workaround posted by Alice0775 White in this bug report?
(btw, she has created a lot of useful extensions)

Add code to the userContent.css file.

embed {
  display:-moz-box !important;
} 

The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

You need to create the chrome folder and within this folder a plain text file called userContent.css.
Make sure to select "All files" and not "Text files" when saving the file to prevent adding a hidden .txt file extension.

This bug is about embed tags that have a hidden attribute. Did you try the workaround posted by Alice0775 White in this bug report?<br /> (btw, [https://addons.mozilla.org/firefox/user/84420/ she has created a lot of useful extensions]) Add code to the userContent.css file. *http://kb.mozillazine.org/userContent.css <pre><nowiki>embed { display:-moz-box !important; } </nowiki></pre> ---- The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder. *http://kb.mozillazine.org/Editing_configuration You can use this button to go to the Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) You need to create the chrome folder and within this folder a plain text file called userContent.css.<br /> Make sure to select "All files" and not "Text files" when saving the file to prevent adding a hidden .txt file extension.

提出問題者

I can't believe it. It worked!

Thank you SO much for letting me know about this. You're a star too!

Cheers :-)

I can't believe it. It worked! Thank you SO much for letting me know about this. You're a star too! Cheers :-)
cor-el
  • Top 10 Contributor
  • Moderator
17694 個解決方法 160093 個答案

You're welcome Sun-flower

You're welcome Sun-flower
dieterschmied 2 個解決方法 14 個答案

Where is the solution? I have the same problem but I can't find the claimed solution.

Where is the solution? I have the same problem but I can't find the claimed solution.

提出問題者

That particular problem was rectified when FF23 came out as it had been a bug in FF22. If you have that problem then it must be because of a different reason unless you do not have FF23 or after.

That particular problem was rectified when FF23 came out as it had been a bug in FF22. If you have that problem then it must be because of a different reason unless you do not have FF23 or after.
dieterschmied 2 個解決方法 14 個答案

I guess that I don't understand the way that these forum comments or answers are entered.

I can't identify any meaningful solution.

Like the original question, how can I fix it? Is there a program? an add-on?

I am using FF -25

I guess that I don't understand the way that these forum comments or answers are entered. I can't identify any meaningful solution. Like the original question, how can I fix it? Is there a program? an add-on? I am using FF -25

提出問題者

Directly under my original question in the same box as my question at the top of page 1 there is a heading which says "Chosen Solution" which says that the problem had been due to a bug in FF 22 and that it would be fixed in FF23 which it was. That was the solution to my problem.

If you have FF25 then there must be a totally different reason for your problem. You will not find the answer to your specific problem in any of the answers to my question.

If you are unable to find a solution elsewhere in the forum then I suggest you start a question of your own, detailing your problem so that, hopefully, others can help you to get a solution to it.

Directly under my original question in the same box as my question at the top of page 1 there is a heading which says "Chosen Solution" which says that the problem had been due to a bug in FF 22 and that it would be fixed in FF23 which it was. That was the solution to my problem. If you have FF25 then there must be a totally different reason for your problem. You will not find the answer to your specific problem in any of the answers to my question. If you are unable to find a solution elsewhere in the forum then I suggest you start a question of your own, detailing your problem so that, hopefully, others can help you to get a solution to it.