搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox incorrectly identifies .xlsx attachments as Firefox HTML documents

  • 6 回覆
  • 11 有這個問題
  • 1773 次檢視
  • 最近回覆由 GWat

more options

When I try to open attachments with .xlsx file extensions, Firefox identifies as a Firefox HTML document and the "open file" window does not show Excel as an option - when I try to Browse to Excel the window does not open to "my programs" where I might be able be able to designate the correct association. (it shows "Program Data" and "Program files" but these don't work to make the association. The file will save ok but, I want to be able to open them as I can easily do in IE. Is the only solution to give up on Firefox and go back to IE?

被選擇的解決方法

Hi Jscher,

Thanks for helping...you don't understand. I didn't make a backup from my bookmarks because I didn't know that I had to do that. But I have a total backup of my computer. That is what I have been putting back into my computer, and everything did come back, except my bookmarks. And that is the trooble, I can't find my old profile anymore. So I tried the places.sqlite that I can find now, but there's nothing happening. And it makes me so angry that I can't get it back, that must be someting that the makers of Firefox have to change. The thing is that your recommends are very light to do, you are very clear. If anybody could tell me where I can find my old profile on the backup, I would do that immidiately. That's the problem. Can you do something with that, because I'm believing now that my files are gone.

I try to make a bookmark backup now and copy places.sqlite in there, you will hear the answer. But I don't think that this is working. I'm sorry.

Thanks schansspringer

從原來的回覆中察看解決方案 👍 0

所有回覆 (6)

more options

Hello GWat ,try to delete the mimeTypes.rdf file in the Firefox profile folder to reset all file actions to default and check firefox again.

(A new file created again when starts firefox or when the application first needs to write to the file)


thank you

more options

Hello,

The following steps should resolve this:

  1. Click on the 'Firefox' button in the top left hand corner
  2. Select 'Options'
  3. Go to the 'Applications' Tab
  4. In the 'Content Type' column look for Excel or XLSX.
  5. Change the value in the 'Action' column to 'Use Microsoft Excel'

See my screenshot for an illustration of the change.

Please let me know if that doesn't help for any reason.

more options

I found and deleted the mimeTypes.rdf file and closed and reopened Firefox, and then tried opening the attached file, but again it thinks it is a Firefox HTML document and does not give Excel as a choice for programs to open it (shows graphics type programs that can open HTML's) any of those shown just open a page of garbage text and symbols. As I mentioned I do not see that the Browse tab takes me to an Excel choice.

more options

When I get to the content type window, there is no reference to Excel or .xlsx or anything similar, so I cannot change anything in the Action choice..

more options

You will have to make sure to add the correct file extension when saving the file if Firefox doesn't do this automatically.

more options

I'm not saving these files - in this case it is the Society of Automotive Engineers that is saving the files. And remember that the same files open with no problem in IE.