搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

此討論串已經關閉並封存。 如果您有需要幫助,請新增一個新問題

Firefox only starts in safemode, I have uninstalled and reinstalled several times

  • 46 回覆
  • 11 有這個問題
  • 5 次檢視
  • 最近回覆由 John99

more options

Using PC with XP. Firefox had been working fine on this PC for a few years, Have had to fix a few times always before if needed by uninstalling completely if need be and starting all new,

Not this time, Have version 22.0 installed, no add on's since I reinstalled so should be clean install no ext or plug ins added yet, but it still does not run in normal mode, only in safe mode.

所有回覆 (20)

more options

Causes for this

  • A Firewall or Security Software is conflicting with these programs.

- Fix: Reinstall Firefox and Chrome and delete all Program FIles in C:/Program Files/Mozilla Firefox or Google Chrome

  • Malware

- Update Anti-malware definitions and run a scan in safe mode, have you tried scans in safe mode with networking with ALL the programs i offered above.

由 kobe 於 修改

more options

Thought I said that it only works in safe mode??

I think the suggestion now is to try Windows safe Mode (F8 key). You appear to have some software interfering with Firefox and other applications. That often turns out to be security related software that is a problem.

It is odd however that Firefox is working in Firefox's safemode. Firefox's safe mode is used to troubleshoot Firefox's settings and extensions. (Also turns off Hardware Acceleration and JIT)

more options

Yes I agree just not sure what is interfering..Firefox is working in Windows XP safe mode.not FF safe mode,.

As I said also now have similat issue with Chrome opens to a browser but will not load any web pages when entered in address bar it use to work fine as well.

I have reinstalled both several times after complete uninstall ..including personal settings for either.

Not sure how to do this? C:/Program Files/Mozilla Firefox or Google Chrome

I have Total Defense Security Software and have tried disabling firewall, ran scans for spyware and viruses to..none found or cleaned!

由 jamesil 於 修改

more options

Uninstall Firefox and Chrome, Then delete C:\Program Files\Mozilla Firefox and C:\Program Files\Google\Google Chrome . And sorry so used to linux where its / instead of windows's \.

more options

Then delete C:\Program Files\Mozilla Firefox and C:\Program Files\Google\Google Chrome

Sorry but how do I do this?

more options

Open the File explorer and go to computer, hit on the C drive, then a Folder named Program Files. In that folder (after uninstall) delete Google CHrome and Mozilla FIrefox Folders.

more options

Where do I find the File explorer?

more options

Hit windows button and R button and type in explorer.exe

more options

Aw okay, I did that only found one file for Mozilla, deleted it..Only file in there sayiong a Googlle File I saw seemed to only relate to Google Earth..

Think the Google Chrome file was removed when I uininstalled it..I hope.

Before I reinstall I am confused was I supposed to enter both of these some where that will let me delete them:

C:\Program Files\Mozilla Firefox and

C:\Program Files\Google\Google Chrome

I don't know where to enter them to be able to do that?

more options

No they automatically reform when you install.

more options

I must say you are displaying incredible patience given such a frustrating problem.

Sorry I did everything carefully. You are clearly saying that Firefox works in Firefox's safemode.

If that is the case it is to be expected that one of the safe mode changes is solving the problem. Or more unusually a combination of those changes is solving the problem.

Safemode does the following

To summarize:

  • Safe Mode temporarily affects the following:
    1. All extensions are disabled.
    2. The default theme is used, without a persona.
    3. The Just-in-time (JIT) JavaScript compiler is disabled.
    4. The userChrome.css and userContent.css files are ignored.
    5. The default toolbar layout is used.
    6. Hardware acceleration is disabled.
  • Safe Mode has no effect on the following:
    1. The status of plugins is not affected.
    2. Custom preferences are not affected. To summarize:

Try to recreate safemode by doing all of that at once in an ordinary instance of Firefox.

3. To disable JIT , set the javascript.options.methodjit. preferences to false in about:config

4. userChrome.css and userContent.css is not likely to apply.
Check your Firefox profile if it contains those files re name them

6. HA disabling was explained above

I would also disable security software. (Test offline that is safer)

If you do all of that you are effectively running Firefox in safemode but by making the changes manually so it should work. Then reverse the changes one at a time to see what causes the problem.


If you do not wish to go through all that trouble then again because we know Firefox works in Firefox's safe mode it will work if you use Firefox's Reset.

由 John99 於 修改

more options

No I didn't say:

"You are clearly saying that Firefox works in Firefox's safemode. " 

I said it works in Windows XP safemode!

more options

I appreciate all the help guys but it does me not much good when you tell me to try something I do not know how to do, with replying and asking..maybe when you tell me to try some thing include the steps how to do it

Like this stuff may as well be in Greek?

3. To disable JIT , set the javascript.options.methodjit. preferences to false in about:config

4. userChrome.css and userContent.css is not likely to apply. Check your Firefox profile if it contains those files re name them

6. HA disabling was explained above

由 jamesil 於 修改

more options

Sorry ignore the comments. I must have been confusing this with another thread.

If you do not have Firefox working in Firefox's safe mode there is no point in trying any of that.

For reference

It appears at this moment in time the mozilazine site is down, if you wish to look at their kb articles google for those pages and use the Google cached copies.

more options

Far as I can tell I have deleted evey thing related to FF or Google Chrome off this machine least when I use the search for files etc fucnction on the C drive it finds none for either browser.

So should be know profiles set up now or active until I reinstall and get it to open normally I would think.

I have not reinstalled either browser just yet..

more options

Do not delete profiles, or use options to remove personal information, because you will destroy bookmarks and passwords etc.

You may wish to move the profile to another location such as the desktop. That way it will not be used & Firefox will create a new one. Bookmarks etc may be recovered from the original profile if you keep it safe (So keep it outside of Firefox or profile paths)

more options

Your beginning to make me think I am speaking in a foreign language,. thought I just said I had deleted all files related to FF which includes profile..I don't care if I loose that info any profile had...

more options

Well at least you now are going to have a clean install and a clean profile.

But that may not stop whatever it was interfering with Firefox again. Reinstall and find out.

more options

Well thanks so far that has been the point asd I have done this several times already before I even came here and it was not fixing..none of the support info I have found in support area is helping to fix it and you guys basically have been just repeating info I had already found and tried..at this point I am trying to find a fix the info so far has not helped yet.

As I said kinda now feel there is something wrong on my end causing it!

more options

Hello jamesil, if Firefox works correct in Windows Safe mode then you have a problem with other software, like security software or maybe a system driver, that is running on your computer.

thank you

  1. 1
  2. 2
  3. 3