X
點擊此處開啟此網站的行動版。

技術支援討論區

How can I stop Firefox from blocking a Java applet from a site that I trust?

已張貼

I'm trying to run an application that displays competitors' routes at an orienteering event. My problem is that Firefox blocks the Java applet. I get a window saying "Application Blocked by Security Settings. Your security settings have blocked an application from running with an insecure or expired jre."

I've tried looking at the Firefox help on "How to enable Java if it's been blocked", but that's no help. It talks about clicking on the red plug-in icon in the address bar, but there isn't a red plug-in icon in the address bar.

The application is from www.epoc.routegadget.co.uk. It worked when I used it last Sunday.

Help, please!

I'm trying to run an application that displays competitors' routes at an orienteering event. My problem is that Firefox blocks the Java applet. I get a window saying "Application Blocked by Security Settings. Your security settings have blocked an application from running with an insecure or expired jre." I've tried looking at the Firefox help on "How to enable Java if it's been blocked", but that's no help. It talks about clicking on the red plug-in icon in the address bar, but there isn't a red plug-in icon in the address bar. The application is from www.epoc.routegadget.co.uk. It worked when I used it last Sunday. Help, please!

被選擇的解決方法

hello, this warning isn't coming from firefox but from the java plugin itself - please update your plugins.

some more information about java's security settings are also available at oracle's support: https://www.java.com/en/download/help/jcp_security.xml

從原來的回覆中察看解決方案 41

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.7 r700
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.20125.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Garmin Communicator Plug-In 4.0.4.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Yahoo! activeX Plug-in Bridge
  • Windows Multimedia Services DRM Store Plug-In

應用程式

  • Firefox 21.0
  • 使用者代理:Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0
  • 技術支援網址:http://support.mozilla.org/1/firefox/21.0/WINNT/en-US/

擴充套件

  • Garmin Communicator 4.0.4 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • Norton Toolbar 2013.4.1.2 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Download Accelerator Plus Integration 8.0.6.5 ({F17C1572-C9EC-4e5c-A542-D05CBB5C5A08}) (Inactive)
  • Microsoft .NET Framework Assistant 1.2.1 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • Norton Vulnerability Protection 11.3.0.9 - 5 ({BBDA0591-3099-440a-AA10-41764D9DB4DB}) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: Intel(R) 82945G Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2772
  • adapterDeviceID2:
  • adapterDrivers: ialmrnt5
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'6.14.10.4926']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 10-14-2005
  • driverDate2:
  • driverVersion: 6.14.10.4410
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'6.14.10.4926']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'6.14.10.4926']
  • windowLayerManagerType: Basic

修改過的偏好設定

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 686080
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.startup.homepage: http://www.google.co.uk/
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • browser.tabs.warnOnClose: False
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • general.useragent.extra.microsoftdotnet: ( .NET CLR 3.5.30729; .NET4.0C)
  • gfx.blacklist.suggested-driver-version: 6.14.10.4926
  • network.cookie.prefsMigrated: True
  • network.http.spdy.enabled: False
  • network.image.imageBehavior: 0
  • places.database.lastMaintenance: 1372446810
  • places.history.expiration.transient_current_max_pages: 80271
  • places.history.expiration.transient_optimal_database_size: 42533354
  • places.last_vacuum: 1326755002
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.downloads: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.history: False
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.item.downloads: False
  • privacy.item.formdata: False
  • privacy.item.history: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.promptOnSanitize: False
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • security.enable_tls: False
  • security.warn_viewing_mixed: False

其他

  • User JS: 否
  • 輔助功能: 否
philipp
  • Top 25 Contributor
  • Moderator
5323 個解決方法 23507 個答案

選擇的解決方法

hello, this warning isn't coming from firefox but from the java plugin itself - please update your plugins.

some more information about java's security settings are also available at oracle's support: https://www.java.com/en/download/help/jcp_security.xml

hello, this warning isn't coming from firefox but from the java plugin itself - please [https://www.mozilla.org/en-US/plugincheck/ update your plugins]. some more information about java's security settings are also available at oracle's support: https://www.java.com/en/download/help/jcp_security.xml

提出問題者

Thanks, Phillip.

I hadn't spotted that it was a Java message rather than a Firefox one. (And I'm still not sure how to tell.)

I've updated the Java plug-in (and, while I was at it, some other plug-ins) and I can once more check my competitors' routes at orienteering events.

Thanks again.

Alastair

Thanks, Phillip. I hadn't spotted that it was a Java message rather than a Firefox one. (And I'm still not sure how to tell.) I've updated the Java plug-in (and, while I was at it, some other plug-ins) and I can once more check my competitors' routes at orienteering events. Thanks again. Alastair
rcovey 0 個解決方法 1 個答案

I have tried updating java but it won't because it is still blocked. What do you suggest I try next

I have tried updating java but it won't because it is still blocked. What do you suggest I try next
philipp
  • Top 25 Contributor
  • Moderator
5323 個解決方法 23507 個答案

hello rcovey, could you provide a little bit more information about the issue - which version of the java plugin do you have listed under firefox > addons > plugins, on which page do you get the error message & what's the exact wording...

hello rcovey, could you provide a little bit more information about the issue - which version of the java plugin do you have listed under firefox > addons > plugins, on which page do you get the error message & what's the exact wording...
back40 0 個解決方法 2 個答案

I have this same problem but with facebook. So I removed the old java, downloaded and installed the latest java (25 I think) version, shut down and restarted my laptop, and it is still happening. Here is the error message I'm getting: [Java script Application] evalinsandbox:Error:Permission denied for <https://facebook.com> to create wrapper for object of class Unnamed class

I have this same problem but with facebook. So I removed the old java, downloaded and installed the latest java (25 I think) version, shut down and restarted my laptop, and it is still happening. Here is the error message I'm getting: [Java script Application] evalinsandbox:Error:Permission denied for <https://facebook.com> to create wrapper for object of class Unnamed class
philipp
  • Top 25 Contributor
  • Moderator
5323 個解決方法 23507 個答案

hello back40, your problem is of different nature (java is not the same as javascript). please update your socialfixer extension: http://socialfixer.com/blog/category/releasenotes/

hello back40, your problem is of different nature (java is not the same as javascript). please update your socialfixer extension: http://socialfixer.com/blog/category/releasenotes/
dsouza1 0 個解決方法 4 個答案

I am trying to get Java to work on my Firefox browser. I have followed all the suggestions on the Java website and also all that I can find on the Mozilla support. Can anyone please help me as this is important to my work. When I do a check on the java website it says I need a plugin; but when I try to check which plugin, there is no plug in that is available. I have checked my plug in manager and all my plugins are up to date.

Please help. (I have downloaded the latest java - java SE7 update 25) Nigeld

I am trying to get Java to work on my Firefox browser. I have followed all the suggestions on the Java website and also all that I can find on the Mozilla support. Can anyone please help me as this is important to my work. When I do a check on the java website it says I need a plugin; but when I try to check which plugin, there is no plug in that is available. I have checked my plug in manager and all my plugins are up to date. Please help. (I have downloaded the latest java - java SE7 update 25) Nigeld
cor-el
  • Top 10 Contributor
  • Moderator
17578 個解決方法 159008 個答案

Note that you need the 32 bit Java version if you have a 64 bit Windows version because Firefox is a 32 bit application.

See also:

Note that you need the 32 bit Java version if you have a 64 bit Windows version because Firefox is a 32 bit application. *http://www.java.com/en/download/faq/java_win64bit.xml See also: *http://kb.mozillazine.org/Java
dsouza1 0 個解決方法 4 個答案

Thank you Cor-el, I am not sure if I have firefox 32 bit or 64 bit version. K did the test you referred to and it does not say anything about what version of firefox I have. I am running firefox on my IMac version 10.8 (Mountian lion) adn have downloaded the latest Java 7 update 25. I am unable to find the Java for a 32 bit firefox browser Can you please guide me?


Thanks, Nigel d

Thank you Cor-el, I am not sure if I have firefox 32 bit or 64 bit version. K did the test you referred to and it does not say anything about what version of firefox I have. I am running firefox on my IMac version 10.8 (Mountian lion) adn have downloaded the latest Java 7 update 25. I am unable to find the Java for a 32 bit firefox browser Can you please guide me? Thanks, Nigel d
cor-el
  • Top 10 Contributor
  • Moderator
17578 個解決方法 159008 個答案

On Mac, Firefox is a 64 bit application (actually a i386/x86_64 universal binary).
The 32 version for Java only applies to the Windows platform.

See also:

On Mac, Firefox is a 64 bit application (actually a i386/x86_64 universal binary).<br /> The 32 version for Java only applies to the Windows platform. See also: *http://kb.mozillazine.org/Java
dsouza1 0 個解決方法 4 個答案

Hi Cor-el, Thanks for your confirmation that I have the 64 bit version of firefox on my IMac. But I still cannot get Java to work./ I have downloaded it, but the computer does not recognise I have it. When I check my Add-ons manager on Firefox, I do not see the Java applet plug in listed. How do I get the Java plug in on to my firefox browser? Thanks for your responses. Nigeld

Hi Cor-el, Thanks for your confirmation that I have the 64 bit version of firefox on my IMac. But I still cannot get Java to work./ I have downloaded it, but the computer does not recognise I have it. When I check my Add-ons manager on Firefox, I do not see the Java applet plug in listed. How do I get the Java plug in on to my firefox browser? Thanks for your responses. Nigeld
GroundControl 0 個解決方法 4 個答案

Mac platform Java 7 u25 FF v22

Glad to hear I'm not the only one with this issue. Re-installing Java and Firefox is not the answer. Solution: Create a new Profile in FF. This has worked, don't now why FF is not automatically recognizing Java. Once you've done this, Java will appear as a plug-in in the Add-Ons. Profile instructions are at this URL:

http://kb.mozillazine.org/Transferring_data_to_a_new_profile

Mac platform Java 7 u25 FF v22 Glad to hear I'm not the only one with this issue. Re-installing Java and Firefox is not the answer. '''Solution:''' Create a new Profile in FF. This has worked, don't now why FF is not automatically recognizing Java. Once you've done this, Java will appear as a plug-in in the Add-Ons. Profile instructions are at this URL: http://kb.mozillazine.org/Transferring_data_to_a_new_profile
GroundControl 0 個解決方法 4 個答案

To create a new profile for Firefox, (Mac) launch the Terminal window located in the Applications folder and paste this information behind the prompt, hit return (FF Profile window will appear)

/Applications/Firefox.app/Contents/MacOS/firefox-bin -profilemanager

To create a new profile for Firefox, (Mac) launch the Terminal window located in the Applications folder and paste this information behind the prompt, hit return (FF Profile window will appear) /Applications/Firefox.app/Contents/MacOS/firefox-bin -profilemanager
jpdemers 1 個解決方法 14 個答案

If the Plug-in is not visible, Firefox may be set to start in 32-bit mode. On a Mac, you want to quit Firefox, find the Firefox application icon in your Applications folder, and Get Info on it (right-click, or cmd-I). There's a checkbox for 32-bit mode, which you'll need to uncheck. (Bizarre approach to setting a critical parameter, but I suppose there's a reason for it.)

If the Plug-in is not visible, Firefox may be set to start in 32-bit mode. On a Mac, you want to quit Firefox, find the Firefox application icon in your Applications folder, and Get Info on it (right-click, or cmd-I). There's a checkbox for 32-bit mode, which you'll need to uncheck. (Bizarre approach to setting a critical parameter, but I suppose there's a reason for it.)
GroundControl 0 個解決方法 4 個答案

jpdemers - You Rock! This Worked!

I've been going crazy for months. Everytime I'd quit FF I'd have to re-create a new profile for FF to see the Java applet (not sure why this works).

Thanks so much for your help!

jpdemers - You Rock! This Worked! I've been going crazy for months. Everytime I'd quit FF I'd have to re-create a new profile for FF to see the Java applet (not sure why this works). Thanks so much for your help!
dugeen1 0 個解決方法 4 個答案

Is there a solution for this yet? I keep clicking 'Reload' but it just sends me round and round in circles.

cor-el, you are specifically requested not to respond as your cut-and-paste responses are completely unhelpful.

Is there a solution for this yet? I keep clicking 'Reload' but it just sends me round and round in circles. cor-el, you are specifically requested not to respond as your cut-and-paste responses are completely unhelpful.
jpdemers 1 個解決方法 14 個答案

dugeen1: What OS? What version of the OS, what version of FF, what version of Java? You can't expect much help if people don't have the basics.

dugeen1: What OS? What version of the OS, what version of FF, what version of Java? You can't expect much help if people don't have the basics.

由 jpdemers 於 修改

dsouza1 0 個解決方法 4 個答案

Thanks for your queries. I am using OS X version 10.8.4 on my IMac which is having the problem. I am using Firefox 22.0 and it is up to date. I have downloaded the latest version of Java from tbe Java website. It is version 7 update 25 build 1.7.0_25-b15

So I have the latest version on the computer but I cannot get Java to work on firefox. Thanks for any help you can provide. Nigel D

Thanks for your queries. I am using OS X version 10.8.4 on my IMac which is having the problem. I am using Firefox 22.0 and it is up to date. I have downloaded the latest version of Java from tbe Java website. It is version 7 update 25 build 1.7.0_25-b15 So I have the latest version on the computer but I cannot get Java to work on firefox. Thanks for any help you can provide. Nigel D
GroundControl 0 個解決方法 4 個答案

dsouza1: Please see jpdemers earlier response posted on 7/18/13. This answered my similar question: "If the Plug-in is not visible, Firefox may be set to start in 32-bit mode. On a Mac, you want to quit Firefox, find the Firefox application icon in your Applications folder, and Get Info on it (right-click, or cmd-I). There's a checkbox for 32-bit mode, which you'll need to uncheck. (Bizarre approach to setting a critical parameter, but I suppose there's a reason for it.)"

Thanks again jpdemers!

dsouza1: Please see jpdemers earlier response posted on 7/18/13. This answered my similar question: '''"If the Plug-in is not visible, Firefox may be set to start in 32-bit mode. On a Mac, you want to quit Firefox, find the Firefox application icon in your Applications folder, and Get Info on it (right-click, or cmd-I). There's a checkbox for 32-bit mode, which you'll need to uncheck. (Bizarre approach to setting a critical parameter, but I suppose there's a reason for it.)"''' Thanks again jpdemers!
jpdemers 1 個解決方法 14 個答案

If the 32-bit mode is not the problem, my next approach would be to completely re-install Firefox. Use something like AppCleaner to remove all the old traces, restart the Mac, then re-run the newest FF installer. With a clean set of default preference settings, it's hard to see what would block Java from running properly.

Bit of a pain to lose your bookmarks, so you might want to have them safely stashed, using Xmarks or Firefox's own synching feature.

If the 32-bit mode is not the problem, my next approach would be to completely re-install Firefox. Use something like AppCleaner to remove all the old traces, restart the Mac, then re-run the newest FF installer. With a clean set of default preference settings, it's hard to see what would block Java from running properly. Bit of a pain to lose your bookmarks, so you might want to have them safely stashed, using Xmarks or Firefox's own synching feature.