搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How do I entirely diasable the recently visited page in newtab?

more options

SO, I'm using the speed dial add on and I want to be able to show my tabs when I hit the home button. Typically in the past I've done this by setting home to about:newtab. My addon does show the speed dial page when I click the + sign in the tabs however about:newtab/home button always takes me to the part where Firefox shows me the most visited sites I've been to.

How do I stop this? I don't want this feature in any shape. I want to see speed dial when I hit home. Is there anyway to completely disable this recently visited feature?

SO, I'm using the speed dial add on and I want to be able to show my tabs when I hit the home button. Typically in the past I've done this by setting home to about:newtab. My addon does show the speed dial page when I click the + sign in the tabs however about:newtab/home button always takes me to the part where Firefox shows me the most visited sites I've been to. How do I stop this? I don't want this feature in any shape. I want to see speed dial when I hit home. Is there anyway to completely disable this recently visited feature?

所有回覆 (12)

more options

Could you try changing your home page to about:blank and see whether that trigger Speed Dial?

You could do the same thing for new tabs.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter the desired value:

(i) Page thumbnails (default)

about:newtab

(ii) Blank tab

about:blank

(iii) Built-in Firefox home page

about:home

(iv) Any other page

full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

more options

You can create these Boolean prefs on the about:config page if you want to prevent Firefox from generating thumbnails for the about:newtab page.

  • name: browser.pagethumbnails.capturing_disabled with value: true
  • name: pageThumbs.enabled with value: false

You need to delete the thumbnails folder in the Firefox profile folder to remove already stored web page thumbnails.

more options

Thank you but I've done all of this already. about:blank opens a blank white screen.

more options

No. I want it to go away completely. It's over riding my plugin somehow. It's a lousy feature and I don't want to play with it. I want it disabled entirely.

more options

Could you check to confirm that your speed dial extension is enabled and up-to-date?

orange Firefox button (or Tools menu) > Add-ons > Extensions category

Click the "gear" icon > Check for Updates to update your extensions.

If it still doesn't work, you could try to get support for it from its author or try a different one.

more options

You can't disable this feature completely. If you set another page as the new tab page, then you won't see them, but the new tab page stays available and will show again if you open it at any time.

You can drag an about:blank link in all squares on the about:newtab page if you do not want any visited pages to show there.

more options

So I have the same problem, firefox is fine, speed dial is fine. I tried all the junk above plus some code changes on my own. All I want to do is click on the home button and get speed dial to show, its a dumb little thing but the heart wants, what the heart wants.

The overall problem is there is some weird option hard coded into Firefox that keeps popping up with the recently visited pages. I can get a blank page or that crap recently visited tab page which I can hide or unhide. We have history we don't need this!!

About:config is kinda awesome but limiting. Where can you set the options to click on the home button and get a true blank new tab and not have firefox features override you, with junk recently visited pages.

由 durst95 於 修改

more options

Hi durst95, you can set your home page to a blank page in the Options/Preferences dialog. Just replace anything that might already be in that line with about:blank and OK the change.

  • Win: orange Firefox button (or Tools menu) > Options > General
  • Mac: Firefox menu > Preferences > General

This article might help: Startup, home page, tabs, and download settings.

more options

Options > Privacy >

  • History: Never remember history
  • Location bar: Nothing

Final, restart your FF, check it,

由 k3lvinmitnick.com 於 修改

more options

"Never remember history" means entering Private Browsing mode and that is a bit overkill for only an issue with the new tab page. You can drag a page like about:blank onto every tile on the about:newtab page to have a blank page pinned to every of the nine tiles. set the two prefs browser.newtabpage.rows and browser.newtabpage.columns to 0 and drag the about:newtab page or a drag a page with a locally saved image to the one tile that is left.

由 cor-el 於 修改

more options

So I don't think people read my post at all. I already did the above stuff setting the homepage to about:blank, about:newtab or leaving the field empty. You get a random blank page that should load speed dial but doesn't or recent doc page which I have no interest. When I start-up Firefox with the load blank page option it opens fine, speed dial works. Kinda weird how setting it screws it up. No changes worked but. Big thanks to the developer of speed dial for the fix.

The pure and correct fix is setting the homepage to "chrome://speeddial/content/speeddial.xul" done, perfect, winner winner chicken dinner. When I hit home button, I now get my speed dial.

由 durst95 於 修改

more options

Hi durst95, you wrote:

So I don't think people read my post at all.

In the last paragraph of your post you asked "Where can you set the options to click on the home button and get a true blank new tab and not have firefox features override you, with junk recently visited pages." That is the question I answered. But a truly blank page wasn't what you actually wanted, so apologies for not properly reading your mind. ;-)

Since the question was how to make the add-on work, you were absolutely correct to consult the add-on author for the answer. Excellent sleuthing.