X
點擊此處開啟此網站的行動版。

技術支援討論區

Some links become unclickable when zooming in.

已張貼

Hi, all :)

Lately, I've been having a problem with some links: they become unclickable when zooming in(Ctrl + Mouse Wheel), but when doing some mild zooming out, it becomes clickable again.

Here are some screenshots I've taken, to make my problem clearer:

http://i.imgbox.com/adlB9NtJ.png As you can see, when zoomed in so it would fill the screen, the mouse cursor isn't detecting any hyperlink and clicking on it won't link me to the desired page.

http://i.imgbox.com/adyPwwFh.png In here, as you can see from the mouse cursor, after zooming out a little, it becomes clickable again.

I would really appreciate if anyone could offer any solution to this. Thanks.

Hi, all :) Lately, I've been having a problem with some links: they become unclickable when zooming in(Ctrl + Mouse Wheel), but when doing some mild zooming out, it becomes clickable again. Here are some screenshots I've taken, to make my problem clearer: http://i.imgbox.com/adlB9NtJ.png As you can see, when zoomed in so it would fill the screen, the mouse cursor isn't detecting any hyperlink and clicking on it won't link me to the desired page. http://i.imgbox.com/adyPwwFh.png In here, as you can see from the mouse cursor, after zooming out a little, it becomes clickable again. I would really appreciate if anyone could offer any solution to this. Thanks.

由 YairGOW 於 修改

被選擇的解決方法

I think you could use a style rule like the following to remove the left and right side ads, either in userContent.css or using the Stylish extension:

@namespace url(http://www.w3.org/1999/xhtml);
@-moz-document domain("one.co.il") {
  #adTower600, #divTopRightAds {display:none !important;}
}

I'm having trouble testing this because on my regular profile the ads are suppressed in some other manner, and in a new profile I didn't have Stylish... I'll try to confirm.

從原來的回覆中察看解決方案 1

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.7 r700
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • ACE Stream Plug-in Version 2.0.9.0, Copyright (c) 2012 Innovative Digital Technologies
  • iTunes Detector Plug-in
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • VLC media player Web Plugin 2.0.2
  • Facebook Video Calling Plugin
  • VDownloader browser plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

應用程式

  • Firefox 20.0.1
  • 使用者代理:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • 技術支援網址:http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

擴充套件

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Anti-Banner 13.0.1.4250 (anti_banner@kaspersky.com)
  • Babylon Spelling and Proofreading 1.0.0.1 (adapter@babylontc.com)
  • Babylon Translation Activation 1.1 (ocr@babylon.com)
  • Cookies Manager+ 1.5.1.1 ({bb6bc1bb-f824-4702-90cd-35e2fb24f25d})
  • Copy Links 0.1.7 ({76C80A11-FAD4-406c-8246-F5ED4F9367B5})
  • IDM CC 7.3.40 (mozilla_cc@internetdownloadmanager.com)
  • Multi Links 3.0.0.19 (multilinks@plugin)
  • ProxTube - Unblock YouTube 1.4.8 (ich@maltegoetz.de)
  • SearchIMDB 1.2.0 (searchimdb@sogame.cat)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • TS Magic Player 1.1.22 (magicplayer@torrentstream.org)
  • YouTubeIT 0.6.2 (youtubeit_aechiara@gmail.com)
  • Content Blocker 13.0.1.4250 (content_blocker@kaspersky.com) (Inactive)
  • Kaspersky URL Advisor 13.0.1.4250 (url_advisor@kaspersky.com) (Inactive)
  • Safe Money 13.0.1.4250 (online_banking@kaspersky.com) (Inactive)
  • VDownloader 3.9.1155 (support@vdownloader.com) (Inactive)
  • Virtual Keyboard 13.0.1.4250 (virtual_keyboard@kaspersky.com) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: AMD Radeon HD 6900 Series
  • adapterDescription2:
  • adapterDeviceID: 0x6719
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 12-19-2012
  • driverDate2:
  • driverVersion: 9.12.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 6900 Series)
  • windowLayerManagerType: Direct3D 10

修改過的偏好設定

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: https://www.google.co.il/
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • browser.tabs.warnOnClose: False
  • browser.urlbar.autoFill: False
  • browser.urlbar.autoFill.typed: False
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • general.useragent.extra.btrs: BTRS35926
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://search.conduit.com/ResultsExt.aspx?ctid=CT3220468&SearchSource=2&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1365702416
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

其他

  • User JS: 是
  • 輔助功能: 否
cor-el
  • Top 10 Contributor
  • Moderator
17764 個解決方法 160655 個答案

Try to disable hardware acceleration in Firefox.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
Try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://hacks.mozilla.org/2010/09/hardware-acceleration/ Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

提出問題者

I think I've discovered what causes the problem. This site has ads on the sides, so when zooming in, Adblock blocks the ads, and since they are "over" the page, the entire area becomes unclickable. When, zooming out a little, the ads are on the white borders and don't interfere with the page itself. I've checked it by disabling Adblock, of course, and noticing the ads on the side. Example of the ads: http://i.imgbox.com/adiLzO19.png

Is there any way around it, then?

I think I've discovered what causes the problem. This site has ads on the sides, so when zooming in, Adblock blocks the ads, and since they are "over" the page, the entire area becomes unclickable. When, zooming out a little, the ads are on the white borders and don't interfere with the page itself. I've checked it by disabling Adblock, of course, and noticing the ads on the side. Example of the ads: http://i.imgbox.com/adiLzO19.png Is there any way around it, then?
jscher2000
  • Top 10 Contributor
8878 個解決方法 72633 個答案

有幫助的回覆

I don't use AdBlock Plus, so this is just a guess. If the extension removes the ads but leaves a container element, you could try this extension. It adds "Remove this object" to the right-click menu.

https://addons.mozilla.org/firefox/addon/nuke-anything-enhanced/

Afterwards, it changes to "Undo last remove" if you discover that you removed the wrong thing.

I don't use AdBlock Plus, so this is just a guess. If the extension removes the ads but leaves a container element, you could try this extension. It adds "Remove this object" to the right-click menu. https://addons.mozilla.org/firefox/addon/nuke-anything-enhanced/ Afterwards, it changes to "Undo last remove" if you discover that you removed the wrong thing.

提出問題者

It works, but each time I enter the page, I have to do the removing all over again. Is there a way to make the removed objects stay removed permanently?

It works, but each time I enter the page, I have to do the removing all over again. Is there a way to make the removed objects stay removed permanently?
cor-el
  • Top 10 Contributor
  • Moderator
17764 個解決方法 160655 個答案

有幫助的回覆

See also: *Remove It Permanently (RIP): https://addons.mozilla.org/firefox/addon/remove-it-permanently/

提出問題者

It still comes back when I reenter the website, even after using RIP :\

It still comes back when I reenter the website, even after using RIP :\
jscher2000
  • Top 10 Contributor
8878 個解決方法 72633 個答案

What is the URL of the page?

What is the URL of the page?

提出問題者

http://one.co.il/
jscher2000
  • Top 10 Contributor
8878 個解決方法 72633 個答案

選擇的解決方法

I think you could use a style rule like the following to remove the left and right side ads, either in userContent.css or using the Stylish extension:

@namespace url(http://www.w3.org/1999/xhtml);
@-moz-document domain("one.co.il") {
  #adTower600, #divTopRightAds {display:none !important;}
}

I'm having trouble testing this because on my regular profile the ads are suppressed in some other manner, and in a new profile I didn't have Stylish... I'll try to confirm.

I think you could use a style rule like the following to remove the left and right side ads, either in [http://kb.mozillazine.org/UserContent.css userContent.css] or using the [https://addons.mozilla.org/en-US/firefox/addon/stylish/ Stylish extension]: @namespace url(http://www.w3.org/1999/xhtml); @-moz-document domain("one.co.il") { #adTower600, #divTopRightAds {display:none !important;} } I'm having trouble testing this because on my regular profile the ads are suppressed in some other manner, and in a new profile I didn't have Stylish... I'll try to confirm.

提出問題者

Thank you, jscher2000! Editing userContent.css according to your instructions worked :)

Btw, any explanation on the terms used in the script would be really appreciated.

Thank you, jscher2000! Editing userContent.css according to your instructions worked :) Btw, any explanation on the terms used in the script would be really appreciated.
jscher2000
  • Top 10 Contributor
8878 個解決方法 72633 個答案

The style rule targets the specific html elements <div id="adTower600"> <div id="divTopRightAds"> -- in a style rule, you use a # sign before the id to indicate that it is an id -- and prevents them from displaying by setting display:none. You can read more about CSS rules here: https://developer.mozilla.org/docs/CSS.

The style rule targets the specific html elements &lt;div id="adTower600"> &lt;div id="divTopRightAds"> -- in a style rule, you use a # sign before the id to indicate that it is an id -- and prevents them from displaying by setting display:none. You can read more about CSS rules here: [https://developer.mozilla.org/docs/CSS].

提出問題者

Again, thank you.

Again, thank you.