搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox 20 crashes when i Startup using Windows 7 64bit

  • 8 回覆
  • 19 有這個問題
  • 4167 次檢視
  • 最近回覆由 John99

more options

Since firefox 19, and recently i upgraded to 20 Firefox crashes, and the only way i can startup firefox is in safetymode. I removed all add-ons and even did a clean install of firefox again, but no result.

被選擇的解決方法

Open Firefox in Safe Mode (Diagnose Firefox issues using Troubleshoot Mode) then disable hardware Acceleration Turning off hardware acceleration. Then start Firefox in normal mode and it should work fine.

從原來的回覆中察看解決方案 👍 4

所有回覆 (8)

more options

We're sorry to hear that your Firefox seems to be crashing when you open it. Please perform the following steps to give us a crash report ID that helps us find out more about the cause of the crash.

  1. Press the following shortcut to get a Run window: [Windows] + [R]. This should bring up a window that contains a text field.
  2. In that text field, enter %APPDATA% and press Enter. An explorer window should open.
  3. From that explorer window, double-click on the Mozilla folder, then double-click on Firefox and then on Crash reports. Double-click on submitted.
  4. Now, you should see a list of files that contain reports. Go to View > Arrange Icons by > Modified to get the most recent files at the top of the window.
  5. Open the most recent 5 files with a text editor and copy the IDs.
  6. Paste each ID with bp- into the reply window on the forums.

Thanks in advance!

You can find more information and troubleshooting steps in the Troubleshoot Firefox crashes (closing or quitting unexpectedly) article.

more options

To investigate further we need a couple of Crash IDs as explained under.

One thing changed by SafeMode is that hardware acceleration is turned off. It may be worth trying experimenting with hardware acceleration on and off, and also checking and updating your graphics drivers.



Standard Response

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash ID's to help us learn more about your crash.

  1. Enter about:crashes in the address bar (that's where you enter your website URL) and press Enter. You should now see a list of submitted crash reports.
  2. Copy the 5 most recent crash ID's that you see in the crash report window and paste them into your response here.

Thank you for your cooperation!

More information and further troubleshooting steps can be found in the Troubleshoot Firefox crashes (closing or quitting unexpectedly) article.

more options

Hi these are the 5 most crash id's which are submitted from 3 april
Crash-ID: bp-bc751aed-e786-4eaa-8fa2-9c93e2130403
Crash-ID: bp-cc6a71a4-3130-46d5-ad80-7a5332130403
Crash-ID: bp-638ff2b7-42f9-4fa9-a2a8-9cf7b2130403
Crash-ID: bp-648324e2-afe7-43b2-9c3c-c159f2130403
Crash-ID: bp-1dc6c183-bc7d-481b-9524-3abde2130403
greetings
Dominique

由 cor-el 於 修改

more options

選擇的解決方法

Open Firefox in Safe Mode (Diagnose Firefox issues using Troubleshoot Mode) then disable hardware Acceleration Turning off hardware acceleration. Then start Firefox in normal mode and it should work fine.

more options

It could be worth trying up dating your graphics drivers.


Note some recently released drivers:

Nvidia released GeForce 314.22 WHQL drivers.

http://www.nvidia.com/object/win8-win7-winvista-32bit-314.22-whql-driver.html

http://www.nvidia.com/object/win8-win7-winvista-64bit-314.22-whql-driver.html

Notebook drivers http://www.nvidia.com/object/notebook-win8-win7-314.22-whql-driver.html

http://www.nvidia.com/object/notebook-win8-win7-64bit-314.22-whql-driver.html


For forum cross referencing purposes

  • Report for CrashID bp-bc751aed-e786-4eaa-8fa2-9c93e2130403
    • Crash Signature: RtlpAllocateHeap | RtlpAllocateHeap | CContext::RestorePipelineStateImpl<int>(SAPIPipelineState*)
    • Related Bug 812683 NEW --- [Win7] startup crash in _d2d_clear_surface @ CContext::RestorePipelineStateImpl (d3d11.dll, after installing KB2670838)
more options

Hi Thx a lot for all your replies. The solution from Tylerdowner worked "disable hardware Acceleration Turning off hardware acceleration. Then start Firefox in normal mode and it should work fine. thx a lot for all your responses

more options

Updating graphics drivers doesn't solve this particular crash as it's caused by a Windows update to Direct2D

more options

Hi Tyler,

Updating graphics drivers doesn't solve this particular crash as it's caused by a Windows update to Direct2D 

I am sure you looked at it in detail, but I did not think it was that clearcut

It seemed to me from the d2d bug discussion as if graphics drivers may be a factor in at least some instances.

and that an alternative workaround would be removing the MS update instead of turning off hardware acceleration