X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox 18.0 is too slow

已張貼

Not really a question, more of a plea...

Firefox 18.0 crawls on my machine. Not the browsing as such; that's only a little slower than 17.0.1 (still noticeable). I'm talking about opening and traversing menus and entering text in text fields on sites. I had to go back to 17.0.1 as it was just too annoying. This is on Linux Mint Debian Edition (Debian Testing), using the nl localized Firefox downloaded from the Mozilla site. Switching off extensions and/or using a new profile didn't help. If this doesn't get any better in following versions, I'll have to look for another browser when 17.0.1 becomes too old. Please don't make me do that. I've just tried Chrome and quite frankly, it's a bit of a joke...

Not really a question, more of a plea... Firefox 18.0 crawls on my machine. Not the browsing as such; that's only a little slower than 17.0.1 (still noticeable). I'm talking about opening and traversing menus and entering text in text fields on sites. I had to go back to 17.0.1 as it was just too annoying. This is on Linux Mint Debian Edition (Debian Testing), using the nl localized Firefox downloaded from the Mozilla site. Switching off extensions and/or using a new profile didn't help. If this doesn't get any better in following versions, I'll have to look for another browser when 17.0.1 becomes too old. Please don't make me do that. I've just tried Chrome and quite frankly, it's a bit of a joke...

被選擇的解決方法

it should be fixed in firefox 19 which is going to be released on tuesday feb.19. if you'd like you can also test it right now by switching to the beta version: https://www.mozilla.org/firefox/channel/

edit: and just for reference, this appears to be bug #832641 (please don't post in bug reports)

從原來的回覆中察看解決方案 2

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.2 r202
  • This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • Gecko Media Player 1.0.6Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer
  • The Totem 3.0.1 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233

應用程式

  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0

更多資訊

adampeebleswrites 1 個解決方法 14 個答案

Hello grizzler,

Try to Turn off hardware acceleration, and check it again (in safe mode hardware acceleration is disable).

Try to Change the home page Try to Change how windows and tabs are loaded Try to Check your antivirus software

Please let us know if any of these tips solve your problem

Thank you

Hello grizzler, Try to [[Turn off hardware acceleration]], and check it again (in safe mode hardware acceleration is disable). Try to [[Change the home page]] Try to [[Change how windows and tabs are loaded]] Try to [[Check your antivirus software]] Please let us know if any of these tips solve your problem Thank you

提出問題者

Makes no difference, I'm afraid.

Makes no difference, I'm afraid.
cor-el
  • Top 10 Contributor
  • Moderator
17473 個解決方法 157940 個答案

A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program. Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process. See: *https://support.mozilla.org/kb/Server+not+found *https://support.mozilla.org/kb/Firewalls ---- Create a new profile as a test to check if your current profile is causing the problems. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

提出問題者

Look at my original post. A new profile has already been tried. And even though I fail to see how disabling the firewall could affect building and traversing Firefox's menus (which is where the slowness is most annoying), I switched off iptables just to be sure. No change of course.

Look at my original post. A new profile has already been tried. And even though I fail to see how disabling the firewall could affect building and traversing Firefox's menus (which is where the slowness is most annoying), I switched off iptables just to be sure. No change of course.
cor-el
  • Top 10 Contributor
  • Moderator
17473 個解決方法 157940 個答案

Sorry about those suggestions. I appear to have missed that you are on Linux.

Any luck with disabling IPv6?

Sorry about those suggestions. I appear to have missed that you are on Linux. Any luck with disabling IPv6? *http://kb.mozillazine.org/Error_loading_websites *http://kb.mozillazine.org/Error_loading_websites#IPv6

提出問題者

The setting network.dns.disableIPv6 has been set to true for ages.

The setting network.dns.disableIPv6 has been set to true for ages.

提出問題者

It's JavaScript/Flash. I just tried 18.0.1 and it seemed acceptable at first. But after the first Flash movie the same slowness crept in (bookmark menu taking seconds to open, traversing the menu with the highlighted item lagging up to five items behind the mouse pointer). Could be that new JavaScript engine is broken in some way or simply requires much more 'horse power'. Back to 17...

It's JavaScript/Flash. I just tried 18.0.1 and it seemed acceptable at first. But after the first Flash movie the same slowness crept in (bookmark menu taking seconds to open, traversing the menu with the highlighted item lagging up to five items behind the mouse pointer). Could be that new JavaScript engine is broken in some way or simply requires much more 'horse power'. Back to 17...

由 grizzler 於 修改

philipp
  • Top 25 Contributor
  • Moderator
5306 個解決方法 23424 個答案

hello, maybe it's an issue with the protected mode in the flash plugin - you could try if downgrading to flash 10.3 (which is still supported) or disabling protected mode makes a difference.

hello, maybe it's an issue with the protected mode in the flash plugin - you could try if [https://support.mozilla.org/en-US/kb/flash-113-crashes#w_solution-2-downgrade-to-flash-10-3 downgrading to flash 10.3] (which is still supported) or [http://forums.adobe.com/thread/1018071#TemporaryWorkaround disabling protected mode] makes a difference.

提出問題者

Downgrading didn't make any difference and neither did disabling protected mode (assuming adding the command mentioned to /etc/adobe/mms.cgf did the trick).

Thanks for your suggestions anyway.

Downgrading didn't make any difference and neither did disabling protected mode (assuming adding the command mentioned to /etc/adobe/mms.cgf did the trick). Thanks for your suggestions anyway.
bmullan 0 個解決方法 5 個答案

I have same problem, firefox 17 was fine, firefox 18 crawls on my Ubuntu 12.10 system. On many actions. At first I thought I was having DNS issues. But now see that many others are reporting same slow response.

Enter a URL and it takes forever to respond with the web page.

Click on a field to enter some kind of data and it can take 5-10 seconds before the keystrokes appear in the web form.

Sometimes my system's display actually dims briefly waiting for responses.

Chrome has NO problems like this on the same system.

I guess I'll downgrade back to v17 Firefox until I see some indication the current v18 problem(s) are resolved.

I have same problem, firefox 17 was fine, firefox 18 crawls on my Ubuntu 12.10 system. On many actions. At first I thought I was having DNS issues. But now see that many others are reporting same slow response. Enter a URL and it takes forever to respond with the web page. Click on a field to enter some kind of data and it can take 5-10 seconds before the keystrokes appear in the web form. Sometimes my system's display actually dims briefly waiting for responses. Chrome has NO problems like this on the same system. I guess I'll downgrade back to v17 Firefox until I see some indication the current v18 problem(s) are resolved.
Audix_Dude 0 個解決方法 4 個答案

I too have this problem, and it is only since the update. no other setting has changed on my PC. I am running Win XP32 on this PC.

It is infuriating to the point of thinking about the I word (Internet Explorer)

I too have this problem, and it is only since the update. no other setting has changed on my PC. I am running Win XP32 on this PC. It is infuriating to the point of thinking about the '''I''' word (Internet Explorer)

由 Audix_Dude 於 修改

bmullan 0 個解決方法 5 個答案

I should state that I see the same "slowness" on Windows so this is NOT a Firefox on LInux problem... at least from what I can see from multiple machines I use that are a mix of firefox on windows or linux.

I should state that I see the same "slowness" on Windows so this is NOT a Firefox on LInux problem... at least from what I can see from multiple machines I use that are a mix of firefox on windows or linux.

提出問題者

I am more than a little annoyed to find this thread somehow got marked as 'solved'. Apparently the reply by madperson was entered as 'chosen solution'. I did NOT do that and I have removed this 'solution' as this issue is by no means solved!

I am more than a little annoyed to find this thread somehow got marked as 'solved'. Apparently the reply by madperson was entered as 'chosen solution'. I did NOT do that and I have removed this 'solution' as this issue is by no means solved!
cor-el
  • Top 10 Contributor
  • Moderator
17473 個解決方法 157940 個答案

You did try a clean profile with out modifications and not by using a reset?
A reset still tries to import some data from the old profile and can cause problems.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

You did try a clean profile with out modifications and not by using a reset?<br /> A reset still tries to import some data from the old profile and can cause problems. ---- Create a new profile as a test to check if your current profile is causing the problems. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox
Inc0gnit0 0 個解決方法 3 個答案

There is definitely something wrong with the Menu / Bookmark code. After "upgrading" to 18.0 the Bookmarks menu became incredibly slow. I find it's pretty easy to replicate this issue: All you have to do is open the Bookmarks menu and navigate around for a bit - you don't even have to open anything. After a while the Bookmarks menu will take 3 seconds to open and also there is a ton of lag when you're navigating around the bookmarks - IOW the highlighted selection is nowhere near where the mouse is and it takes a while for it to catch up. It even does this in Safe Mode so it's definitely not related to any plug-in. I hate to say it, but it might be time to start using Google Chrome full-time... My coworkers and I already have to use it (Chrome) at work due to the heavy use of JavaScript with the tools we use and FF is just too slow in comparison.

There is definitely something wrong with the Menu / Bookmark code. After "upgrading" to 18.0 the Bookmarks menu became incredibly slow. I find it's pretty easy to replicate this issue: All you have to do is open the Bookmarks menu and navigate around for a bit - you don't even have to open anything. After a while the Bookmarks menu will take 3 seconds to open and also there is a ton of lag when you're navigating around the bookmarks - IOW the highlighted selection is nowhere near where the mouse is and it takes a while for it to catch up. It even does this in Safe Mode so it's definitely not related to any plug-in. I hate to say it, but it might be time to start using Google Chrome full-time... My coworkers and I already have to use it (Chrome) at work due to the heavy use of JavaScript with the tools we use and FF is just too slow in comparison.
cor-el
  • Top 10 Contributor
  • Moderator
17473 個解決方法 157940 個答案

Hi Inc0gnit0

Did you try to delete the places.sqlite database file?

You can check for problems with the places.sqlite database file in the Firefox Profile Folder.

Hi Inc0gnit0 Did you try to delete the places.sqlite database file? You can check for problems with the places.sqlite database file in the Firefox Profile Folder. *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file
troyengel 0 個解決方法 1 個答案

有幫助的回覆

It's definitely Firefox 18.0 that's broken, not our profiles. Fedora 17 64bit here - all I have to do is start Firefox, go to Pandora and let it play and my Bookmarks/menus get stupid slow. I tried every suggestion under the sun (listed here and Googling), nothing helped.

All I had to do was go get the older 17.0.1 RPMs from koji.fedoraproject.org, do a quick downgrade and boom - everything is fast again. No other changes, it's that easy and quick to get rid of this problem.

rpm -Uhv --oldpackage firefox-17.0.1-1.fc17.x86_64.rpm xulrunner-17.0.1-3.fc17.x86_64.rpm

Now everything is back to normal and I've blacklisted the upgrade until someone at Mozilla figures out what they broke and fixes it.

It's definitely Firefox 18.0 that's broken, not our profiles. Fedora 17 64bit here - all I have to do is start Firefox, go to Pandora and let it play and my Bookmarks/menus get stupid slow. I tried every suggestion under the sun (listed here and Googling), nothing helped. All I had to do was go get the older 17.0.1 RPMs from koji.fedoraproject.org, do a quick downgrade and boom - everything is fast again. No other changes, it's that easy and quick to get rid of this problem. rpm -Uhv --oldpackage firefox-17.0.1-1.fc17.x86_64.rpm xulrunner-17.0.1-3.fc17.x86_64.rpm Now everything is back to normal and I've blacklisted the upgrade until someone at Mozilla figures out what they broke and fixes it.
The_Pirate 0 個解決方法 4 個答案

I have the same problem: Firefox 18.0.1 on a Ubuntu 10.04 has gone incredibly slow. _ONLY_ system change: upgrade to 18.0.1.

The system (2.4GHz single cpu, 1Gb RAM) goes from about 2% CPU load to 100% as soon as i click on 'bookmarks'. The response time on a bookmark is between 3 seconds on a freshly started browser, up to 20 sek at 100% CPU load, when the browser have been in operation for roughly an hour+ Memory use remain unchainged around 400Mb.

Sorry lads, i guess this lemon belongs in your lap. I am an absolutely abysmal programmer, so i cannot look into the code myself.

I have the same problem: Firefox 18.0.1 on a Ubuntu 10.04 has gone incredibly slow. _ONLY_ system change: upgrade to 18.0.1. The system (2.4GHz single cpu, 1Gb RAM) goes from about 2% CPU load to 100% as soon as i click on 'bookmarks'. The response time on a bookmark is between 3 seconds on a freshly started browser, up to 20 sek at 100% CPU load, when the browser have been in operation for roughly an hour+ Memory use remain unchainged around 400Mb. Sorry lads, i guess this lemon belongs in your lap. I am an absolutely abysmal programmer, so i cannot look into the code myself.

有幫助的回覆

Just tried 18.0.2 and like 18.0.1 it seemed to be a little less slow at first, but as soon as I started to do some serious browsing and opening bookmark (sub)menus, it started to crawl again. And I'm still running with only a minimal add-on set-up. So, still broken... :(

Just tried 18.0.2 and like 18.0.1 it seemed to be a little less slow at first, but as soon as I started to do some serious browsing and opening bookmark (sub)menus, it started to crawl again. And I'm still running with only a minimal add-on set-up. So, still broken... :(
Inc0gnit0 0 個解決方法 3 個答案

Confirmed. 18.0.2 has the same issue.

Confirmed. 18.0.2 has the same issue.