X
點擊此處開啟此網站的行動版。

技術支援討論區

speedtest on firefox is slower than a speedtest on internet explorer i'm talking the halve slower...

已張貼

when i do a speedtest on speedtest.net i should see a speed result of above 100 mbit cause my connection is 120 mbit down

in firefox its always halve like 50 mbit max and in internet explorer it shows the correct speed...

before i never had problems with firefox but with the new updates not...

when i do a speedtest on speedtest.net i should see a speed result of above 100 mbit cause my connection is 120 mbit down in firefox its always halve like 50 mbit max and in internet explorer it shows the correct speed... before i never had problems with firefox but with the new updates not...

被選擇的解決方法

speedtest uses flash for speed measurements & adobe has introduced a special protected mode for its flash plugin only for firefox, which might cause slowdowns when there is interference between the following processes (so you might not observe it on IE or other browsers): firefox.exe, plugin-container.exe & FlashPlayerPlugin_11*.exe - please make sure that norton's firewall or av-engine isn't blocking/sandboxing them in any way.

alternatively you can also try disabling the protected mode for adobe flash & see if this is making a difference...

從原來的回覆中察看解決方案 2

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • Windows Activation Technologies Plugin for Mozilla
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • 4.1.10329.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp
  • Yahoo! activeX Plug-in Bridge

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

更多資訊

iamjayakumars 493 個解決方法 5983 個答案

Update your firefox to Firefox 18 and check it out...

Update your firefox to Firefox 18 and check it out...

提出問題者

there's a slight improvement but when i test it more than 1 times sometimes its back to unstabile, and in iE it stays stabile.

there's a slight improvement but when i test it more than 1 times sometimes its back to unstabile, and in iE it stays stabile.

由 broken 於 修改

philipp
  • Top 25 Contributor
  • Moderator
5330 個解決方法 23536 個答案

hello, could you tell us which kind of security software is running on your pc?

hello, could you tell us which kind of security software is running on your pc?

提出問題者

norton internet security 2013

norton internet security 2013

提出問題者

Its really hard to get an accurate speed test meeting in firefox always shows 60 Mbit and in IE it always goes way over 100Mbit...

When i tested it 5 times with the new firefox version 18 out of 5 imes it went 1 time over 100Mbit which was a good result of the speedtest. But now its showing way lower agin... Likz 50 , 60 Mbit

And if i test it 10 times with IE i get overal the same results.


I also noticed the flashplayer from http://www.speedtest.net/ is like hanging its not fluid at all and i updated that aswell..

Just tested it the flashplayer with the speedtest in IE and agin stabile as hell... Nothing like the problems FF is showing me.

Its really hard to get an accurate speed test meeting in firefox always shows 60 Mbit and in IE it always goes way over 100Mbit... When i tested it 5 times with the new firefox version 18 out of 5 imes it went 1 time over 100Mbit which was a good result of the speedtest. But now its showing way lower agin... Likz 50 , 60 Mbit And if i test it 10 times with IE i get overal the same results. I also noticed the flashplayer from http://www.speedtest.net/ is like hanging its not fluid at all and i updated that aswell.. Just tested it the flashplayer with the speedtest in IE and agin stabile as hell... Nothing like the problems FF is showing me.

由 broken 於 修改

philipp
  • Top 25 Contributor
  • Moderator
5330 個解決方法 23536 個答案

選擇的解決方法

speedtest uses flash for speed measurements & adobe has introduced a special protected mode for its flash plugin only for firefox, which might cause slowdowns when there is interference between the following processes (so you might not observe it on IE or other browsers): firefox.exe, plugin-container.exe & FlashPlayerPlugin_11*.exe - please make sure that norton's firewall or av-engine isn't blocking/sandboxing them in any way.

alternatively you can also try disabling the protected mode for adobe flash & see if this is making a difference...

speedtest uses flash for speed measurements & adobe has introduced a special protected mode for its flash plugin only for firefox, which might cause slowdowns when there is interference between the following processes (so you might not observe it on IE or other browsers): firefox.exe, plugin-container.exe & FlashPlayerPlugin_11*.exe - please make sure that norton's firewall or av-engine isn't blocking/sandboxing them in any way. alternatively you can also try [http://forums.adobe.com/thread/1018071#TemporaryWorkaround disabling the protected mode for adobe flash] & see if this is making a difference...

提出問題者

Well @madperson your trick solved the problem i had for ages... With the flashplayer on ProtectedMode=0 it works like a charm. Now my question is do i have to leave the flashplayer like this? on ProtectedMode=0?

Well @madperson your trick solved the problem i had for ages... With the flashplayer on ProtectedMode=0 it works like a charm. Now my question is do i have to leave the flashplayer like this? on ProtectedMode=0?
John99 971 個解決方法 13138 個答案

Hi broken,

In light of your post above I have taken the liberty of marking the thread solved with madperson's answer.

Unfortunately Firefox (Windows) has been having problems with protected mode and FlashPlayer for some months now. Turning off protected mode is not ideal, and some users find it a rather difficult procedure, but until and unless a permanent fix is available from Adobe FlashPlayer then it may be necessary to turn off protected mode.

You could also consider speeding things up by not using FlashPlayer unnecessarily, maybe considering something like no-script to block unwanted instances. (The click to play feature may also be useful https://blog.mozilla.org/security/2012/10/11/click-to-play-plugins-blocklist-style/ )

Hi broken, In light of your post above I have taken the liberty of marking the thread solved with madperson's answer. Unfortunately Firefox (Windows) has been having problems with protected mode and FlashPlayer for some months now. Turning off protected mode is not ideal, and some users find it a rather difficult procedure, but until and unless a permanent fix is available from Adobe FlashPlayer then it may be necessary to turn off protected mode. You could also consider speeding things up by not using FlashPlayer unnecessarily, maybe considering something like no-script to block unwanted instances. (The click to play feature may also be useful https://blog.mozilla.org/security/2012/10/11/click-to-play-plugins-blocklist-style/ )
philipp
  • Top 25 Contributor
  • Moderator
5330 個解決方法 23536 個答案

unfortunately this is most probably influenced by external factors so mozilla can't do much about addressing the issue...

i'm not familiar with norton's software, but we had reports that other security software (old versions of f-secure) did intefere with the flash protected mode and cause cause slowdowns when a function named "enhanced process monitoring" was enabled.

you might want to try setting ProtectedMode=1 again and experiment with your norton settings - in case there is an options to whitelist certain applications from in-depth scanning/sand-boxing/etc please add firefox.exe, plugin-container.exe (located in the mozilla firefox program folder) & FlashPlayerPlugin_11*.exe (located in C:\Windows\SysWOW64\Macromed\Flash) to this list.

unfortunately this is most probably influenced by external factors so mozilla can't do much about addressing the issue... i'm not familiar with norton's software, but we had reports that other security software (old versions of f-secure) did intefere with the flash protected mode and cause cause slowdowns when a function named "enhanced process monitoring" was enabled. you might want to try setting ProtectedMode=1 again and experiment with your norton settings - in case there is an options to whitelist certain applications from in-depth scanning/sand-boxing/etc please add firefox.exe, plugin-container.exe (located in the mozilla firefox program folder) & FlashPlayerPlugin_11*.exe (located in C:\Windows\SysWOW64\Macromed\Flash) to this list.

提出問題者

But what does protected mode 0 do can it be harmfull if i leave it like this?

What can happen?

But what does protected mode 0 do can it be harmfull if i leave it like this? What can happen?
philipp
  • Top 25 Contributor
  • Moderator
5330 個解決方法 23536 個答案

protected mode is an additional security measure introduced by adobe 6 months ago that makes flash content run in a container with low rights to make it harder for malicious code to infect other parts of the system...

for more technical details on it see http://blogs.adobe.com/asset/2012/06/inside-flash-player-protected-mode-for-firefox.html

protected mode is an additional security measure introduced by adobe 6 months ago that makes flash content run in a container with low rights to make it harder for malicious code to infect other parts of the system... for more technical details on it see http://blogs.adobe.com/asset/2012/06/inside-flash-player-protected-mode-for-firefox.html

提出問題者

I'll leave it like this than, thanks to all the people who helped and replyd.

Thank u.

I'll leave it like this than, thanks to all the people who helped and replyd. Thank u.
PeterB1970 0 個解決方法 5 個答案

I had this problem to since 11.3 came out. 11.2 worked fine. As the op said, ie was fine and ff results on speedtest.net were half speed, all over the place, choppy and unreliable. I have just turned protected mode to 0 and it's same as ie now, nice and smooth and 127Mbit down, nice and steady.

Here is a video I found that demonstrates the problem I had.

I have microsoft security essentials. Disabling didn't do anything.

Here is a strange thing though, I was using fraps (screeen recorder) to record what happens when I upgraded flash to a version higher than 11.2 and while fraps is running, the speedtest.net result was fine, just like ie. Exit Fraps and the problem returns. Q) what is Fraps doing to make flash work in protected mode?

I had this problem to since 11.3 came out. 11.2 worked fine. As the op said, ie was fine and ff results on speedtest.net were half speed, all over the place, choppy and unreliable. I have just turned protected mode to 0 and it's same as ie now, nice and smooth and 127Mbit down, nice and steady. [http://www.youtube.com/watch?v=n7B2nuBqdbA Here is a video] I found that demonstrates the problem I had. I have microsoft security essentials. Disabling didn't do anything. Here is a strange thing though, I was using fraps (screeen recorder) to record what happens when I upgraded flash to a version higher than 11.2 and while fraps is running, the speedtest.net result was fine, just like ie. Exit Fraps and the problem returns. Q) what is Fraps doing to make flash work in protected mode?

由 PeterB1970 於 修改

提出問題者

How do i disable this please care to explain :p

protected mode to 0 ?
How do i disable this please care to explain :p protected mode to 0 ?
PeterB1970 0 個解決方法 5 個答案

Hi Broken, I thought you already knew how to do this when you replied to madperson. "Well @madperson your trick solved the problem i had for ages... With the flashplayer on ProtectedMode=0 it works like a charm"

To disable Protected Mode, add the following line to your mms.cfg file located in:

Windows 32bit: C:\windows\system32\macromed\flash

Windows 64bit: C:\windows\syswow64\macromed\flash

ProtectedMode=0

Hi Broken, I thought you already knew how to do this when you replied to madperson. "Well @madperson your trick solved the problem i had for ages... With the flashplayer on ProtectedMode=0 it works like a charm" To disable Protected Mode, add the following line to your mms.cfg file located in: Windows 32bit: C:\windows\system32\macromed\flash Windows 64bit: C:\windows\syswow64\macromed\flash ProtectedMode=0

由 PeterB1970 於 修改

提出問題者

Nope didn't know thanks man :)

Nope didn't know thanks man :)

提出問題者

Btw what i always did was disable hardware acceleration in firefox, doesn't help either though. i'll try your method, thanks.

Btw what i always did was disable hardware acceleration in firefox, doesn't help either though. i'll try your method, thanks.

提出問題者

I have no mms.cfg file in there... Just dll's and uninstallers and plugins.

I have no mms.cfg file in there... Just dll's and uninstallers and plugins.
PeterB1970 0 個解決方法 5 個答案

Create one using notepad. If you can't see file extensions, (i'm using vista)

Start > Settings > Control Panel > Folder Options > View Tab >

Uncheck 'hide extensions for known file types'

Then rename your .txt to .cfg

Create one using notepad. If you can't see file extensions, (i'm using vista) Start > Settings > Control Panel > Folder Options > View Tab > Uncheck 'hide extensions for known file types' Then rename your .txt to .cfg

由 PeterB1970 於 修改

提出問題者

You edited previous link for the folder Peter cause now i see the textfile, thanks :D

You edited previous link for the folder Peter cause now i see the textfile, thanks :D

由 broken 於 修改