搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 18 crashes

  • 34 回覆
  • 89 有這個問題
  • 7213 次檢視
  • 最近回覆由 oneofj

more options

I love Firefox. On my laptop ( ASUS UX32VD-DB71 ) Firefox auto updated from 17.0.1 to 18.0 and the stability is very poor. Crash occurs nearly immediately or a few seconds after launch every time. Adblock plus is the only addon and disabling it makes no difference. Although, Firefox 18 Safe mode does work without crashing, interestingly. I uninstalled and downgraded back to 17.0.1 and full stability is back. Version 18 and 18.0.1 are not ready in my opinion. I have not tried using a fresh profile.

UPDATE: FireFox 18.0.1 is also buggy and broken.

bp-e351a168-5b5c-4dcc-a7fa-1e2692130119 1/19/2013 4:45 PM

bp-de4730b6-4a16-4728-9674-1f6f52130119 1/19/2013 4:45 PM

bp-ce743869-bb12-4242-b125-994592130119 1/19/2013 4:44 PM


bp-c93e7c32-306a-401d-843e-3a0842130110 1/10/2013 4:56 AM

bp-5f76093c-9cbd-43f3-8067-2bad02130110 1/10/2013 4:56 AM

bp-cf23a9cd-969f-4f83-9d33-f6b832130110 1/10/2013 4:52 AM

bp-177717c4-bf27-44d5-9c93-cda9f2130110 1/10/2013 3:22 AM

bp-81a0d800-185e-4371-a9a7-224d42130109 1/9/2013 1:20 PM

bp-3c3aa8dd-45e7-4f00-b24d-1d92f2130108 1/8/2013 2:46 PM

bp-fabe18ff-27d3-4d90-b417-9ebf02130108 1/8/2013 2:41 PM

bp-30b367e9-3fd0-454b-b5a1-49fbd2130108 1/8/2013 2:30 PM

bp-8755acb5-67cc-40c6-9cf0-44e492130108 1/8/2013 2:30 PM

由 bluetickle 於 修改

被選擇的解決方法

Crash after crash... Hardware acceleration disabling doesnt solve. Please can U tell me how I can prevent auto-update to 18 version ? Thank you... about:crashes

bp-44eea239-cddd-4767-a1e8-b06442130111 11. 1. 20138:05f638e2f1-3839-45ce-a69b-e8b3fca5c9ea 11. 1. 20137:48c2a4e6f3-50f0-487c-9538-f6d8c148be5e 10. 1. 20139:12

從原來的回覆中察看解決方案 👍 2

所有回覆 (20)

more options

hello luetickle, could you provide some crash-ids? this would help us understand what's going on...

---

  1. Enter about:crashes in the Firefox location bar (that's where you enter your website names) and press Enter. You should now see a list of submitted crash reports.
  2. Copy the most recent 5 report IDs that you see in the crash report window and paste them into your forum response.

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

more options

If Firefox is not crashing in Safe Mode, then this is likely either a problem with hardware acceleration or your profile, so not a Firefox 18 issue. Please update back to 18, then try to disable Hardware acceleration. Upgrade your graphics drivers to use hardware acceleration and WebGL or Turning off hardware acceleration

Also, try a Firefox Reset. Refresh Firefox - reset add-ons and settings and do you have the crash id? (go to about:crashes in the address bar, give me the id that starts with bp- that is from the time of the crash)

more options

bp-81a0d800-185e-4371-a9a7-224d42130109 1/9/2013 1:20 PM

bp-3c3aa8dd-45e7-4f00-b24d-1d92f2130108 1/8/2013 2:46 PM

bp-fabe18ff-27d3-4d90-b417-9ebf02130108 1/8/2013 2:41 PM

bp-30b367e9-3fd0-454b-b5a1-49fbd2130108 1/8/2013 2:30 PM

bp-8755acb5-67cc-40c6-9cf0-44e492130108 1/8/2013 2:30 PM

由 bluetickle 於 修改

more options

I have Win7-64 with a Nvidia GT 620m and Intel 4000 for graphics. Nvidia driver 306 is installed and it is the latest available at this time for this mobile graphics chip. I have specified in the Nvidia driver to have Firefox use Nvidia for acceleration.

Firefox 17.0.1 is perfectly stable with zero crashes with hardware acceleration enabled. I'm very happy with 17.0.1

I'll try the profile reset when I have a free moment.

Thanks for your help and feedback. :-)

more options

hello, the crash reports show an intel graphics driver crashing firefox (a reset probably won't help against that). please try to upgrade to the latest driver available from intel or else keep hardware acceleration disabled: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=22375&lang=eng&OSVersion=Windows%207%20%2864-bit%29*&DownloadType=Drivers

more options

Surely you shouldn't have both drivers installed? Unless there's some new wizardry that lets you use both graphics chips at the same time.

more options

Hi!

I was having the same problem here and I got resolve it by editing the homepage option. I used the homepage as a 'blank page' or about:blank and that was causing the problem.

I suggest you open Firefox with the Safe Mode option, go to Edit - Preferences - Home Page and in the text field report any website. Close Firefox and reopen it without the Safe Mode option. Here it worked!

more options

Reply to yalam96,

It's a little laptop by ASUS with NVIDIA Optimus automatic graphics switching.

http://www.nvidia.com/object/optimus_technology.html

由 bluetickle 於 修改

more options

Reply to madperson,

Hey thanks, my Intel video driver is old... It's dated 5-21-2012.

The one you linked to is newer and dated 12-18-2012.

I'll try that...

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=22375&lang=eng&OSVersion=Windows%207%20%2864-bit%29*&DownloadType=Drivers

Still not working.

Intel 4000 driver 9-26-2012 and FireFox 18 = immediate crash

Intel 4000 driver ( 9.17.10.2932 ) 12-12-2012 and FireFox 18 = immediate crash


bp-81a0d800-185e-4371-a9a7-224d42130109 1/9/2013 1:20 PM


Safe mode and/or disabling hardware acceleration allows FireFox 18 to function without crashing...

I think I'll be going back to FireFox 17.0.1 for now where hardware acceleration does work.

由 bluetickle 於 修改

more options

I am not especially computer savvy and I am totally confused by this updating graphics drivers to resolve the crashing problem. I have located a list of drivers on the Dell website, but have no idea which driver, if any, is the correct one for my laptop. I'm not even sure which of the listed drivers is for graphics. How do I find out what driver I currently have? How do I figure out which driver is the right one for my PC?

Since I couldn't understand what to do on the Dell site, I tried the NVIDIA generic driver. But I can't select a driver manually since I don't know which graphics card I have and I can't use their automatic thing because it requires the latest version of Java. And when I go to the Java site I have no idea which Java thing is the correct one to use.

Basically I am completely lost. Help!!!!!

more options

After several hours of fighting my way through the Dell, NVIDIA and Java websites I have not been able to find a more recent driver for my graphics card. And I have found that the latest version of Java will not work on my PC.

I have turned off hardware acceleration and disabled WebGL (whatever that is), then reinstalled 18. So far it hasn't crashed. Fingers crossed.

Spoke too soon. 18 still hangs up. I am back to 17.0.

由 woollymammoth 於 修改

more options

After upgraded to 18, crash almost every few seconds, rendering it unusable. As for 17.x, no crash even running for several days.
My graphics driver is the latest nvidia 310.90.
Following are crashes submitted:

bp-c12a3092-1552-4117-b265-62d792130109
bp-fc11d300-d852-402a-b146-df5922130108

both of which are backtraced to DrawWindow()

由 cor-el 於 修改

more options

Try to disable hardware acceleration in Firefox.

more options

It's nothing to do with HW acceleration. Through some experiments, I finally found the addon `showcase' is the culprit, but by referring the `showcase' addon page, it's firefox bug that cause the crash.

Here's how to solve the crash: https://addons.mozilla.org/en-us/firefox/addon/showcase/reviews/345058/

This is the Firefox bug causing the crashes: https://bugzilla.mozilla.org/show_bug.cgi?id=614772

more options

second reply to madperson,

I've had some progress.

I can get FF18 to work with hardware acceleration enabled if I choose (Intel display) as the hardware to use for hardware acceleration in the nvidia control panel. This is with the updated Intel video driver.

Unfortunately Intel 4000 graphic performance is lacking and studders with HD video and I would really like to use the higher performing Nvidia GeForce GT 620M. I would especially need Nvidia for HD level YouTube and Netflix videos.

I can NOT get FF18 to work with hardware acceleration enabled if I choose (nVidia display) as the hardware to use for hardware acceleration in the nvidia control panel. FF18 hardware acceleration is non-functional using nVidia driver versions 306.97 from nvidia.com and 305.46 from asus.com on Geforce GT 620M. When I try to install version 310.90 from nVidia.com I get an error message that this driver is not compatible.


bp-c93e7c32-306a-401d-843e-3a0842130110 1/10/2013 4:56 AM

bp-5f76093c-9cbd-43f3-8067-2bad02130110 1/10/2013 4:56 AM

bp-cf23a9cd-969f-4f83-9d33-f6b832130110 1/10/2013 4:52 AM

bp-177717c4-bf27-44d5-9c93-cda9f2130110 1/10/2013 3:22 AM

more options

Crash after crash... Hardware acceleration disabling doesnt solve. Please can U tell me how I can prevent auto-update to 18 version ? Thank you...

about:crashes

bp-44eea239-cddd-4767-a1e8-b06442130111 11. 1. 20138:05f638e2f1-3839-45ce-a69b-e8b3fca5c9ea 11. 1. 20137:48c2a4e6f3-50f0-487c-9538-f6d8c148be5e 10. 1. 20139:12

more options

選擇的解決方法

Crash after crash... Hardware acceleration disabling doesnt solve. Please can U tell me how I can prevent auto-update to 18 version ? Thank you... about:crashes

bp-44eea239-cddd-4767-a1e8-b06442130111 11. 1. 20138:05f638e2f1-3839-45ce-a69b-e8b3fca5c9ea 11. 1. 20137:48c2a4e6f3-50f0-487c-9538-f6d8c148be5e 10. 1. 20139:12

more options
more options

Thank you !

more options

Same problem here, constant crashes with 18, both normal and safe mode. Reverted to 17.2 and all is good again. I am running win 8. It would not even get past the reset window without crashing a lot of the times

Here are the last 3 (out of about 30 since the upgrade) bp-228833c7-2152-4e41-85ee-11c47213011111/01/201319:02

bp-05f9bfbb-ac42-4435-9ebf-bf52d213011111/01/201319:01

bp-17a4f136-e711-4456-a3f0-31856213011111/01/201319:01

由 strumble 於 修改

  1. 1
  2. 2