搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Why does Forefox 17.0.1 not dislplay videos when Firefox16.0.2 does?

more options

I've got Firefox 17.0.1 running on a Solaris 10 SPARC system. (I know, Solaris is not supported, but perhaps someone has seen this problem elsewhere, e.g., with Linux.) Except for the video on the Welcome to Firefox page, videos appear black and will not play--no controls appear. (In one case, the video soundtrack would play, but not the picture.) I'm using Flash 11.2.202.223, the most recent version of FlashPlayer which will run on Solaris 10, and Java 1.7.0_10, the most recent version. The plugins appear normally in the Addons tool. Oddly, if I fall back to Firefox 16.0.2, the same videos play perfectly. The two Firefox versions are configured identically, with the same plugins (not just the same versions--they're linked to the same files). What gives? How can I get the later version of Firefox to behave?

Thank you for your assistance.

Ian H. Redmount

所有回覆 (2)

more options

Did you try the latest flash-plugin-10.3.183.48-release.i386.rpm to see if that version works?

more options

Thank you for considering my question. I have used Flash Player 10_3_183... in the past, although it did display some flaws. However, I am now using the most recent version of Flash Player which--according to Adobe--will run on Solaris 10, namely version 11_2r202_223. This works without crashing the browser, a statement not always applicable to earlier or later versions. But the point here is that the earlier version of Firefox, 16.0.2, displays videos correctly, while the later 17.0.1 does not, both versions using the same plugin (literally, the same libflashplayer.so file). Why would the later version of Firefox require an earlier version of Flash Player?

Thanks again for your help.

Ian H. Redmount