On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

搜尋 Mozilla 技術支援網站


Learn More

Java installed but not working

  • 45 回覆
  • 364 有這個問題
  • 19 次檢視
  • 最近回覆由 ChickenPants

more options

Hi, after updating to Java 7 update 10 Java stopped working. Plug in checker indicates Java Deployment Toolkit is installed correctly, but Java test page says plugin needed and Java Runtime Environment 1.7 u10 is available. Install fails. Uninstalled Java and tried manual install (including as administrator) but no resolution. All old Java versions have been uninstalled. Thank you for your time.

Hi, after updating to Java 7 update 10 Java stopped working. Plug in checker indicates Java Deployment Toolkit is installed correctly, but Java test page says plugin needed and Java Runtime Environment 1.7 u10 is available. Install fails. Uninstalled Java and tried manual install (including as administrator) but no resolution. All old Java versions have been uninstalled. Thank you for your time.

所有回覆 (20)

more options

Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

more options

All plugins are up to date. thanks

more options
more options

Followed instructions in above plugin troubleshooting link; 1) manual uninstall of Java 2) re-initalized data base 3) uninstalled Java from control panel 4) reinstall Java 5) plug in checker says Java Deployment Toolkit installed and up to date 6) Java.com test page "something is wrong. java not working" thanks

more options

The issue is not with Firefox but with a problem with the Java installer and the IsScript.msi on the user’s machine. The Java installer is updating or loading the Java Deployment Toolkit but not the Java ™ Platform SE 7 U10 plugin (you can confirm this by going to Tools => Add ons =>Add-ons Manager and see one but not the other)

1- Download the offline version of the Java installer file to your Desktop. Run the file with the command; javadownloadfile.exe /LV* %TEMP%\jreMSI.log (where javadownloadfile.exe is the name of the offline java installer file)

You will get a log file (reMSI.log) in your %Temp% file that should show one or both messages; ISSCRIPT_VERSION_MISSING = The InstallScript engine is missing from this machine. If available, please run ISScript.msi, or contact your support personnel for further assistance.

And/Or ISSCRIPT_VERSION_OLD = The InstallScript engine on this machine is older than the version required to run this setup. If available, please install the latest version of ISScript.msi, or contact your support personnel for further assistance.

2 - Go to link below to find the procedures to fix the issue for the update file you are running. http://consumerdocs.installshield.com/selfservice/viewContent.do?externalId=Q108158&sliceId=1

NOTE - If in doubt about version number for the update file just

Delete the folder C:\Program Files\Common Files\InstallShield\engine 

Run IkernelUpdate.exe found at http://consumerdocs.installshield.com/selfservice /viewContent.do?externalId=Q108158&sliceId=1

3 – Uninstall the Java version installed incorrectly by going to Control Panel => Programs and Features

4 – Re-run the javadownloadfile.exe by double clicking it from your Desk top.

5 – Confirm that Java ™ Platform SE 7 U10 plugin is now installed by going to Tools => Add ons =>Add-ons Manager

6 – Test that Java is now working thru the Java Website tester


由 jackcorncrib 於 修改

more options

Sorry about the lousy formatting. Also kernelUpdate.exe is available at http://consumerdocs.installshield.com/selfservice/viewContent.do?externalId=Q108158&sliceId=1

more options

I tried all the solutions here... updating InstallShield seemed promising, but didn't work for me. I found a solution that did work at http://support.mozilla.org/en-US/questions/937263?esab=a&s=Java+installed+but+not+working&r=3&as=s (editing the Windows registry MozillaPlugins subkey).

more options

You can also check for issues caused by an installed JavaFX program.

more options

I’ve tried everything short of messing around with the registry and can’t get Java working properly with Firefox, so have resorted to using IE for Java specific sites. Thanks all for the replies.

more options

Did you try to uninstall Java and all other Java components and only install the 32 Java JRE?

Do you have all required registry keys for the Java plugin in addition to the Java Deployment kit?

If Firefox doesn't find the Java plugin then it is possible that the Java installed didn't create the required registry key that Firefox checks to scan for plugins. 32 bit Windows:

  • HKLM\Software\MozillaPlugins\@java.com/JavaPlugin,version=10.xx.xx

64 bit Windows:

  • HKLM\Software\Wow6432Node\MozillaPlugins\@java.com/JavaPlugin,version=10.xx.xx
more options

This fixed it for me (32 bit windows) after installing Version 7 Update 10, but not seeing the plugin:

1) start regedit

2) navigate to HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins

3) right click, add New Key, name: @java.com/JavaPlugin,version=10.xx.xx

4) click on it, then right click and add new string value, name: path

5) right click, Modify, change value data to: C:\Program Files\Java\jre7\bin\plugin2\npjp2.dll [check if this is the right dll for your setup]

6) exit regedit

7) start FF

8) open champagne (hopefully)

more options

SOLVED for Windows x64: Firefox (32 bit) & Java 7 update 10 If you installed the 64 bit version of java you may need to install the 32 bit as well. Having successfully updated java to 7.10, Firefox reported that it was still using the old version and to update. I uninstalled the previous version and Firefox said I needed to install the new version which was installed and verified! Realizing I was running 32 bit Firefox I downloaded and installed the 7.10 32 bit version - voila, problem solved.

more options

I also am unable to get Firefox to recognize Java 7 version 10. When Java completes its installation, the software says install successful. However, there is no Java add-in under Firefox options. Java does NOT run.

Altered my registry per ScrumpyJoe's guideline above - but, Java 7 does not work. Would like to avoid a complete re-install of Firefox.

Looking forward to HTML5.

Any ideas, please?

由 stocktic 於 修改

more options

My 'SOLVED' only relates to the situation of installing the 64bit version of java 7U10 for use in a 32bit Firefox (which is what happened to me) - the 32bit java 7u10 is needed .

FWIW I'm running FF 18 and the results of testing (http://www.java.com/en/download/testjava.jsp) show this~ Version: Java SE7 Update 10 Operating System: Windows 7 6.1 Java architecture: 32-bit

more options

Java 7 Version 10 (32-bit manual download & install) is recognized as being present in Control Panel\Programs & Features. I can uninstall & reinstall Java which is recognized in Programs & Features section of the Control Panel. However, Firefox will not install the Plugin required to run Java. An alert pops up that a plugin is needed. I attempt to use the alert's plug in install feature but, no Java plug in is installed.

Yes, I have restarted Firefox and rebooted my computer. No Java plug in under Firefox.

more options

I need an use Java daily...fix this ASAP

more options

If you are using Firefox (FF) on Windows 64 bit, then FF is only available as 32-bit, so you need 32-bit Java installed (which will run alongside Java 64-bit if you are using that).

Alternatively, you can use Pale Moon 64-bit browser, http://www.palemoon.org/ , which is based on FF and this will work with 64-bit Java.

more options

p.s. There is a serious security alert for Java at the moment!

"All versions of Java 7 through update 10 are affected. Web browsers using the Java 7 plug-in are at high risk."


more options

I have both 32- and 64- bit versions installed...

more options

I have this problem as well. I have spent three hours uninstalling and reinstalling this crap to no success. I'm using Firefox 18 and have had no success with getting the Java 7.0.10 Runtime Environment to appear in my Firefox add-ons. This is beyond infuriating for the reason that I use this daily.

The registry hacks don't work;

The command line log file workaround does nothing;

Running 32bit and 64 bit simultaneously does nothing;

Downgrading to v9 of the Java does nothing;

Going to the Java control panel and attempting to force it to default to Mozilla Browsers does nothing.

As a result, I have done nothing in my attempts to remedy this disaster

ETA - the below screen shot shows that there is a check by default to set Java to use IE and not Mozilla. Firefox is my default browser, and the efforts to make a check mark stay in the box shown with the green arrows do not work - I run the Javlcpl (Java Control Panel and Admin), but it won't stick.

To say that this Java problem is a catastrophe is an understatement.

由 ChickenPants 於 修改

  1. 1
  2. 2
  3. 3