搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Awesomebar autocomplete buggy, annoying

  • 4 回覆
  • 1 有這個問題
  • 126 次檢視
  • 最近回覆由 Dadamam

more options

So, this is the problem. The url-bar (the "Awesomebar") predicts the website I'm typing and already puts it in there for me to enter.

The thing is, I mistyped a website once, for example:

instead of "www.youtube.com" I typed "www.yotube.com" (in this case, the website "yotube.com" doesn't exist)

now, every time I enter www.y it shows "yotube.com" in the Awesomebar and "youtube" in the dropdown right under it.

So the prediction is false, while the bookmark is the right website.

Which means that every time I type www.y - it shows www.yotube.com and I'm sent to the wrong website, having to add a 'u' every time. Even though the bookmark shows the correct website and the prediction doesn't.

Even if I delete history, "forget about this website", delete places.sqlite and do all that, it stays like that.

Here's a picture: http://i.imgur.com/RbEAx.jpg

所有回覆 (4)

more options

Hi,

You can also right-click and Toggle the key browser.urlbar.autoFill to false in about:config.

about:config Entries

The Config Descriptions add-on adds helpful source comments in about:config.

Also, if you manually choose the correct one for the next one or two times, then it will receive higher priority. So eventually you would get it right.

more options

Use these steps to remove saved (form) data from a drop down list:

  1. Click the (empty) input field on the web page to open the drop down list
  2. Highlight an entry in the drop down list
  3. Press the Delete key (on Mac: Shift+Delete) to remove it.
more options

Hi

I don't want to disable the autofill, and I don't want to delete the dropdown entry.

The dropdown entry is correct. There's no need to delete it. The prediction in the URL-bar is incorrect, and it needs to be deleted or changed. (check the image - dropdown says "ool" and prediction says "ol")

more options

Nevermind - I fixed it by disabling autofill and enabling it again.

Thanks.