X
點擊此處開啟此網站的行動版。

技術支援討論區

Constant JavaScript 'Syntax error' notification after upgrading to 17.0

已張貼

Almost at every page I open appears following notification 'Error: Syntax error' from JavaScript application. Even on this page where I fill the form. I have to click 'OK' several times to make it disappear.

Almost at every page I open appears following notification 'Error: Syntax error' from JavaScript application. Even on this page where I fill the form. I have to click 'OK' several times to make it disappear.

被選擇的解決方法

Same issue with latest upgrade. In Safe Mode removed SocialFixer. That fixed the problem.

從原來的回覆中察看解決方案 33

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.5 r502
  • VLC media player Web Plugin 2.0.2
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Provides additional functionality on Facebook. See our web site for details.
  • Version 1.0.5, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/
  • iTunes Detector Plug-in
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Office Plugin for Netscape Navigator

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/17.0 Firefox/17.0

更多資訊

geminisama 0 個解決方法 1 個答案

Getting the same errors, this is with and without extensions, and I made sure Java was up to date.

Getting the same errors, this is with and without extensions, and I made sure Java was up to date.

提出問題者

My Java is up to date too

My Java is up to date too

提出問題者

Guys, the problem is most likely with some of your plugins. I started FireFox in safe mode with all my plugins disabled (menu Help) and the problem with JavaScript syntax error disappeared.

Guys, the problem is most likely with some of your plugins. I started FireFox in safe mode with all my plugins disabled (menu Help) and the problem with JavaScript syntax error disappeared.
cor-el
  • Top 10 Contributor
  • Moderator
17472 個解決方法 157925 個答案

This issue can be caused by an extension that isn't working properly.
Another user has reported that the Social Fixer extension caused this issue.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
This issue can be caused by an extension that isn't working properly.<br /> Another user has reported that the Social Fixer extension caused this issue. Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do not click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
rfwinans 1 個解決方法 1 個答案

選擇的解決方法

Same issue with latest upgrade. In Safe Mode removed SocialFixer. That fixed the problem.

Same issue with latest upgrade. In Safe Mode removed SocialFixer. That fixed the problem.
MissM007 0 個解決方法 9 個答案

I have the same problem but it happens on pages that are not on facebook, (like pages on Oprah.com) which tells me its NOT socialfixer, or not JUST to do with socialfixer.

My java is also up-to-date.

I have the same problem but it happens on pages that are not on facebook, (like pages on Oprah.com) which tells me its NOT socialfixer, or not JUST to do with socialfixer. My java is also up-to-date.
DriftMGR 0 個解決方法 4 個答案

I was getting the Syntax Error (Javascript ap.) in Gmail (Start Page). After disabling Integrated Gmail 2.8.8, All back to normal !

I was getting the Syntax Error (Javascript ap.) in Gmail (Start Page). After disabling Integrated Gmail 2.8.8, All back to normal !
summertime 0 個解決方法 4 個答案

I still have the problem. Is there a way that Firefox can fix the problem from their end, for those of us who aren't that technically savvy?

I still have the problem. Is there a way that Firefox can fix the problem from their end, for those of us who aren't that technically savvy?
DriftMGR 0 個解決方法 4 個答案

I would like you to first try Safe Mode. Do not confuse this with Windows safe mode. Read here: https://support.mozilla.org/kb/Safe+Mode If you can operate your browser, you should be able to get into Safe Mode. Reading is knowledge, thus read the link first. Once you achieve Safe Mode, report back to us on the forum with your results. Good Luck!

I would like you to first try Safe Mode. Do not confuse this with Windows safe mode. Read here: https://support.mozilla.org/kb/Safe+Mode If you can operate your browser, you should be able to get into Safe Mode. Reading is knowledge, thus read the link first. Once you achieve Safe Mode, report back to us on the forum with your results. Good Luck!
summertime 0 個解決方法 4 個答案

Thanks, DriftMGR, for contacting me so quickly. I clicked the Restart Firefox button. Now everything looks very different, but happy to say that Error Message isn't popping up all the time anymore. May take a while to adjust to all the other changes, but I will manage. Thank you

Thanks, DriftMGR, for contacting me so quickly. I clicked the Restart Firefox button. Now everything looks very different, but happy to say that Error Message isn't popping up all the time anymore. May take a while to adjust to all the other changes, but I will manage. Thank you
MissM007 0 個解決方法 9 個答案

Ok, so it turns out that for me it really was socialfixer. There was an upgrade on Tuesday and I just found out about it today. All better for me.  :)

Ok, so it turns out that for me it really was socialfixer. There was an upgrade on Tuesday and I just found out about it today. All better for me. :)
summertime 0 個解決方法 4 個答案

Now my Adblock isn't working anymore. Groan. That has always been one of my favorite things about Fire Fox. No ads. Any advice on how to get Adblock working again?

Now my Adblock isn't working anymore. Groan. That has always been one of my favorite things about Fire Fox. No ads. Any advice on how to get Adblock working again?
cor-el
  • Top 10 Contributor
  • Moderator
17472 個解決方法 157925 個答案

Hi summertime

Try to ask advice at the Adblock Plus forum.

Hi summertime Try to ask advice at the Adblock Plus forum. *https://adblockplus.org/forum/
summertime 0 個解決方法 4 個答案

46 views and 0 answers on the Adblock Plus forum :-(

46 views and 0 answers on the Adblock Plus forum :-(
eyereader 0 個解決方法 1 個答案

有幫助的回覆

Social Fixer was the culprit in my case. The problem has been fixed in their version 7.3.

Social Fixer was the culprit in my case. The problem has been fixed in their version 7.3.
jeltz 0 個解決方法 1 個答案

Same problem (and solution) here with the syntax errors happening not only on facebook, but other sites like IMBD etc.

Social fixer was the problem and updating it resolved the issue, the version available via the Add-ons Manager is still the old one but the version available from the socialfixer.com is working fine.

@ summertime, FWIW I'm using ABP without issue.

Thanks people.

Same problem (and solution) here with the syntax errors happening not only on facebook, but other sites like IMBD etc. Social fixer was the problem and updating it resolved the issue, the version available via the Add-ons Manager is still the old one but the version available from the socialfixer.com is working fine. @ summertime, FWIW I'm using ABP without issue. Thanks people.

由 jeltz 於 修改

Nogueira13 0 個解決方法 4 個答案

I changed to Safe Mode and It solved the problem. But how can I discover wich plugin (or plugins) or extension is causing the problem? thanks in advance.

I changed to Safe Mode and It solved the problem. But how can I discover wich plugin (or plugins) or extension is causing the problem? thanks in advance.
DriftMGR 0 個解決方法 4 個答案

With all plug ins disabled, you can add them back one by one. Restart when needed. Continue this process until you find the non-compatible plug-in.

With all plug ins disabled, you can add them back one by one. Restart when needed. Continue this process until you find the non-compatible plug-in.
Nogueira13 0 個解決方法 4 個答案

Ok, and I discovered that the extension that was producing the error message was "Linkify (for Microsoft Lync) 1.0. I I excluded it and I didn't receive the error message longer. Thanks for the help. Very very thanks. Antonio Carlos.

Ok, and I discovered that the extension that was producing the error message was "Linkify (for Microsoft Lync) 1.0. I I excluded it and I didn't receive the error message longer. Thanks for the help. Very very thanks. Antonio Carlos.
Edzzed 0 個解決方法 2 個答案

google social fixer 7.3 and download it. fixed the problem for me as well.

google social fixer 7.3 and download it. fixed the problem for me as well.