搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

nav bar contains social site buttons that are supposed to show icons but only show text

  • 2 回覆
  • 1 有這個問題
  • 135 次檢視
  • 最近回覆由 cor-el

more options

I have been using firefox as my main development page for a new website. I am using WordPress 3.4.2 and custom theme called Thesis 1.8.5.

The main nav bar contains 8 buttons; 1 to my blog which is the home page and the other 7 to static pages. These buttons all justify to the left. The right end of the bar contains buttons to Twitter, Google+, Facebook, and Feedburner. The are (or were) linked to images; these buttons justify to the right.

Here is the code that makes this work:

http://diythemes.com/thesis/rtfm/replace-wp-menu-text-links-image-sprites/

They worked fine until yesterday when I made some design adjustments to the space between the left button. Now rather than display icons, the underlying text shows on the right justified buttons.

Now here is what is interesting. I also have Safari and Chrome on my system. The icons show up fine in both of the them.

I can't find any explanation or fixes for this problem.

I will provide the site URL but it is in Maintenance mode so won't show the problem.

Thanks for your help.

被選擇的解決方法

These screenshots of the firefox, chrome, and safari nav bars might help.

從原來的回覆中察看解決方案 👍 0

所有回覆 (2)

more options

選擇的解決方法

These screenshots of the firefox, chrome, and safari nav bars might help.

more options

We can't access that website to check this:

NicheBuilders is currently undergoing scheduled maintenance. Please try back in 25 days, 14 hours, and 9 minutes (on December 3, 2012 at 5:17 pm).

If images are missing then check that you aren't blocking images from some domains.

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

Make sure that you do not block third-party images, the permissions.default.image pref should be 1.

There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images.

See also:


A good place to ask advice about web development is at the MozillaZine "Web Development/Standards Evangelism" forum.

The helpers at that forum are more knowledgeable about web development issues.
You need to register at the MozillaZine forum site in order to post at that forum.