搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How can I prevent the open/save file confirmation window popup ? Mine is currently set for "always do this action" but I still get the popup.

  • 2 回覆
  • 9 有這個問題
  • 386 次檢視
  • 最近回覆由 Mikal_Drey

more options

Whenever I "export" a QIF file from my bank I get a File Action confirmation window popup. I have the correct application selected and I have it selected to "open" and "always do this action" but the popup always pops.

I have checked the applications tab and the correct application is selected.

How can I prevent the confirmation popup window please ?

所有回覆 (2)

more options

The server may be sending the file with another MIME type than was use to save that file action or the file may be send as Content-Disposition.
That is always hard to tell.

You can try to delete the mimeTypes.rdf file in the Firefox Profile Folder to reset all file actions.

more options

Cheers for the reply.

I have deleted the rdf file but no difference. I still get the opening file box popup.

From the resetting download actions link. Both lines in the about:config are missing.

I have also tried switching the download option for the qif file to use a csr file but that also opens the confirmation box.

I pulled this from the rdf file

<RDF:Description RDF:about="urn:mimetype:handler:text/x-qif"
                  NC:alwaysAsk="false"
                  NC:saveToDisk="false"
                  NC:useSystemDefault="false"
                  NC:handleInternal="false">
   <NC:externalApplication RDF:resource="urn:mimetype:externalApplication:text/x-qif"/>
   <NC:possibleApplication RDF:resource="urn:handler:local:C:\Program Files\Microsoft Money\System\msmoney.exe"/>
 </RDF:Description>
 <RDF:Description RDF:about="urn:scheme:webcal"
                  NC:value="webcal">
   <NC:handlerProp RDF:resource="urn:scheme:handler:webcal"/>
 </RDF:Description>
 <RDF:Description RDF:about="urn:mimetype:externalApplication:text/x-qif"
                  NC:path="C:\Program Files\Microsoft Money\System\msmoney.exe"
                  NC:prettyName="msmoney.exe" />


Not sure if that helps.

Thanks again for the reply