搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox takes 2-3 minutes to load

  • 9 回覆
  • 7 有這個問題
  • 246 次檢視
  • 最近回覆由 cor-el

more options

Hi there.

I've researched this before and have found that:

- Launching in safe mode does not help - Resetting Firefox does not help - Reinstalling Firefox does not help

I only have two addons installed, Adblock and LastPass. I'm on a reasonably fast PC, 4GB RAM, 2xPhenom 550 @ 3.5GHz proc.

所有回覆 (9)

more options

Did this start recently after a Firefox or system update?

Some people find that over time, the accumulation of history (browsing history and download history) and cached files can slow Firefox's startup. To see how Firefox starts up without any history, you can try creating a new profile. Of course, it won't have any bookmarks either, but it's just for demonstration and you can easily switch back or (less easily) recustomize the new profile.

Close Firefox and start up in the Profile Manager (Profile Manager - Create, remove or switch Firefox profiles) from the Start menu search box using:

firefox.exe -p

Any time you want to switch profiles, close Firefox and return to this dialog.

Does Firefox start more quickly? If not, could you take a look at your plugins and disable any that are not essential and test again?

orange Firefox button or classic Tools menu > Add-ons > Plugins category

Please let us know your test results.

more options

By the way, security updates have been released for Java and Flash. You can use the plugin check page to access the installers:

http://www.mozilla.org/plugincheck/

more options

Hi Jscher,

I've tried that. I've made a completely new profile and launched with it and also installed Firefox Preloader and the issue remains. I cleared the cache and I believe it is limited to 1GB anyway. History goes only a month back.

more options

You tested in safe mode, but to eliminate all variables, in the new profile, could you also try disabling hardware acceleration?

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button or classic Tools menu > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the performance improved?


If you disable internet access and/or set Firefox to Work Offline, does that make any difference? I'm curious whether network latency (for updates, or whatever) might be a factor here.


Also, some malware may hook into Firefox at launch. Usually it makes every effort to be unobstrusive so you don't become suspicious, but it still is worth checking. Some free scanners that are highly regarded are:

Malwarebytes Anti-malware : http://www.malwarebytes.org/products/malwarebytes_free

SUPERAntiSpyware : http://www.superantispyware.com/

more options

Hi again.

I've disabled hardware acceleration and there is no change to the loadup times. Disconnecting internet also resulted in no change and there has been no malware etc detected by Avira Antivirus.


I timed the exact time taken to launch FF: 2:12

由 Zixtyy 於 修改

more options

I don't know what Firefox is doing for two minutes with no internet access, no extensions, no cache, no history. Makes no sense.

There are tools to monitor access to the file system and registry, but I haven't used them for a very long time, too long to describe how to use them efficiently.

Hopefully another volunteer will have some further suggestions. All I've got left is: don't close Firefox any more often than you need to. ;-)

more options

Can anyone else take a look? Issue is still there for me :C

more options

can you test if the same slowdown happens when you run a portable version of firefox? http://portableapps.com/apps/internet/firefox_portable

more options

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that works.