搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox (15) inserts a "Firefox HTML document" in Windows Explorer File > New menu. It breaks my works patterns (Alt FWF stops working). Need to disable.

  • 14 回覆
  • 3 有這個問題
  • 3330 次檢視
  • 最近回覆由 Mike Gale

more options

I often use the shortcut Alt FWF to create new directories on Windows.

When FF 15 is set as default it alters the File New menu from Windows Explorer.

It inserts a "Firefox HTML document" item.

This item seems to sabotage the above key combination. It intercepts the last F.

In addition I object to the naming which is plain wrong, for me.

I have deleted the registry key that inserts this thing. Unfortunately it re-appears.

I want to stop this behaviour.

How do I kill this. (Other than by making another browser the default.)

被選擇的解決方法

I see, you created a ShellNew command for .htm files.

Poking around for where the description might originate... Did you try renaming the (Default) and/or FriendlyTypeName under:

HKEY_CLASSES_ROOT\FirefoxHTML

to see whether that would work? And if so, how long it sticks?

從原來的回覆中察看解決方案 👍 0

所有回覆 (14)

more options

I'm not seeing that on Windows 7 (which I'm sure is no consolation to you).

Since Folder usually is the top item on the new items menu, can you use


Alt+f w Enter

until someone comes up with a better workaround an actual solution?

more options

Yep I'm doing something like that, but it's very annoying.

Essentially there's something in there which adds a registry entry. (I think that "discardable" is part of the registry path.) If I delete the entry it comes along and puts it back. Not friendly!

I assume there's a way to permanently eliminate it.

(The interesting thing is that my ShellNew command (entered by hand) seems to still be active behind that entry...)

more options

I checked my old XP laptop and upgraded it to Firefox 15.0.1. It doesn't have an HTML item on the "New" menu, either. Do you ever use that? If not, I wonder whether you might be able to get rid of it by removing a "new" action through the File Types dialog.

Windows Explorer > Tools > Folder Options > File Types

If you scroll down, select HTML, then click the Advanced button, do you have a "new" action here?

more options

I deliberately entered a ShellNew for .htm files. It's done in the classes hive of the registry against the file extension entry.

Like this:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.htm\ShellNew] "FileName"="html.html"

Where the default directory is C:\Windows\ShellNew but a fully qualified name can also be used.

I prefer a computer to work the way I want it to!

An entry that Firefox is using is probably,

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\ShellNew

(I haven't rechecked.)

With a little digging I found this: This entry cannot be changed to accomplish what is displayed or not displayed on the "New" context menu. If you change that value, it will be overridden by Explorer the next time you right click and bring up the "New" context menu. Try it and you will see what I mean.

I'm not aware of any way to achieve this using Folders/FileTypes. (I'm no expert in this area, so there may be an alternate approach.) The file types also has that annoying "Firefox HTML..." moniker which I also can't change.

So the original problem remains. Firefox inserts an entry that is confusing and prevents normal keyboard shortcuts working. I want to switch that off. I've done similar things from the browser using config settings. (Again I'm no expert in that.)

Side note. I just checked a Win 7 machine. On that Opera has done something similar on the new menu. Capturing the name of HTM files and renaming them!!

Anybody got a proven answer to this?

由 Mike Gale 於 修改

more options

選擇的解決方法

I see, you created a ShellNew command for .htm files.

Poking around for where the description might originate... Did you try renaming the (Default) and/or FriendlyTypeName under:

HKEY_CLASSES_ROOT\FirefoxHTML

to see whether that would work? And if so, how long it sticks?

more options

By the way, if you make IE the default browser, what text appears on the "New" menu for HTML files?

more options

I've just altered the Friendly name. It works on a new instance of Windows Explorer. If it fails (gets changed beyond my control) again I'll report back on that.

The IE name is the same as the default "HTML Document". There was a Mozilla developer discussion about it a few years ago. My impression was that it had been decided to use "HTML Document".

more options

I suspect that registry key gets rewritten by the installer at upgrade, but not in between. Let us know what you learn.

more options

It's two weeks or so and the change has held so I now consider this one done.

Of the things I changed I suspect the friendly name setting may have been the one that did it.

I now have the feeling that I'm back in control of the machines. So FF can be set as default browser, but it's not easy with the attempt to hijack htm file associations. (In fact I found no explicit help or setting within FF to correct this!)

In my view htm's/html's etc don't belong in any way at all to a browser. (I use multiple browsers when accessing pages and multiple development environments when developing content, so no software has ownership or naming rights on the extension.)

I recommend changing the thinking here and not trying to hijack these in future.

more options

To submit development suggestions, the best approach is to use Help > Submit Feedback. You can include a link to this thread.

more options

Thanks for that. (The feedback mechanism isn't great. Very limited character count and it won't accept the full URL (to this page). Odd design.)

由 Mike Gale 於 修改

more options

Same problem re-occurred with version 16 upgrade.

It's ludicrous to spend time fixing registry entries for each upgrade. The upgrades are too frequent.

Anybody else encountering this issue. I'm finding 5 registry entries with the hijacked name string for HTML documents.

That's the end of Firefox as a default for me.

more options

Anybody else encountering this issue.

This is the standard configuration, but apparently others are not using the Alt+FWF method of creating a new folder, or their menu is structured differently. For example, unlike you, I don't have the HTML document type (under any name) on my New items menu. Not sure why the difference.

Edit: I see I mentioned this before and you already explained.

由 jscher2000 於 修改

more options

No idea how many are getting the issue. Let's face it most people don't bother. (Don't blame them, this has taken more of my time than I think is reasonable.)

I'm disappointed. The issue was raised in the past and discussed by Moz developers. I think the decision was not to hijack.

Now like other things on the web we're going backward, in some respects.

I'm mentioning it again (and making a bit of a noise about an hour or two of wasted time) in the hope that something will be done. I personally want there to be more serious browser choices, but things like this cut down the choices for serious users.

If it is changed I'll probably never find out but others will benefit.

It might be easier if I could write a registry editing file (*.reg) that kicked in with an upgrade and just undid the damage.

Go well. Thanks for your responsive replies. Well done.