搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Certain web pages do not load correctly eg Amazon secure pages

  • 13 回覆
  • 5 有這個問題
  • 452 次檢視
  • 最近回覆由 cor-el

more options

Amazon home page loads perfectly, but Amazon secure pages (e.g. after I log-in, or after I move from selecting the items to go to checkout) do not show images. The following page does not show images: http://www.amazon.co.uk/gp/feature.html/ref=kcp_ipad_mkt_lnd?docId=1000425503 I have similar problems with certain other sites, such as www.marksandspencer.com. I have tried all the ideas on your help page and followed the ideas from others who had similar problems. i.e: - clearing history and caches; setting to have no history; and clearing network cache. - I have checked that images are not blocked - none of them are greyed out. - I have switched Kaspersky internet security off. - I have been through all the Option>Settings and checked that they are the same as on my Acer notebook which loads all pages perfectly. The Amazon and Marks and Spencer pages load perfectly using Internet Explorer on this computer, which is a Toshiba Satellite L505 running Windows 7. This is only a problem with Firefox and only since recent “upgrades”. It worked fine before. I cannot see what else to try

被選擇的解決方法

I think we may have cleared the problem.

I clicked on an 0x0 image and copied the URL to a new page in Firefox. When I tried to open it, I got a message that <<< This Connection is Untrusted You have asked Firefox to connect securely to images-na.ssl-images-amazon.com, but we can't confirm that your connection is secure. Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified. >>>

Despite this, as I knew the connection was from Amazon, I accepted Security Exception (tick box) and the image appeared on the new screen OK.

I then went back and refreshed the original Amazon web page and now it works!

The crazy thing is , that this has also made the Marks and Spencer web site display correctly.

Hope the problem does not re-occur

從原來的回覆中察看解決方案 👍 0

所有回覆 (13)

more options

Make sure that you allow pages to choose their colors and that you haven't enabled High Contrast in the Accessibility settings.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Use the Google cache in case of problems accessing the MozillaZine KB (prefix links with cache:)

more options

Sorry - these idea did not help. - "allow pages to select their own colours" is already set. - Contrast is set to medium. - None of the tick boxes, such as select 256 colours, are ticked. The internet sites work perfectly on the same computer with Internet Explorer, so i am fairly sure it is a Firefox problem, not a computer problem and it is a problem that has only occurred since recent Firefox upgrades

more options

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.


If images are missing then check that you aren't blocking images from some domains.

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

Make sure that you do not block third-party images, the permissions.default.image pref should be 1.

There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images.

See also:

more options

Thanks for your suggestions.

I enclose 4 screenshots: 2 from internet explorer and 2 from Firefox. As you will see everything is stripped out of the page in Firefox, but it works perfectly in IE.

Regarding your other suggestions:

Permissions: The settings were all to ‘Use Default’ but to ensure that there were no problems while viewing the Amazon page I changed these to : Load Images - Allow Open Popup Window - Allow Set cookies - Allow for Session Install extension or Theme - Use default. I also tried it on <Allow> but it didn’t make any difference Share locations - Always ask Maintain Offline Storage - Always ask

Check that images are enabled: Tools > Options > Content: [X] Load images automatically Load images automatically is ticked.

Check the exceptions in "Tools > Options > Content: Load Images > Exceptions" There are no exceptions in this box

Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key). None of the images are gray and none are blocked (see attached JPEG), but I do notice that the image size is 0px x 0px, which does not seem correct and I cannot see the image in the preview window.

Make sure that you do not block third-party images, the permissions.default.image pref should be 1. Sorry - I do not understand this statement. Where do I find this permissions to check that it is set to 1? (except in Permissions which I have detailed above).

There are also extensions (Tools > Add-ons > Extensions) I am not sure what I am looking for, but there is nothing obvious which could relate to Amazon or firefox. Java Console 6.0.33 is enabled. The disabled applications relate to AOL, Ask Toolbar, HP Smart web printing, Kaspersky URL advisor and Virtual keyboard, Skype Extension for Firefox and Tor button (the last few all incompatible with Firefox 14.0.1)


Security software (firewall, anti-virus) that can block images. Kaspersky (fully licensed and up to date) is not blocking these pages in Internet Explorer and I am also running the same version of Kaspersky with Firefox on my Acer notebook and the page works fine on that machine. Also, I disabled protection and that did not make any difference.

Regards, Arthur

more options

Do all images show a size of 0 x 0 pixels as I see in that last screenshot?

Did you check that your security software isn't blocking images if the settings in Firefox are correct?

Do you get the image if you copy the URL from the Page Info window to the location bar?
Click the line with the URL and use Ctrl+A and Ctrl+C to copy the URL to the clipboard.

more options

選擇的解決方法

I think we may have cleared the problem.

I clicked on an 0x0 image and copied the URL to a new page in Firefox. When I tried to open it, I got a message that <<< This Connection is Untrusted You have asked Firefox to connect securely to images-na.ssl-images-amazon.com, but we can't confirm that your connection is secure. Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified. >>>

Despite this, as I knew the connection was from Amazon, I accepted Security Exception (tick box) and the image appeared on the new screen OK.

I then went back and refreshed the original Amazon web page and now it works!

The crazy thing is , that this has also made the Marks and Spencer web site display correctly.

Hope the problem does not re-occur

more options

It shouldn't be necessary to add an exception for that domain.

Do you see the "AddTrust AB -> COMODO High-Assurance Secure Server CA" intermediate certificate in the Certificate Manager?

  • Tools > Options > Advanced : Encryption: Certificates - View Certificates > Authorities

Which chain do you currently see if you inspect the certificate by clicking the Site Identity Button on the location bar and proceed with "More Information" -> "View Certificate" with such an image in the current tab?

more options

Thank you. I have followed your instructions and enclose a scan of the certificate - General and Detail. Hope that clarifies the issue. Arthur

more options

That doesn't look good.

Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored.

If that helped to solve the problem then you can remove the renamed cert8.db.old file.
Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates.
Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

more options

Please can you advise where I find cert8.db file I went to > Program files (x86) > Mozilla Firefox > Defaults > Profile > the only thing in Profile is ‘Chrome’ > if I click on that I see message <<folder is empty>> Note: I checked in Windows Explorer (Folder and Search options) and confirmed that WE is set to show hidden files and folders I have also gone to Start > and I typed ‘cert8.db’ in the data entry box and got a return << no items match your search>>. Please advise how I find this file. Thanks Arthur

more options

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder
more options

Thanks for all your help. That seems to have cured the problem

more options

You're welcome