Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

long time to load and cannot change homepage

  • 22 回覆
  • 3 有這個問題
  • 432 次檢視
  • 最近回覆由 dmackay41

more options

I live in France and my ISP is Orange. I have a LIVEBOX 2 and have used Orange for the last year and a half.

Up until a few days ago, Forefox only took about 10 seconds to load to my homepage which was www.google.co.uk

A few days ago, Firefox took about one minute to load and the homepage has changed to the French Orange homepage/portal. If I try to reset the homepage back to Google, it always defaults back to the Orange portal on every start up.

I have tried downloading the Browser Protect 1.1.3 add-on but this had no effect either. I have also re-started Firefox with add-ons disabled, and again, this had no effect.

被選擇的解決方法

Hi Cor-el, many thanks for all your help. I have already tried a reset and that had no effect either. The steps you advise in your last post are getting a little out of my depth now, so I think i will just accept that the Orange settings are defaulting to the homeage everytime Firefox loads up, something I think I can live with at the moment. Thanks again.

從原來的回覆中察看解決方案 👍 0

All Replies (20)

more options

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

more options

Hi, thank you for the advice. It has fixed the homepage problem...now back to Google, however it still takes about a minute to load up, and even once loaded, the mouse is a bit unresponsive for about 3 seprate periods of about 10 seconds (it is like the PC is using up resources performing some unknown task)...and I now cannot find the orange Mozilla Firefox start button on the toolbar. How do I get this back? Thank very much.

more options

Run all Windows Updates, install all needed service packs, etc.

Update your graphics driver (Firefox uses your graphics card for some rendering, and an out of date graphics card driver can cause problems. Upgrade your graphics drivers to use hardware acceleration and WebGL

Update all your plugins (Flash, Java, etc.): http://www.mozilla.org/plugincheck/.

Download and Install MalwareBytes Anti-Malware, run a full Scan. http://www.malwarebytes.org/. This helps check that there are no viruses on your computer causing issues. You can uninstall this program after you clean off any infections.

more options

Tried that. I am all up to date.

more options

And...thanks to a previous post from cor-el, I have found the orange Firefox button.

more options

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

If you do not keep changes after a restart then see:

more options

Despite retrieving my Google homepage yesterday and completing all the actions from Cor-el, the homepage is now back to Orange, France today!

more options

Did you find a user.js file in the Firefox Profile Folder that might account for that behavior?

Does anything related to the Orange website come up if you do a search on the about:config page?

more options

I have not found any js file, but found several references to orange in the about.support page, if this is what you mean by the MF Profile Page (not an advanced user :-( )

more options

Note that Windows may be hiding the .js file extension, so you may only see a user and a prefs file. You can check the file type via the Properties in the right-click context menu.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

You have the home page and the search engine (keyword.URL) for the location bar search set to the Orange website.

There may be more prefs because only some prefs in a white-list are shown on the Help > Troubleshooting Information page.


Doesn't changing the home page last if you close and restart Firefox?


由 cor-el 於 修改

more options

Thanks cor-el.. I have attached a snapshot which indicated "user", "prefs" and "sessionstore" all having the same file, although different times and dates of modification.

"You have the home page and the search engine (keyword.URL) for the location bar search set to the Orange website." - this happens every time I try to change the homepage and it does not last!, ie it goes back to the Orange homepage everytime I restart Firefox.

more options

What is the content of that JScript Script file user if you open it in a text editor like Notepad?

more options

This is what I get :

user_pref("browser.startup.homepage", "http://r.orange.fr/r/Ohome_portail?ref=O_OI_defaultPage_FF"); user_pref("browser.search.selectedEngine", "Orange"); user_pref("keyword.URL", "http://r.orange.fr/r?ref=O_OI_hook_openSearchFF&url=http%3A//rws.search.ke.voila.fr/RW/S/opensearch_orange?rdata=");

more options

That file is causing the prefs to get set every time you start Firefox, so you need to remove that user.js file.

Then you can reset the browser.startup.homepage and keyword.URL prefs on the about:config page and this time the change should stay after a Firefox restart.

more options

I have removed the file "user" and changed the homepage back to Google, however when Firefox restarted it went back to Orange. In the profile folder I attached in the previous post, there were 2 other js files, "prefs" and "sessionstore" - do I also have to remove them both too?

more options

I have just checked again, and despite moving the "user" file, it had re-appeared in the profile folder after I had removed it to the RecycleBin, thats why it defaulted back to Orange.

more options

Sounds that you have either a Firefox extension or software on your computer that recreates the user.js file.

A possibility to try is to delete all data in the user.js file with a text editor and change the file to read-only in the properties via the right-click context menu to see if that helps.

Start Firefox in Safe Mode to check if one of the extensions is causing the problem.

more options

Thanks Cor-el. I tried to delete the data in the user.js file using Notepad then changing the properties to "read only", however the deleted data re-appears automatically when I open the file again immediately.

I have checked the extensions in Safe Mode, however that had no effect at all.

Your only other suggestion that some software is on the PC which recreates the user.js file seems the more likely answer, however, where this came from (probably Orange), and how to get rid of it is a mystery.

more options

Make sure that the file gets saved as user,js and doesn't get a hidden .txt file extension.
Selecting All Files when saving a file in Notepad should make this easier.
You can also try to create an empty file with the name user.js.

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that works.

more options

Thanks Cor-el. I have tried all your advice so far. I managed to empty the user.js file of all contebt by creating a blank new one elsewhere and then transferring it to the MF Profile folder. The only difference is that the load up time is now about half, ie about 20 seconds, but nothing I can do stops the homepage defaulting to Orange, France at every restart. The only other thing I have noticed, and I do not know if it is relevant is the content of the "prefs" folder, a script file in the MF Profile folder. It seem to have all the preferences towards Orange in it, but cannot be edited. Is this file causing the problem too? I have attached an image of the content.

  1. 1
  2. 2