搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Whenever I print something from a web page on Firefox each page of the print-out has a line of what I call "gobbledy-gook" at the top and bottom.

  • 7 回覆
  • 2 有這個問題
  • 87 次檢視
  • 最近回覆由 jhromer

more options

It's the same at the top and bottom and the same every time. It appears to be 9 characters long and starts with a question mark in a black diamond. 5 of the 9 characters are the letter A (some upper-case, some lower-case), alternating with other less decipherable character.. It reminds me somewhat of Vietnamese but it obviously isn't. Some sort of special computer encoding? It does not happen when I print out a web page from MS Internet explorer.

所有回覆 (7)

more options

Hi,

Please also try setting the Header & Footers to blank in File (Alt + F) > Page Setup > Margins & Header/Footer.

Print setup

Can you also please create a screenshot of the problem you're seeing by following the guide mentioned at How do I create a screenshot of my problem?.

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. You really help us to visualize the problem.

more options

You might want to make sure your default fonts are "TrueType" or "Outline" fonts in the following dialog:

orange Firefox button or classic Tools menu > Options > Content

In the Fonts & Colors section, click the Advanced button.

Serif: e.g., Times New Roman
Sans-Serif: e.g., Arial
Monospace: e.g., Courier New

more options

Thanks, dumdidadida. I went where you suggested and changed the boxes for the top middle and bottom middle to "blank." That eliminated both of the "gobledygooks." I'd love to send screenshots of what printed out in those two places before, but I can't because it no longer happens. I can't even tell you what was entered in those two boxes when I first went there, because I do not remember.

more options

Hi jhromer, you really should be able to print the page Title, URL, Date/Time and Page # of # without gibberish characters. However, if you don't care to have those on your printouts, then the workaround is effective.

more options

Sounds that Unicode characters get displayed as their separate components.

more options

Thanks, cor-el. Yes! "Unicode." I was trying to remember what the real name was for what I was calling "gobbledygook." Jim

more options

Thanks, jscher. The page Title, URL, Date/Time and Page # of # have always been there and still are. It's just that that annoying gibberish (which I now know is called "Unicode") always appeared in the middle of the header and in the middle of the footer. As recommended by dumdidadida, I have now set those two middle sections to "blank" and everything seems fine. I suppose it would be interesting to know how that Unicode got there in the first place but unless the problem recurs I don't really need to know that.