搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Can't open links in Firefox by clicking URL in Thunderbird

  • 49 回覆
  • 39 有這個問題
  • 57 次檢視
  • 最近回覆由 maccool

more options

This has started happening since the last Firefox upgrade (to 14.0.1). It affects two machines - one running Windows 7, the other XP. The symptoms are identical.

Firefox is the default browser on both machines. I'm using only a default profile on each machine. I've checked that there are no stray "no-remote" switches in the command line or environment variables and I've tried deleting "parent.lock". The fact that it has happened to two separate installations, as a result of the upgrade, and the fact that all other functions of Firefox work as expected, makes me doubt that it's a profile corruption. I have also tried opening Firefox in Safe Mode but the behaviour is the same.

Here's what happened/happens:

Previously, if I had opened Firefox in the normal way from the start menu and then clicked on a link in an email in Thunderbird, the link would open in a new tab in the running copy of Firefox. I could do this with multiple links, each opening a new tab.

Now, if I do this I get the "Firefox is already running" error box.

If I close Firefox the click on a link in an email in Thunderbird, it will start Firefox as expected, and open the link. But if I then click on a second link, I get the error message.

If I click on URLs in other applications (for instance Pidgin instant messenger), the links open in new tabs in the running Firefox in the usual way, so the problem seems to be specific to links opened in Thunderbird.

As an experiment, I rolled my FF installation back to 13.0.1 on the XP machines. Everything then worked as before, and as expected, so this is clearly to do with the upgrade.

所有回覆 (20)

more options

I tracked problem to DoNotTrackPlus 2.0.6.. I switched to AVG donottrack and Domino's works. Domino's was the only site I had trouble with with DoNotTrackPlus.

more options

I also had this problem. This is what solved it for me: In TB, go to Tools | Options and select the Attachments tab. In the Incoming list, click on "http" and, in the Action column, select "Use other..." from the drop-down list. Click "Browse" and a list should open in the Program Files folder. Double-click on "Mozilla Firefox" and select "Firefox" (or "Firefox.exe") and click "Ok.". Do the same for "https." I did the same for "Hyper Text Markup Language" but I don't think that was necessary.

more options

Out problem in TH 16.0.2 is clicking on a link when FF is open takes about 3 to 5 minutes for the link to display in a tab in FF. The TB tools/Attachments-Incoming list of "Content Type"s does not list either "http" or "https". How can these 2 types be added to the "Content Type" list?

more options

Hi tedanne449, when this delay occurs, is Firefox already running? If you click a link in another application, e.g., a stand-alone PDF reader or a word processing program, is it similarly slow or does it open quickly? Trying to determine whether the problem is Thunderbird or Firefox or a more general settings issue.

more options

When this delay occurs, is Firefox already running? (Yes) If you click a link in another application, e.g., a stand-alone PDF reader or a word processing program, is it similarly slow or does it open quickly? (It opens quickly) I just opened a .docx file sent as an attachment into TH, it opened as any normal Word file would and as quickly. In the same email there was a link to a site via http://. With TH open it was very slow in opening the web site. I clicked on a link with a .docx file and the slowness was present while TH was open.

more options
more options

Opened this link Windows_error_opening_Internet_shortcut_or_local_HTML_file_-_Firefox. Reinstall Firefox - did not help the problem Extensions - disabled all extensions did not solve the problem. File Types edit - using Windows 7 not relevant. Registry edit - followed instruction for each registry listed, then started FF and made the preferred browser. The problem still persisted. Also ran is FF safe -mode and the problem did not show when opening a link in an E-mail in TH.

more options

Hi tedanne449, I wasn't completely clear in my previous questions.

I'm trying to distinguish whether Firefox behaves differently if you're clicking a link to a URL in a message body in Thunderbird vs. a link to a URL in another application, e.g., a link in a Word document or in a PDF. To test in a Word document, paste in a link to your favorite site and use Ctrl+click to launch it. Does that work normally or is it just as slow as loading a page after clicking a link in a Thunderbird message?

We had another thread about problems with external links when the user was running Firefox in Sandboxie. Do you launch Firefox in Sanboxie or similar virtualization software?

more options

Jcher2000, I just tried your experiment with OpenOffice. Link in a document opens a new tab in a running Firefox. I then tried it from Thunderbird and got the error pop-up (Firefox is already running ....).

In the past I've tried all the things suggested in this thread with no joy (registry, changing default browser to IE and back, safe-mode, etc).

由 maccool 於 修改

more options

@maccool: Are you running the standard or PortableApps version of Thunderbird?

more options

Ratcatcher: standard TB, current version 16.0.2 running on WIn7 (but this has been going on for a long, long time, back to WinXP).

more options

Why does ff url appear as C:// and ending w/ htm??? even when i save as shortcuts. where is the normal URL for the page??? This is really ticking me off!!

more options

Hi bevybev, could you describe this in more detail?

Is it a link someone sent to you in email? Or a webpage attached to an email?

Where are you saving the shortcut and how are you saving it?

more options

You know, I want to tell everyone how great firefox is but I am having some issues that you never responded with. FF was my default but had to switch back to IE because when I saved a shortcut to a webpage I would get something like this: 'C:\Users your grammar on this page.htm NOW WHAT IS UP W/ THAT?? where is the NORMAL url?? When i want a shortcut, you know,,, rt.click and save on desktop.IE is my default right now so the page url's are normal and not like the above

由 bevybev 於 修改

more options

Any webpage shortcut, it doesn't matter. it starts like a file C:\Users\ and ends with htm... Why??? smh

more options

I think you might have been saving the page rather than creating a shortcut. There isn't an option on the right-click menu to create a shortcut.

One way to create a shortcut on the desktop to the current page is to drag and drop the icon from the "site identity area" just to the left of the URL (on this page, it's a gray lock) to the desktop.

To add a right-click option, there is at least one add-on. I haven't tried it myself: deskCut :: Add-ons for Firefox.

more options

Hi, So saving on desktop webpage complete means nothing??? That is what i have been doing. I don't get it!! \o/

more options

What other options do I have without downloading that extra? Thanks for responding!1

more options

Hi bevybev, saving the page makes a local copy. Local on the C: drive. The URL you are seeing is accurate.

If you prefer a shortcut to the website, you can drag the site icon to the desktop. You only need the add-on if you want a right-click option.

more options

Glad everyone is getting helped, but it would be nice to stick to a single subject (by starting new posts when the subject is different). I've been following this post's comments in hopes that the original subject ("Can't open links in Firefox by clicking URL in Thunderbird") might someday be answered.

  1. 1
  2. 2
  3. 3