搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Cant watch youtube videos

  • 10 回覆
  • 200 有這個問題
  • 24 次檢視
  • 最近回覆由 DarkMoonFox

more options

i know i made a second post about this i messed up. so i cant watch any youtube videos on firefox but i can watch them on google chrome and internet explore. when i try to play a youtube video i cant cick play and the video is all black i post a screen and show you.

由 gervanieh 於 修改

所有回覆 (10)

more options

11.2 If the flash player if you restore Firefox works fine on 13.1. 11.3 Adobe Flash player and video does not turn on if I crash Win7.thanks.

more options
more options

Dont need help because now i can watch videos kind of wired because i could it watch any videos and now i can put thanks anyways

more options

Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Try to "disable the hardware acceleration" in the Flash Player as a quick test.

Flash "Display settings" window:

more options

search softpidea and downlode flash player offline pakage


only working flash pluging ok


reinstall flash player and firefox try

由 capee 於 修改

more options

Guys i can watch youtube videos now its just that when i played a video the screen was black but after a while i can watch youtube videos on firefox now.

由 gervanieh 於 修改

more options

i have the same exactly porblem and have screenshot of my own https://support.cdn.mozilla.net/media/uploads/images/2013-01-06-13-19-22-79838b.png

none of the replies did help me please, i really dont like the other browsers and the idea of launching one only to watch a video in youtube freaks me out.

please help me to fix this problem i've tryed E-V-R-E-Y-T-H-I-N-G - reinstall firefox - reinstall and update external patchs/add-ons - cleaning all temporary and chace files - disable firewall and antivirus to see if it sloves the problem - allowing Java & JavaScipt just all the options it demends

none of them helped me... im really desperate

more options

gervanieh if you can tell me what you did to fix the problem i'll be thankful

more options

ok guys i think i came up with the solution the problem is with acessing videos on youtube with the normal connection protocol www. or http:// for some reason acessing videos with insecure connection is not allowed by youtube's servers

while https:// which is secured protocol connection is allowed and allow running of videos.

to be honest i dont know why youtube/google not preforming auto-linking between each protocol in cases 1 of them is not working well like facebook's servers do for example.

i will try to contact them and ask them why.

anyway i would like to thank all of you