搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Fox News Polls do not show the poll questions in FF 13.0 but DO in Chromium

  • 13 回覆
  • 1 有這個問題
  • 51 次檢視
  • 最近回覆由 Paul Hubert

more options

I am using Firefox 13.0 under 64 bit Ubuntu 11.04. When I access a Fox News poll, the poll QUESTIONS do not display. No Java error is displayed (I have NoScript installed) Chromium has no problem with the pages.

被選擇的解決方法

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

1. Clear Firefox's Cache

Edit > Preferences > Advanced > Network

Under Offline Storage : "Clear Now"

2. If needed, delete the site's cookies here

While viewing a page on the site, right-click and choose View Page Info > Security > "View Cookies"

You also can change the search box at the top of the dialog to look for any polldaddy cookies.

Then try reloading the page. Does that help?


If that doesn't help, I wonder whether any of your other add-ons could be interfering? A standard diagnostic for that is to try Firefox's Safe Mode.

First, I recommend backing up your Firefox settings in case something goes wrong. See Back up and restore information in Firefox profiles. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, restart Firefox in Firefox's Diagnose Firefox issues using Troubleshoot Mode using

Help > Restart with Add-ons Disabled

In the Safe Mode dialog, do not check any boxes, just click "Continue in Safe Mode."

If the poll appears, this points to one of your other add-ons or a custom setting as the problem. Maybe an ad blocker?

從原來的回覆中察看解決方案 👍 0

所有回覆 (13)

more options

The options with the radio buttons do not display? For what it's worth, I see them on Windows 7. Do you see any additional blocked domains on the NoScript menu that might need unblocking?

more options

Exactly. BUT it did the same with NoScript disabled (restarted, of course).

I didn't really believe it WAS NoScript, but had to eliminate it.

Of course Firefox under 64 bit Ubuntu is most definitely NOT the same as FF under any version of Windows.

I've encountered a number of cases where FF fails and Chromium succeeds, but I REALLY do not like Chromium! It's there ONLY for such situations!

For me, FF 13.0 seems to have introduced problems of this sort I've never seen before.

By the way, are you primarily a Windows guy, and if so, why??? Just curious.

I only jumped to Ubuntu after my Win XP SP3 had crashed hard for the 3rd time. Never looked back. Never will.

I DON'T like the Ubuntu "Unity" interface - seems to me all the OS providers are aiming at the tablet and smartphone market and trying to make desktops conform.

Ugh! I NEVER use "keyboard shortcuts"!

Sorry, soapboxing... & ranting. I've used Firefox since 0.9 version and tend to be VERY brand loyal!

more options

One other little point: I'm NOT using Unity under my Ubuntu 11.04. I don't think that should cause this sort of problem either (though I believe it has introduced some video issues with my dual monitors and Nvidia card).

more options

That text uses font-family:Verdana,Arial,Helvetica,sans-serif;

You can use this extension to see which fonts are used for selected text.

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts and disable website fonts as a test.

  • Edit > Preferences > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"
more options

Thanks for the information. I ran the test and found no corrupted fonts. I'm not sure how to interpret the PageInfo, but the following are missing (and present in Chromium):

  • New Poll
  • button response selection list
  • Vote button and "View Results" (underlined)

The text before and the following line below ARE present.

This is a non-scientific viewer question

I haven't yet found the equivalent of "Page Info" in Chromium for comparison!

由 Paul Hubert 於 修改

more options

Is there any text visible if you select that area and use "View Selection Source" in the right-click context menu?

由 cor-el 於 修改

more options

In the Chromium page source I find this:

<script src="http://static.polldaddy.com/p/6311704.js" charset="utf-8" type="text/javascript"></script>

Where the poll contents should be.

And the following in Firefox (apparently not executed)


<script src="http://static.polldaddy.com/p/6311704.js" charset="utf-8" type="text/javascript"></script>

more options

View Selection source displays the text before and after with the poll contents script in-between as it should be. However, it's clear the script isn't being executed in Firefox.

NoScript and AutoCopy both disabled.

A Java issue????

more options

The UN Tuesday called the 15-month conflict in Syria a full-scale civil war. Meanwhile, the US warned Russia about selling arms to the Assad regime. Is it time for the US to start arming the Syrian rebels?

<script src="http://static.polldaddy.com/p/6311704.js" charset="utf-8" type="text/javascript"></script>

This is a non-scientific viewer question.

more options

The POLL content is coming from polldaddy (as you can see) - viewing the source of that in Ghostery.

more options

選擇的解決方法

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

1. Clear Firefox's Cache

Edit > Preferences > Advanced > Network

Under Offline Storage : "Clear Now"

2. If needed, delete the site's cookies here

While viewing a page on the site, right-click and choose View Page Info > Security > "View Cookies"

You also can change the search box at the top of the dialog to look for any polldaddy cookies.

Then try reloading the page. Does that help?


If that doesn't help, I wonder whether any of your other add-ons could be interfering? A standard diagnostic for that is to try Firefox's Safe Mode.

First, I recommend backing up your Firefox settings in case something goes wrong. See Back up and restore information in Firefox profiles. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, restart Firefox in Firefox's Diagnose Firefox issues using Troubleshoot Mode using

Help > Restart with Add-ons Disabled

In the Safe Mode dialog, do not check any boxes, just click "Continue in Safe Mode."

If the poll appears, this points to one of your other add-ons or a custom setting as the problem. Maybe an ad blocker?

more options

I'd thought about clearing cache. I'll follow your suggestions - I'm fairly confident this will work, tho. I'll let you know - a little busy to get to it just now, tho.

I don't EXPECT to need safe mode OR touching the profile (recently DELETED the profile entirely thanks to a CPU & RAM problem!).

由 Paul Hubert 於 修改

more options

Safe mode did it. Tried clearing cache and deleting cookies first. Adblock has never caused this in the past, but I added Ghostery and NoScript - I don't think NoScript has been a problem in the past and disabling it was no help.