X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox uploading doesn't show My Pictures

已張貼

The file explorer that comes up when you go to download or upload a file will not show My Pictures.

https://lh4.googleusercontent.com/-zCqwdPxiNIs/T86YSJWp0uI/AAAAAAAAAGk/j5h2uilJraY/s625/Chromium%2520problem.jpg

I feel this is a Chromium based problem, as Google Chrome does the same thing, I think it might be some kind of Picture limit, it can only display a certain amount. I can go to another folder with pictures in it and I can see all of them. Also, any other applications like image editing programs such as GIMP show them, but neither Firefox or Chrome will.

Edit: I'd like to also point out that I can only access those folders from going into: C:\Users\USERNAME\My Pictures or whatever else Library folder there is. It's like Chromium doesn't like the shortcuts, but I had no problem doing this before, it's a recent problem and I haven't been infected, installed anything I haven't already used before or anything, it's like it came up out of the blue.

The file explorer that comes up when you go to download or upload a file will not show My Pictures. https://lh4.googleusercontent.com/-zCqwdPxiNIs/T86YSJWp0uI/AAAAAAAAAGk/j5h2uilJraY/s625/Chromium%2520problem.jpg I feel this is a Chromium based problem, as Google Chrome does the same thing, I think it might be some kind of Picture limit, it can only display a certain amount. I can go to another folder with pictures in it and I can see all of them. Also, any other applications like image editing programs such as GIMP show them, but neither Firefox or Chrome will. Edit: I'd like to also point out that I can only access those folders from going into: C:\Users\USERNAME\My Pictures or whatever else Library folder there is. It's like Chromium doesn't like the shortcuts, but I had no problem doing this before, it's a recent problem and I haven't been infected, installed anything I haven't already used before or anything, it's like it came up out of the blue.

由 loanstar744 於 修改

額外的系統細節

這發生了

每當開啟 Firefox 的時候

問題發生於...

Randomly.

已安裝的外掛程式

Troubleshooting information shows all installed plugins.

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0

更多資訊

Application Basics
Name
Firefox
Version
13.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.0.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Add to Amazon Wish List Button
1.8
true
amznUWL2@amazon.com
avast! WebRep
7.0.1426
true
wrc@avast.com
Battlefield Heroes Updater
5.0.137.0
true
battlefieldheroespatcher@ea.com
Battlefield Play4Free
1.0.66.2
true
battlefieldplay4free@ea.com
DivX Plus Web Player HTML5 <video>
2.1.2.145
true
{23fcfd51-4958-4f00-80a3-ae97e717ed8b}
FlashGot
1.4.5
true
{19503e42-ca3c-4c27-b1e2-9cdb2170ee34}
NoScript
2.4.3
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
Personas
1.6.2
true
personas@christopher.beard
FaceTweak
1.0.4
false
{1519200d-6633-40c9-a9a1-d60d8d1d0479}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
747520
browser.places.smartBookmarksVersion
3
browser.startup.homepage
https://twitter.com/#!/garrynewman|http://blog.counter-strike.net/|http://e3.nintendo.com/|http://www.facebook.com/Sapph…
browser.startup.homepage_override.buildID
20120601045813
browser.startup.homepage_override.mstone
13.0
browser.startup.homepage_reset
http://www.bing.com/?pc=MOZO
extensions.lastAppVersion
13.0
gfx.direct3d.prefer_10_1
true
keyword.URL
http://www.bing.com/search?form=MOZPLB&pc=MOZO&q=
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1338203183
places.history.expiration.transient_current_max_pages
104858
places.history.expiration.transient_optimal_database_size
167772160
privacy.cpd.cookies
false
privacy.cpd.sessions
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
AMD Radeon HD 6800 Series
Vendor ID
0x1002
Device ID
0x6738
Adapter RAM
1024
Adapter Drivers
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.961.0.0
Driver Date
4-5-2012
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (AMD Radeon HD 6800 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)
GPU Accelerated Windows
1/1 Direct3D 10
AzureBackend
direct2d
JavaScript
Incremental GC
1
Library Versions
Expected minimum version
Version in use
NSPR
4.9
4.9
NSS
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC
NSS Util
3.13.4.0
3.13.4.0
NSS SSL
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC
NSS S/MIME
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC

cor-el
  • Top 10 Contributor
  • Moderator
17697 個解決方法 160138 個答案

Can you open any of the other folders in Libraries?

Did you check the permissions of that My Pictures folder?

EDIT: You've tagged the thread with "beta".

Are you using the official Firefox 13.0 release (Help > About Firefox shows release update channel)?

Can you open any of the other folders in Libraries? Did you check the permissions of that My Pictures folder? EDIT: You've tagged the thread with "beta". Are you using the official Firefox 13.0 release (Help > About Firefox shows release update channel)? *Firefox 13.0.x: http://www.mozilla.org/en-US/firefox/all.html

由 cor-el 於 修改

Oxylatium 71 個解決方法 563 個答案

How many pictures does the folder contain?

How many pictures does the folder contain?

提出問題者

The My Pictures folder has permissions unlocked for my account as Admin. Actually, now that I tried it, I can't access the other Library folders in Firefox or Chrome either, but I can in Internet Explorer. All my other folders show up just fine.

Actually it added those tags itself, I've been having this issue since even version 11.0 and it's an issue in Chrome, I've yet to try out Opera, but I think Opera runs Chromium now anyways so it would more than likely be the same. My first thought with his issue was to check permissions, I can go into the folder but pictures don't show.

The My Pictures folder has permissions unlocked for my account as Admin. Actually, now that I tried it, I can't access the other Library folders in Firefox or Chrome either, but I can in Internet Explorer. All my other folders show up just fine. Actually it added those tags itself, I've been having this issue since even version 11.0 and it's an issue in Chrome, I've yet to try out Opera, but I think Opera runs Chromium now anyways so it would more than likely be the same. My first thought with his issue was to check permissions, I can go into the folder but pictures don't show.

由 loanstar744 於 修改

提出問題者

As a small time graphic artist/photographer I have over 3GBs of pictures in the folder but most have their own folders inside the My Pictures folder to keep everything tidy.

As a small time graphic artist/photographer I have over 3GBs of pictures in the folder but most have their own folders inside the My Pictures folder to keep everything tidy.
jscher2000
  • Top 10 Contributor
8839 個解決方法 72252 個答案

If you click the link that says "Includes 1 location" does the library point to the expected folder? For some reason, mine shows two locations, one under "Public" and the other under my username.

If you click the link that says "Includes 1 location" does the library point to the expected folder? For some reason, mine shows two locations, one under "Public" and the other under my username.

提出問題者

Yes, though I took out the Public Folder long ago as I never used it. Another program that has this problem is Steam, because of it's recent switch, now it's Chromium based as well.

I have no problem going to the folder while in explorer, and it shows up and works correctly under Internet Explorer as well. It really seems like a Permission issue, but I already have full permission for everything, I even tried running Firefox under Run as Administrator and I still got the problem, I can go to them, but i have to go to C:\ then navigate to Users, my name then to which ever folder I need to access, it's just incredibly annoying and consumes a greater amount of time.

Yes, though I took out the Public Folder long ago as I never used it. Another program that has this problem is Steam, because of it's recent switch, now it's Chromium based as well. I have no problem going to the folder while in explorer, and it shows up and works correctly under Internet Explorer as well. It really seems like a Permission issue, but I already have full permission for everything, I even tried running Firefox under Run as Administrator and I still got the problem, I can go to them, but i have to go to C:\ then navigate to Users, my name then to which ever folder I need to access, it's just incredibly annoying and consumes a greater amount of time.
jscher2000
  • Top 10 Contributor
8839 個解決方法 72252 個答案

Perhaps I should have mentioned initially that Firefox isn't a Chromium-based program. So we can't blame Google.

I'm leaning toward a Windows or third party software issue. You may want to explore threads such as the following on Microsoft's forums:

Why are my libraries empty when I am attaching a file or uploading a picture? - Microsoft Answers

Picture Library "Folder is empty" when viewing other than by Folder - Microsoft Answers

Pictures disappear in libraries. - Microsoft Answers

Perhaps I should have mentioned initially that Firefox isn't a Chromium-based program. So we can't blame Google. I'm leaning toward a Windows or third party software issue. You may want to explore threads such as the following on Microsoft's forums: [http://answers.microsoft.com/en-us/windows/forum/windows_7-files/why-are-my-libraries-empty-when-i-am-attaching-a/9dc7487e-000a-48aa-bde2-2f125f051284 Why are my libraries empty when I am attaching a file or uploading a picture? - Microsoft Answers] [http://answers.microsoft.com/en-us/windows/forum/windows_7-files/picture-library-folder-is-empty-when-viewing-other/2990d9e9-8e2a-4409-bfbb-dfa46b9377ac Picture Library "Folder is empty" when viewing other than by Folder - Microsoft Answers] [http://answers.microsoft.com/en-us/windows/forum/windows_7-pictures/pictures-disappear-in-libraries/c63ba5ab-367d-e011-9b4b-68b599b31bf5 Pictures disappear in libraries. - Microsoft Answers]

提出問題者

So far none of the above mentioned fixes helps, and switching to Homegroup just causes windows to pop up and show File Sharing saying it could take a few minutes but does nothing and has been going for about 10-15 minutes though Sharing is already enabled. I had tried switching back to Library Default originally but that doesn't seem to have worked either.

I can't remember where I saw it in Firefox one day but when I was changing the settings internally once I saw chrome:"string" somewhere. Even some of the addons in about:config show chrome:"Some Settings". So since then I started to think that Firefox uses some of Chromium's open source code: http://www.chromium.org/Home

Also, never messed with any of the important settings in about:config, just the URL string to fix the default URL bar search preference back to Google instead of Bing.

So far none of the above mentioned fixes helps, and switching to Homegroup just causes windows to pop up and show File Sharing saying it could take a few minutes but does nothing and has been going for about 10-15 minutes though Sharing is already enabled. I had tried switching back to Library Default originally but that doesn't seem to have worked either. I can't remember where I saw it in Firefox one day but when I was changing the settings internally once I saw chrome:"string" somewhere. Even some of the addons in about:config show chrome:"Some Settings". So since then I started to think that Firefox uses some of Chromium's open source code: http://www.chromium.org/Home Also, never messed with any of the important settings in about:config, just the URL string to fix the default URL bar search preference back to Google instead of Bing.

由 loanstar744 於 修改

jscher2000
  • Top 10 Contributor
8839 個解決方法 72252 個答案

One thing I noticed in your screen shot is the text "No items match your search." I can't seem to replicate that without actually running a search. Simply pointing the library at a blank folder doesn't cause it. Running out of ideas...

One thing I noticed in your screen shot is the text "No items match your search." I can't seem to replicate that without actually running a search. Simply pointing the library at a blank folder doesn't cause it. Running out of ideas...
the-edmeister
  • Top 25 Contributor
  • Moderator
5420 個解決方法 40435 個答案

chrome:// in Mozilla has nothing to do with Google Chrome browser - it's the name for Mozilla's XML User Interface Language (XUL = "zool").

http://en.wikipedia.org/wiki/Chrome_Mozilla

Was written by fans of Ghostbusters.

'''chrome://''' in Mozilla has nothing to do with Google Chrome browser - it's the name for Mozilla's XML User Interface Language (XUL = "zool"). http://en.wikipedia.org/wiki/Chrome_Mozilla ''Was written by fans of Ghostbusters.''