X
點擊此處開啟此網站的行動版。

技術支援討論區

How can I enable blocked flash plugin on firefox?

已張貼

A couple of days ago, my computer (mac OS X 10.4.11 PPC) suddenly seemed to stop recognizing that I had flash installed and wouldn't play anything requiring flash - instead a message came telling me to install it.

I uninstalled flash and the installed the latest version for my computer from the adobe website (which is 10.1.102.64).

Computer still thinks flash isn't installed and when I checked plugins I discovered firefox has blocked it telling me the version of flash I want to use is too old (even though the version I've downloaded is the latest I can use with my computer).

How can I enable the plugin on firefox so I can use flash? The 'enable' button on the plugin has been greyed out so I can't press it.

Please help - I'm rubbish with computers so please give any advice in very simple language! ( i have firefox 3.0.4)

A couple of days ago, my computer (mac OS X 10.4.11 PPC) suddenly seemed to stop recognizing that I had flash installed and wouldn't play anything requiring flash - instead a message came telling me to install it. I uninstalled flash and the installed the latest version for my computer from the adobe website (which is 10.1.102.64). Computer still thinks flash isn't installed and when I checked plugins I discovered firefox has blocked it telling me the version of flash I want to use is too old (even though the version I've downloaded is the latest I can use with my computer). How can I enable the plugin on firefox so I can use flash? The 'enable' button on the plugin has been greyed out so I can't press it. Please help - I'm rubbish with computers so please give any advice in very simple language! ( i have firefox 3.0.4)

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_4_11; en) AppleWebKit/533.19.4 (KHTML, like Gecko) Version/4.1.3 Safari/533.19.4

更多資訊

cor-el
  • Top 10 Contributor
  • Moderator
17567 個解決方法 158896 個答案

Try to disable blocklisting by setting the Boolean pref extensions.blocklist.enabled to false on the about:config page.

Also remove the blocklist.xml file and the pluginreg.dat file in the Firefox Profile Folder.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder
Try to disable blocklisting by setting the Boolean pref <b>extensions.blocklist.enabled</b> to <i>false</i> on the <b>about:config</b> page. *http://kb.mozillazine.org/about:config Also remove the blocklist.xml file and the pluginreg.dat file in the Firefox Profile Folder. You can use this button to go to the Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Open Containing Folder
philipp
  • Top 25 Contributor
  • Moderator
5320 個解決方法 23501 個答案

hello this should not have happened - mozilla recently uses the blocklist feature to notify users about the outdated flash plugin but not block it. you'd have to trigger a manual update of the blocklist and hope that this time the correct version is retrieved.

go to tools > web-developers > error console & copy the following line into the code field & hit evaluate:

Components.classes['@mozilla.org/extensions/blocklist;1'].getService(Components.interfaces.nsITimerCallback).notify(null);

sorry for the computer gibberish. afterwards restart the browser & see if you can enable the plugin in the addons manager again.

hello this should not have happened - mozilla recently uses the blocklist feature to notify users about the outdated flash plugin but not block it. you'd have to trigger a manual update of the blocklist and hope that this time the correct version is retrieved. go to tools > web-developers > error console & copy the following line into the code field & hit evaluate: ''Components.classes['@mozilla.org/extensions/blocklist;1'].getService(Components.interfaces.nsITimerCallback).notify(null);'' sorry for the computer gibberish. afterwards restart the browser & see if you can enable the plugin in the addons manager again.
ammyper 0 個解決方法 1 個答案

I was facing flash player error while playing angry birds. The thing you need to do just download the adobe flash player uninstaller and remove the old flash player after that install the fresh flash player from the adobe website. Restart your browser... This works for me.

I was facing flash player error while playing [http://angrybirdsonlinegames.org/ angry birds]. The thing you need to do just download the adobe flash player uninstaller and remove the old flash player after that install the fresh flash player from the adobe website. Restart your browser... This works for me.

由 ammyper 於 修改

James
  • Top 25 Contributor
  • Moderator
1600 個解決方法 11319 個答案

marigolds, The Firefox 3.0.4 is rather old and vulnerable as it came out back on November 12, 2008.

The last version from Mozilla to work on PPC macs is Firefox 3.6.28 which was made EOL in April. http://www.mozilla.org/en-US/firefox/all-older.html

marigolds, The Firefox 3.0.4 is rather old and vulnerable as it came out back on November 12, 200'''8'''. The last version from Mozilla to work on PPC macs is Firefox 3.6.28 which was made EOL in April. http://www.mozilla.org/en-US/firefox/all-older.html