X
點擊此處開啟此網站的行動版。

技術支援討論區

How to positively get rid of AVG Secure search

已張貼

I have tried many of the method suggested by user but AVG Secure Search is unaffected or goes away but keeps coming back.

I don't understand how it only seems to affect people running Firefox and why Firefox seems to rely completely on forums and suggestions by users as to how to fix it. Why is there not an official Firefox answer to this problem that seems to be a problem for a very large number of Firefox users?

I have tried many of the method suggested by user but AVG Secure Search is unaffected or goes away but keeps coming back. I don't understand how it only seems to affect people running Firefox and why Firefox seems to rely completely on forums and suggestions by users as to how to fix it. Why is there not an official Firefox answer to this problem that seems to be a problem for a very large number of Firefox users?

被選擇的解決方法

Good luck. I thought that about Babylon, then it turned up in Chrome.

從原來的回覆中察看解決方案 4

額外的系統細節

這發生了

每當開啟 Firefox 的時候

問題發生於...

Several weeks ago, not sure what caused it

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0

更多資訊

Most every search I do I get AVG Secure search. It sucks.

ianilku 3 個解決方法 34 個答案

Hi wdp1952 You can easily change the search preference. You can do this by clicking on search bar in your firefox and select you favorite search engine from the list.

Let me now if it works.

Hi wdp1952 You can easily change the search preference. You can do this by clicking on search bar in your firefox and select you favorite search engine from the list. Let me now if it works.

提出問題者

Can you be more specific? What do you mean, "click on the search bar"

Can you be more specific? What do you mean, "click on the search bar"
ianilku 3 個解決方法 34 個答案

Please fallow these steps change search engine

Please fallow these steps [https://support.mozilla.org/en-US/kb/Search%20bar change search engine]
Hasan 469 個解決方法 5600 個答案

see the following articles from AVG:

Check and tell if its working.

see the following articles from AVG: * Uninstalling AVG Security Toolbar -> http://www.avg.com/ww-en/faq.num-4367 * Changing the search provider in browser after uninstallation of AVG Security Toolbar -> http://www.avg.com/ww-en/faq.num-4369#tba3 * Disabling AVG Secure Search after removing the AVG Security Toolbar -> http://forums.avg.com/ww-en/avg-forums?sec=thread&act=show&id=195993#post_195993 * How To Disable AVG Secure Search.. in Mozilla Firefox -> http://forums.avg.com/ww-en/avg-forums?sec=thread&act=show&id=196406#post_196406 Check and tell if its working.
sunflowr 0 個解決方法 1 個答案

有幫助的回覆

05/29/2012

I found this somewhere. It worked for me. about:config did not work for me.

Here is the very simple solution to remove AVG secure search from Firefox.

I first uninstalled the avg toolbar using Revo Uninstaller (free program from cnet download)

1. Go to Firefox "Help". 2. Click "Restart with Add-ons Disabled" 3. Click "Restart". 4. The browser will close and a pop-up box will open. 5. Select "Reset all user preferences to Firefox defaults".

All adds on remained enabled. 6. Click "Make Changes and Restart".

05/29/2012 I found this somewhere. It worked for me. about:config did not work for me. Here is the very simple solution to remove AVG secure search from Firefox. I first uninstalled the avg toolbar using Revo Uninstaller (free program from cnet download) 1. Go to Firefox "Help". 2. Click "Restart with Add-ons Disabled" 3. Click "Restart". 4. The browser will close and a pop-up box will open. 5. Select "Reset all user preferences to Firefox defaults". All adds on remained enabled. 6. Click "Make Changes and Restart".

由 sunflowr 於 修改

提出問題者

I've tried several of the posted fixes, some complicated, some not. The one that worked for me was the one posted by sunflower. it's simply, easy and in my case effective.

wdp1952

I've tried several of the posted fixes, some complicated, some not. The one that worked for me was the one posted by sunflower. it's simply, easy and in my case effective. wdp1952
KerriB 0 個解決方法 7 個答案

Sorry, can't post good.

Sorry, can't post good.

由 KerriB 於 修改

KerriB 0 個解決方法 7 個答案

有幫助的回覆

Here is what to do, and it has worked great for me:

FOR FIREFOX... IF YOU NEED TO KNOW HOW FOR OTHER BROWSERS, LET ME KNOW.

1. Click the small arrow next to the search provider icon and select Manage Search Engines

2. Select the AVG Secure Search and Remove

3. Open the Firefox menu and select Options -> Options (or open the Tools menu and select the Options item).

4. Select the General tab and reset your home page.

5. Type about:config in the address bar and press Enter.

6. Press the I’ll be careful, I promise! Button.

7. Type search in the Search text box.

8. Right-click the browser.search.defaultenginename and select Reset from the context menu.

9. Type keyword in the Search text box.

10. Right-click the keyword.URL item and select Reset from the context menu.

11. Type browser.startup in the Search text box.

12. Right-click the browser.startup.homepage_override.mstone item and select Reset from the context menu.

13. Restart the Mozilla Firefox.

14. AVG Secure Search is now completely removed from the Mozilla Firefox browser.

Here is what to do, and it has worked great for me: FOR FIREFOX... IF YOU NEED TO KNOW HOW FOR OTHER BROWSERS, LET ME KNOW. 1. Click the small arrow next to the search provider icon and select '''Manage Search Engines'''… 2. Select the '''AVG Secure Search''' and '''Remove''' 3. Open the Firefox menu and select '''Options''' -> '''Options''' (or open the''' Tools''' menu and select the''' Options''' item). 4. Select the '''General''' tab and reset your home page. 5. Type '''about:config''' in the address bar and press '''Enter'''. 6. Press the''' I’ll be careful, I promise!''' Button. 7. Type '''search''' in the '''Search''' text box. 8. Right-click the '''browser.search.defaultenginename''' and select''' Reset '''from the context menu. 9. Type '''keyword''' in the '''Search''' text box. 10. Right-click the '''keyword.URL''' item and select''' Reset''' from the context menu. 11. Type '''browser.startup''' in the '''Search''' text box. 12. Right-click the''' browser.startup.homepage_override.mstone''' item and select '''Reset''' from the context menu. 13. Restart the Mozilla Firefox. 14. AVG Secure Search is now completely removed from the Mozilla Firefox browser.
rocklandweb 0 個解決方法 1 個答案

The collection of ideas on this post were very, very helpful. I used a combination of KerryB's and Sunflowr's posts, to completely nuke that annoying SafeSearch thing! AVG should stick with security and stop being so intrusive.

Lemme add one other thing to the mix. The combo of this, along with the preceding two, should get rid of SafeSearch:

1. Go to [Tools] >> [Add-Ons] >> [Extensions] 2. Disable AVG Security Toolbar, as well as any other items related to AVG. 3. Restart Firefox from the link provided, just above the disabled item(s)

Test it out by opening a few tabs.

That should do it!

The collection of ideas on this post were very, very helpful. I used a combination of KerryB's and Sunflowr's posts, to completely nuke that annoying SafeSearch thing! AVG should stick with security and stop being so intrusive. Lemme add one other thing to the mix. The combo of this, along with the preceding two, should get rid of SafeSearch: 1. Go to [Tools] >> [Add-Ons] >> [Extensions] 2. Disable AVG Security Toolbar, as well as any other items related to AVG. 3. Restart Firefox from the link provided, just above the disabled item(s) Test it out by opening a few tabs. That should do it!
gerebal1 0 個解決方法 3 個答案

After searching for quite a long time, and testing several approaches, I finally discovered a post in the avg forum that describes the procedure to be used in each an all main browsers, particularly Firefiox. Presently, in addition to all solutions listed everywhere and which did not function for me, there is one field in Firefox about:config that content reactivates the avg search. Go and have a look at : http://forums.avg.com/ww-en/avg-forums?sec=thread&act=show&id=196402#post_196402. for those who are too lazy to have a look, here is the full-fledged procedure: Mozilla Firefox

1. Click the small arrow next to the search provider icon and select Manage Search Engines… 2. Select the AVG Secure Search and Remove it as seen on this screenshot. 3. Open the Firefox menu and select Options -> Options (or open the Tools menu and select the Options item). 4. Select the General tab and reset your home page as seen on this screenshot. 5. Type about:config in the address bar and press Enter. 6. Press the I’ll be careful, I promise! Button. 7. Type search in the Search text box. 8. Right-click the browser.search.defaultenginename and select Reset from the context menu. 9. Type keyword in the Search text box. 10. Right-click the keyword.URL item and select Reset from the context menu. 11. Type browser.startup in the Search text box. 12. Right-click the browser.startup.homepage_override.mstone item and select Reset from the context menu. 13. Restart the Mozilla Firefox. 14. AVG Secure Search is now completely removed from the Mozilla Firefox browser.

And this is perfectly true.

Good luck folks

After searching for quite a long time, and testing several approaches, I finally discovered a post in the avg forum that describes the procedure to be used in each an all main browsers, particularly Firefiox. Presently, in addition to all solutions listed everywhere and which did not function for me, there is one field in Firefox about:config that content reactivates the avg search. Go and have a look at : http://forums.avg.com/ww-en/avg-forums?sec=thread&act=show&id=196402#post_196402. for those who are too lazy to have a look, here is the full-fledged procedure: Mozilla Firefox 1. Click the small arrow next to the search provider icon and select Manage Search Engines… 2. Select the AVG Secure Search and Remove it as seen on this screenshot. 3. Open the Firefox menu and select Options -> Options (or open the Tools menu and select the Options item). 4. Select the General tab and reset your home page as seen on this screenshot. 5. Type about:config in the address bar and press Enter. 6. Press the I’ll be careful, I promise! Button. 7. Type search in the Search text box. 8. Right-click the browser.search.defaultenginename and select Reset from the context menu. 9. Type keyword in the Search text box. 10. Right-click the keyword.URL item and select Reset from the context menu. 11. Type browser.startup in the Search text box. 12. Right-click the browser.startup.homepage_override.mstone item and select Reset from the context menu. 13. Restart the Mozilla Firefox. 14. AVG Secure Search is now completely removed from the Mozilla Firefox browser. And this is perfectly true. Good luck folks
gerebal1 0 個解決方法 3 個答案

Oooops, did not read carefully this thread, just realized that KerryB found the same procedure I did. Apologies, but for the link to avg forum which is useful to the users of other browsers...

Oooops, did not read carefully this thread, just realized that KerryB found the same procedure I did. Apologies, but for the link to avg forum which is useful to the users of other browsers...
llum 0 個解決方法 1 個答案

Can post instructions for getting rid of the Secure Search in Chrome?

Can post instructions for getting rid of the Secure Search in Chrome?
gerebal1 0 個解決方法 3 個答案

Here it is, with no guarantee as I did not test it (I stay with Firefox, it has characteristics and add-ons that I have not found in other browsers):

1. Click the wrench icon in the upper-right corner of the Chrome window and select Settings (or Options if using an older Chrome version). 2. Choose your search engine from the drop-down menu (or click the Basics tab in the older version.) 3. Or alternatively click the Manage search engines… and then easily remove unwanted search engines by clicking the X button (the button is visible after hovering your cursor above the respective search engine item.) .


Good luck

Here it is, with no guarantee as I did not test it (I stay with Firefox, it has characteristics and add-ons that I have not found in other browsers): 1. Click the wrench icon in the upper-right corner of the Chrome window and select Settings (or Options if using an older Chrome version). 2. Choose your search engine from the drop-down menu (or click the Basics tab in the older version.) 3. Or alternatively click the Manage search engines… and then easily remove unwanted search engines by clicking the X button (the button is visible after hovering your cursor above the respective search engine item.) . Good luck
mattdeany 0 個解決方法 6 個答案

KerriB's solution is fantastic! I've tried several complicated and simple ways of doing this. Simple resets, deleting remnants of program files for AVG and many other things great and small, without destroying my history, addons and other personalisations. This was great! Finally free! Matt

KerriB's solution is fantastic! I've tried several complicated and simple ways of doing this. Simple resets, deleting remnants of program files for AVG and many other things great and small, without destroying my history, addons and other personalisations. This was great! Finally free! Matt

由 mattdeany 於 修改

mattdeany 0 個解決方法 6 個答案

Thanks!

Thanks!

由 mattdeany 於 修改

samoo7 0 個解決方法 1 個答案

Listed below are according to browser, dear fellow just want to let you know please try this things and it will totally remove the AVG Search from your browser. I have done it and posting the solution so that everyone can be familiar with such kind of situation. IE and chrome are easy to remove but in Firefox its little hard.

So please follow all the steps to overcome the problem.


Internet Explorer 9

1. Press the Windows logo key and R simultaneously.

2. Type inetcpl.cpl and click OK.

3. Click the Programs tab.

4. Click the Manage add-ons button.

5.You can select any of the available search providers in the list, set it as default or remove it. Before removing a search provider, please make sure to set another one as your default search provider. If your favorite search provider is not in the list, click the Find more search providers blue link in the lower part of the window.

7. Also, you could prevent programs from changing your default search provider and enable or disable searching in the address bar.

8. All changes are applied immediately; when the configuration suits your needs, simply click the Close button.

While using the AVG Secure Search provider, you could have changed your home page by clicking the Set as homepage link in the upper-right corner of the AVG Secure Search page. If you wish to change your default home page now, please proceed as follows:

1. Open the desired web page (e.g. your favorite search portal) in your Internet Explorer browser.

2. Right click the “home” icon in upper-right corner of the window.

3. Select Add or change home page in the menu.

4. Then, select the Use this webpage as your only home page option and confirm your choice.


Internet Explorer 8

If you are using Windows Vista or Windows 7, we strongly recommend upgrading to the most recent Internet Explorer version. Please run the Windows Update facility if you wish to download Internet Explorer 9. (The Internet Explorer 9 is not available for older Windows versions, such as the Windows XP.)

1. Press the Windows logo key and R simultaneously.

2. Type inetcpl.cpl and click OK.

3. Click the Programs tab.

4. Click the Manage add-ons button.

5. You can select any of the available search providers in the list, set it as default or remove it. Before removing a search provider, please make sure to set another one as your default search provider. If your favorite search provider is not in the list, click the Find more search providers blue link in the lower part of the window.

7. Also, you could prevent programs from changing your default search provider.

8. All changes are applied immediately; when the configuration suits your needs, simply click the Close button.


If you wish to change your default home page, please proceed as follows:

1. Open the desired web page (e.g. your favorite search portal) using the Internet Explorer 8 browser.

2. Click the small black arrow next to the “home” button and select Add or change home page.

3. Then, select the Use this webpage as your only home page option and confirm your choice.


Mozilla Firefox

1. Click the small arrow next to the search provider icon and select Manage Search Engines…

2. Open the Firefox menu and select Options -> Options (or open the Tools menu and select the Options item).

4. Select the General tab and reset your home page.

5. Type about:config in the address bar and press Enter.

6. Press the I’ll be careful, I promise! Button.

7. Type search in the Search text box.

8. Right-click the browser.search.defaultenginename and select Reset from the context menu.

9. Type keyword in the Search text box.

10. Right-click the keyword.URL item and select Reset from the context menu.

11. Type browser.startup in the Search text box.

12. Right-click the browser.startup.homepage_override.mstone item and select Reset from the context menu.

13. Restart the Mozilla Firefox.

14. AVG Secure Search is now completely removed from the Mozilla Firefox browser.


Google Chrome

1. Click the wrench icon in the upper-right corner of the Chrome window and select Settings (or Options if using an older Chrome version).

2. Choose your search engine from the drop-down menu (or click the Basics tab in the older version.)

3. Or alternatively click the Manage search engines… and then easily remove unwanted search engines by clicking the X button (the button is visible after hovering your cursor above the respective search engine item.)

Listed below are according to browser, dear fellow just want to let you know please try this things and it will totally remove the AVG Search from your browser. I have done it and posting the solution so that everyone can be familiar with such kind of situation. IE and chrome are easy to remove but in Firefox its little hard. So please follow all the steps to overcome the problem. '''Internet Explorer 9''' 1. Press the Windows logo key and R simultaneously. 2. Type inetcpl.cpl and click OK. 3. Click the Programs tab. 4. Click the Manage add-ons button. 5.You can select any of the available search providers in the list, set it as default or remove it. Before removing a search provider, please make sure to set another one as your default search provider. If your favorite search provider is not in the list, click the Find more search providers blue link in the lower part of the window. 7. Also, you could prevent programs from changing your default search provider and enable or disable searching in the address bar. 8. All changes are applied immediately; when the configuration suits your needs, simply click the Close button. While using the AVG Secure Search provider, you could have changed your home page by clicking the Set as homepage link in the upper-right corner of the AVG Secure Search page. If you wish to change your default home page now, please proceed as follows: 1. Open the desired web page (e.g. your favorite search portal) in your Internet Explorer browser. 2. Right click the “home” icon in upper-right corner of the window. 3. Select Add or change home page in the menu. 4. Then, select the Use this webpage as your only home page option and confirm your choice. '''Internet Explorer 8''' If you are using Windows Vista or Windows 7, we strongly recommend upgrading to the most recent Internet Explorer version. Please run the Windows Update facility if you wish to download Internet Explorer 9. (The Internet Explorer 9 is not available for older Windows versions, such as the Windows XP.) 1. Press the Windows logo key and R simultaneously. 2. Type inetcpl.cpl and click OK. 3. Click the Programs tab. 4. Click the Manage add-ons button. 5. You can select any of the available search providers in the list, set it as default or remove it. Before removing a search provider, please make sure to set another one as your default search provider. If your favorite search provider is not in the list, click the Find more search providers blue link in the lower part of the window. 7. Also, you could prevent programs from changing your default search provider. 8. All changes are applied immediately; when the configuration suits your needs, simply click the Close button. If you wish to change your default home page, please proceed as follows: 1. Open the desired web page (e.g. your favorite search portal) using the Internet Explorer 8 browser. 2. Click the small black arrow next to the “home” button and select Add or change home page. 3. Then, select the Use this webpage as your only home page option and confirm your choice. '''Mozilla Firefox''' 1. Click the small arrow next to the search provider icon and select Manage Search Engines… 2. Open the Firefox menu and select Options -> Options (or open the Tools menu and select the Options item). 4. Select the General tab and reset your home page. 5. Type about:config in the address bar and press Enter. 6. Press the I’ll be careful, I promise! Button. 7. Type search in the Search text box. 8. Right-click the browser.search.defaultenginename and select Reset from the context menu. 9. Type keyword in the Search text box. 10. Right-click the keyword.URL item and select Reset from the context menu. 11. Type browser.startup in the Search text box. 12. Right-click the browser.startup.homepage_override.mstone item and select Reset from the context menu. 13. Restart the Mozilla Firefox. 14. AVG Secure Search is now completely removed from the Mozilla Firefox browser. '''Google Chrome''' 1. Click the wrench icon in the upper-right corner of the Chrome window and select Settings (or Options if using an older Chrome version). 2. Choose your search engine from the drop-down menu (or click the Basics tab in the older version.) 3. Or alternatively click the Manage search engines… and then easily remove unwanted search engines by clicking the X button (the button is visible after hovering your cursor above the respective search engine item.)

由 samoo7 於 修改

otagonza18 0 個解決方法 1 個答案

I did it and it worked !!!! Finally I could get rid of that annoying "avg secure engine" !!!

thanks a lot for your help !!!!

I did it and it worked !!!! Finally I could get rid of that annoying "avg secure engine" !!! thanks a lot for your help !!!!
KerriB 0 個解決方法 7 個答案

This works great for Firefox!

1. Click the small arrow next to the search provider icon and select Manage Search Engines

2. Select the AVG Secure Search and Remove 3. Open the Firefox menu and select Options -> Options (or open the Tools menu and select the Options item).

4. Select the General tab and reset your home page.

5. Type about:config in the address bar and press Enter.

6. Press the I’ll be careful, I promise! Button.

7. Type search in the Search text box.

8. Right-click the browser.search.defaultenginename and select Reset from the context menu.

9. Type keyword in the Search text box.

10. Right-click the keyword.URL item and select Reset from the context menu.

11. Type browser.startup in the Search text box.

12. Right-click the browser.startup.homepage_override.mstone item and select Reset from the context menu.

13. Restart the Mozilla Firefox.

'''This works great for Firefox!''' 1. Click the small arrow next to the search provider icon and select '''Manage Search Engines'''… 2. Select the '''AVG Secure Search''' and '''Remove ''' 3. Open the Firefox menu and select''' Options''' -> '''Options''' (or open the '''Tools''' menu and select the '''Options''' item). 4. Select the '''General''' tab and reset your home page. 5. Type '''about:config''' in the address bar and press '''Enter'''. 6. Press the '''I’ll be careful, I promise! Button.''' 7. Type '''search''' in the Search text box. 8. Right-click the '''browser.search.defaultenginename''' and select '''Reset''' from the context menu. 9. Type '''keyword''' in the Search text box. 10. Right-click the '''keyword.URL''' item and select '''Reset''' from the context menu. 11. Type '''browser.startup''' in the Search text box. 12. Right-click the '''browser.startup.homepage_override.mstone''' item and select '''Reset''' from the context menu. 13. Restart the Mozilla Firefox.
krithika 0 個解決方法 1 個答案

and it must be removed from add-ons also which is most important.

and it must be removed from add-ons also which is most important.
fairyme 0 個解決方法 1 個答案

FREE at last.....AVG Secure Search. I did everything, but still it was on my computer. Thank you (have forgotten who after all this) but logic says - you can disable it, but you have to go back to the source - that is AVG installation and remove it there.

I went into Control Panel - Programs - Select AVG 2012 installation - Click on Change .......then go through the installation process. When it comes to the boxes of ADD/REMOVE you can then remove the Secure Search.....

I'm still keeping the free 2012 Antivirus to see how it goes without stuffing things up.

'''FREE''' at last.....AVG Secure Search. I did everything, but still it was on my computer. Thank you (have forgotten who after all this) but logic says - you can disable it, but you have to go back to the source - that is AVG installation and remove it there. I went into ''Control Panel - Programs - Select AVG 2012 installation - Click on Change ''.......then go through the installation process. When it comes to the boxes of ADD/REMOVE you can then remove the Secure Search..... I'm still keeping the free 2012 Antivirus to see how it goes without stuffing things up.