搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

firefox 12 not showing site favicons by url bar consistently, how to fix?

  • 8 回覆
  • 21 有這個問題
  • 1202 次檢視
  • 最近回覆由 cor-el

more options

i'm a webmaster so i have access to insert icon into a joomla website, the pages all have <link rel="shortcut icon" type="image/x-icon" href="/favicon.ico" /> added anyway as its a joomla 2,5 site.

icon shows ok for the domain name page which is a simple index.htm, without the above code! but no favicon for any domain name/index.php page.. even with the code added above.

bookmarks newly taken on the site pages are blank favicon too,

the pre-upgrade bookmarks are retained as are any websites favicons already visited before upgrade to v12

how to fix the blindness to site favicons?

as far as i know its a 16 by 16 pixel favicon, it was produced online.

被選擇的解決方法

I've no problems with seeing favicons on the three sites in your PM on the Tab bar (future Firefox 14+ versions won't show the favicon on the location bar).
They are all send as Content-Type: image/x-icon by the server.

I do notice that there are two different favicons available for the first two links that you provide. Your page code specifies /templates/pulsar/favicon.ico (a star shaped icon;Content-Length: 1150), but there is also another favicon (Content-Length: 894) in the root folder of the site that looks different.
I don't know which favicon you intent to show up (Firefox shows the specified star icon for me).

No problem with the S shaped icon on the third link either.

You can try to use the Live Http Headers extension to check if there is a request send for the favicons and the the response from the server.
You can also check Tools > Page Info > Media to see if the favicon shows there.


You can do a standard test for problems with images.

If images are missing then check that you aren't blocking images from some domains.

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

Make sure that you do not block third-party images, the permissions.default.images pref should be 1.

There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images.

從原來的回覆中察看解決方案 👍 0

所有回覆 (8)

more options

Can you post a link to a public page that doesn't require authentication (log in) to access it, so we can check it?

more options

give me an email address or method i can send the url's privately to you please, these are sites we don't want searchable on the web just yet.

more options

you can send cor-el a private message, just click on his avatar when logged in on this forum

more options

thanks madperson i pm'd him now.

more options

選擇的解決方法

I've no problems with seeing favicons on the three sites in your PM on the Tab bar (future Firefox 14+ versions won't show the favicon on the location bar).
They are all send as Content-Type: image/x-icon by the server.

I do notice that there are two different favicons available for the first two links that you provide. Your page code specifies /templates/pulsar/favicon.ico (a star shaped icon;Content-Length: 1150), but there is also another favicon (Content-Length: 894) in the root folder of the site that looks different.
I don't know which favicon you intent to show up (Firefox shows the specified star icon for me).

No problem with the S shaped icon on the third link either.

You can try to use the Live Http Headers extension to check if there is a request send for the favicons and the the response from the server.
You can also check Tools > Page Info > Media to see if the favicon shows there.


You can do a standard test for problems with images.

If images are missing then check that you aren't blocking images from some domains.

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

Make sure that you do not block third-party images, the permissions.default.images pref should be 1.

There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images.

more options

ok thanks i'll look into all that and get back

more options

hi thanks so much.. the naughty pulsar joomla template has a star favicon as you say, and they don't tell you its there. prob solved, now that pulsar star is deleted the root favicon shows ok.

sorry to have put you to trouble!

more options

You're welcome