X
點擊此處開啟此網站的行動版。

技術支援討論區

how to uninstall a Yahoo-affiliated "Search Here" functionality from Firefox

已張貼

I picked up a Yahoo Search functionality inside Firefox but there was no Yahoo toolbar. I ran Revo Uninstaller and there was no listing for Yahoo. I ran Add/Remove Programs in the Control Panel but there was no listing for Yahoo. However, in my Programs File under My Computer there is a folder titled Yahoo.

Whenever I opened Firefox I would get a Yahoo Search page instead of Google. I did a bunch of searches for solutions and found that I needed to delete all of the search listings in the drop down list from clicking the gray arrow in the search box.

They were all in there – Google, Yahoo, Bing, Twitter, and an odd entry called “Search Here” I deleted everything except Google. Then I went to about:config and reset the Keyword URL to the Google entry it was supposed to be.

I thought everything was fine but all of this left me with some strange Search Here window next to the Firefox Tabs and the same Search Here entry in the drop down list previously changed.

If I perform a search from the search window next to the open tabs I get a Yahoo Search result:

If I perform a search from Google I get a Google result as I should.

Interestingly, the Search Here listing appears again automatically in the listing of search engines.

I picked up a Yahoo Search functionality inside Firefox but there was no Yahoo toolbar. I ran Revo Uninstaller and there was no listing for Yahoo. I ran Add/Remove Programs in the Control Panel but there was no listing for Yahoo. However, in my Programs File under My Computer there is a folder titled Yahoo. Whenever I opened Firefox I would get a Yahoo Search page instead of Google. I did a bunch of searches for solutions and found that I needed to delete all of the search listings in the drop down list from clicking the gray arrow in the search box. They were all in there – Google, Yahoo, Bing, Twitter, and an odd entry called “Search Here” I deleted everything except Google. Then I went to about:config and reset the Keyword URL to the Google entry it was supposed to be. I thought everything was fine but all of this left me with some strange Search Here window next to the Firefox Tabs and the same Search Here entry in the drop down list previously changed. If I perform a search from the search window next to the open tabs I get a Yahoo Search result: If I perform a search from Google I get a Google result as I should. Interestingly, the Search Here listing appears again automatically in the listing of search engines.

額外的系統細節

這發生了

每當開啟 Firefox 的時候

問題發生於...

Probably when I installed a program and has been happening only for the last few weeks

已安裝的外掛程式

  • GEPlugin
  • Google Update
  • Shockwave Flash 11.1 r102
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • LogMeIn, Inc. Remote Access Components
  • 4.1.10111.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • FreshDownload Plugin
  • Garmin Communicator Plug-In 3.0.1.0
  • Sling Player Plug-In for Mozilla
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Office Plugin for Netscape Navigator

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:11.0) Gecko/20100101 Firefox/11.0

更多資訊

Cleared the drop down list of search engines, Search Here automatically populates.
Changed the keyword URL in about:config but there was no change.
Deleted the Yahoo folder from Program Files folder with no change.
The same functionality does NOT appear on my desktop or other laptop even though their Firefox applications are setup the same way.

user633449 1539 個解決方法 10745 個答案

有幫助的回覆

If you install https://addons.mozilla.org/en-US/firefox/addon/searchreset/, does that help? This basically resets your search engines to default

If you install [https://addons.mozilla.org/en-US/firefox/addon/searchreset/ https://addons.mozilla.org/en-US/firefox/addon/searchreset/], does that help? This basically resets your search engines to default

提出問題者

Thank you for trying to help. I should have noted in the original posting that I had already tried that solution without positive results.

This darn thing is tenacious and insidious, and quite frankly a pain in a portion of the human anatomy.

I have screenshots of these added elements if anyone is interested in seeing them.

Thanks again.

Thank you for trying to help. I should have noted in the original posting that I had already tried that solution without positive results. This darn thing is tenacious and insidious, and quite frankly a pain in a portion of the human anatomy. I have screenshots of these added elements if anyone is interested in seeing them. Thanks again.
Terraj 0 個解決方法 1 個答案

OK have a solution for you. Go to uninstall and or remove programs tab. Then list all the files by the date that they were modified on. Look for a file that was modified the day your explorer got messed up. (probably the most recent one) then delete that. Worked like a charm for me and i am free of the TROLL yahoo search bar. YAHOO SHOULD BE SHUT DOWN BECAUSE OF THIS CRAP!......anyways, The name is inconspicuous... i forget exactly what it was because I deleted it already but thats how i found it. Hope that helps!

OK have a solution for you. Go to uninstall and or remove programs tab. Then list all the files by the date that they were modified on. Look for a file that was modified the day your explorer got messed up. (probably the most recent one) then delete that. Worked like a charm for me and i am free of the TROLL yahoo search bar. YAHOO SHOULD BE SHUT DOWN BECAUSE OF THIS CRAP!......anyways, The name is inconspicuous... i forget exactly what it was because I deleted it already but thats how i found it. Hope that helps!

由 Terraj 於 修改

mechel18 0 個解決方法 1 個答案

Go to Tools/Add-ons and one-by-one Disable any Add-ons you don’t recognize until you find the one putting the “Search Here” box on the Tab toolbar. Once you find the “Search Here” Add-on just remove it. You should then also remove “Search Here” from the Search Engine list. Use the little down arrow to pull down the list, click on “Manage Search Engines” then find and remove “Search Here.”

Go to Tools/Add-ons and one-by-one Disable any Add-ons you don’t recognize until you find the one putting the “Search Here” box on the Tab toolbar. Once you find the “Search Here” Add-on just remove it. You should then also remove “Search Here” from the Search Engine list. Use the little down arrow to pull down the list, click on “Manage Search Engines” then find and remove “Search Here.”
maximblack82 0 個解決方法 1 個答案

Hi guys. I had same problem and tryed most of your sugestions with no succes but here is solution for this Yahoo pain in ars. - Go to Control Panel/Uninstall Program/ - Under program name look for Default Tab or Pad or under Publisher column look for Search Results LLC - Click and uninstall this damn thing

Hi guys. I had same problem and tryed most of your sugestions with no succes but here is solution for this Yahoo pain in ars. - Go to Control Panel/Uninstall Program/ - Under program name look for Default Tab or Pad or under Publisher column look for Search Results LLC - Click and uninstall this damn thing
sunrisearts 0 個解決方法 1 個答案

I had the search here toolbar as well, tried doing a computer search and deleting it but it still appeared. The solution is to right click on the search here icon on the toolbar itself and remove it that way.....hope this helps guys

I had the search here toolbar as well, tried doing a computer search and deleting it but it still appeared. The solution is to right click on the search here icon on the toolbar itself and remove it that way.....hope this helps guys
GTocz5 0 個解決方法 1 個答案

Try removing under add/uninstall programs Search Qu toolbar. It sort of helped.

Try removing under add/uninstall programs Search Qu toolbar. It sort of helped.
davidtleblanc 0 個解決方法 1 個答案

有幫助的回覆

The add-on is called default tab in Add-ons manager. Remove that and it's gone. Finally. It's a clever and innocuous title. I went over it several times before I could figure it out.

The add-on is called default tab in Add-ons manager. Remove that and it's gone. Finally. It's a clever and innocuous title. I went over it several times before I could figure it out.
dubious1 0 個解決方法 4 個答案

Unfortunately, none of the fixes suggested here work for OSX. It's not in my Add-ons or Extensions, and OSX has nothing comparable to the Windows uninstall feature. I checked my Receipts folder, but found nothing.

Suggestions welcome

Unfortunately, none of the fixes suggested here work for OSX. It's not in my Add-ons or Extensions, and OSX has nothing comparable to the Windows uninstall feature. I checked my Receipts folder, but found nothing. Suggestions welcome
mi-dad 0 個解決方法 4 個答案

Had the same damn 'search here' toolbar. myself Try this: Go to Tools: add-ons extensions Remove 'Default tab' Next clear the url bar and type in: 'about:config' press 'search' A warning comes up,but ignore this and proceed. A search box appears at the top. Type in 'search here' Press 'search' Highlight the results then 'right click' and press 'reset' Restart Firefox... Next left click on the damn toolbar icon itself. This gives a drop down box with the option to 'manage search engines' Highlight the one (or ones) you wish to get rid of,then click 'REMOVE' ......Worked for me!

Had the same damn 'search here' toolbar. myself Try this: Go to Tools: add-ons extensions Remove 'Default tab' Next clear the url bar and type in: 'about:config' press 'search' A warning comes up,but ignore this and proceed. A search box appears at the top. Type in 'search here' Press 'search' Highlight the results then 'right click' and press 'reset' Restart Firefox... Next left click on the damn toolbar icon itself. This gives a drop down box with the option to 'manage search engines' Highlight the one (or ones) you wish to get rid of,then click 'REMOVE' ......Worked for me!

由 mi-dad 於 修改

dubious1 0 個解決方法 4 個答案

That fix works only temporarily for me. After a few minutes, "Search Here" resurrects itself somehow.

That fix works only temporarily for me. After a few minutes, "Search Here" resurrects itself somehow.
mi-dad 0 個解決方法 4 個答案

Sorry about that. Have updated the original post with some extra info for you. Good Luck!

Sorry about that. Have updated the original post with some extra info for you. Good Luck!
dubious1 0 個解決方法 4 個答案

Your directions say "Highlight the results then press reset" but I don't see a reset button or option anywhere. Where is it located please?

Your directions say "Highlight the results then press reset" but I don't see a reset button or option anywhere. Where is it located please?
mi-dad 0 個解決方法 4 個答案

Sorry,Do apologize. But am on an airfield in torrential rain at the moment with no pc access,should have stated...

'right click' on entry when highlighted this should give you the 'reset' option...

Sorry,Do apologize. But am on an airfield in torrential rain at the moment with no pc access,should have stated... 'right click' on entry when highlighted this should give you the 'reset' option...

由 mi-dad 於 修改

cor-el
  • Top 10 Contributor
  • Moderator
17697 個解決方法 160124 個答案

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

If it does work in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do not click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode If it does work in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears. Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit") *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
dubious1 0 個解決方法 4 個答案

@mi-dad: That worked. 2 FF restarts and 3 days later, and "Search Here" is still gone.

The crucial steps for OSX are those involving about:config -- without those, merely removing it from the list of search engines works only temporarily.

Don't know how you sorted that out but thanks very much!

@mi-dad: That worked. 2 FF restarts and 3 days later, and "Search Here" is still gone. The crucial steps for OSX are those involving about:config -- without those, merely removing it from the list of search engines works only temporarily. Don't know how you sorted that out but thanks very much!
mi-dad 0 個解決方法 4 個答案

You 're welcome. Should work for any unwanted toolbars...

You 're welcome. Should work for any unwanted toolbars...