搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Insecure version of Firefox? I've just updated!

  • 18 回覆
  • 15 有這個問題
  • 89 次檢視
  • 最近回覆由 SafeBrowser

more options

I updated to Firefox 12 about 20 minutes ago, restarted my PC, but the Firefox Help page (the first page after clicking on 'Firefox Help') says I'm using an insecure version - why? More importantly, is my version secure? Thanks.

所有回覆 (18)

more options

I'd also like to know why Firefox didn't update from 11 to 12 automatically please.

more options

would you mind copying and pasting the website that you are seeing this issue on into this thread? It may be that the wording on that page needs to be updated. But Firefox 12 that you are running is secure :) sorry about the confusion.

And Firefox isn't automatically updating yet, just to make sure there are no major issues before a mass update is pushed in the next day or two.

more options

Thanks for replying - it's at https://support.mozilla.org/en-US/home?as=u#os=win&browser=fx11 - I'm still seeing the message but glad to know I'm all snug and secure! Thanks again.

more options

You probably recently accessed support and picked Firefox 11 in the dropdown in the right sidebar so it's giving you messaging for Firefox 11 (which in this case is now out of date)

more options

I'm seeing the same thing. Just updated from FF11 to FF12 and hit the help page and got presented with the "You're using an insecure version......" message. Running FF12 Win7 ult x64

more options

Same problem here. Have FF12 and OSX 7

more options

The other thing to check is to make sure that you don't have anything corrupting your user agent. Go to about:config in your location bar (no spaces). Click OK at the warning and then put useragent in the search box. Make sure that everything is the default (right click on any that are not and select reset to default, if necessary).

Some extensions may corrupt your user agent so these changes may not "stick" and you should disable the offending ones.

more options

Both are set to default thanks. I see it's still saying it, and 10 other people have the same problem. Just out of interest, if you click on the link I gave above, what do you see?

more options

If you have manually changed the selection of the browser or the OS when looking at Knowledge Base items clearing your cookies will reset it to normal so that you see the correct page.

Once cleared you should see the pages relevant to your browser (as per the User Agent String). There is a similar cookie for the OS.

more options

The link you gave has os=win&browser=fx11 in the URL which tells this site to show content for Firefox 11 (which would then show you as out of date)

more options

The link that you posted, is looking specifically for Firefox 11 (browser=fx11) on a system running Windows (os=win).

Try the link below and see what you get (this is the real address without regard to OS or a particular Firefox version)


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

more options

Is "user agent" and "about:config" a Windows thing? I have the problem with my MacBook Pro, OSX 7, FF 12.

more options

That works! I see now that the URL has fx-11 on the end, presumably meaning Firefox 11.

(I hit 'helpful' next to your reply - couldn't see 'solved it')

more options

Only one reply can be marked as the solution. Since you have previously marked another reply as the solution, you must "Undo" that choice before choosing another reply as the solution. "Undo" will be available only to the original poster of the original question when signed in to the forum. You click "Undo" then you will see "Solved It" to the right of other replies.

more options

Thanks (kudos to Cww too!).

more options

Are any of these solutions applicable to a Mac OSX 7 platform?

more options

They should all be cross-platform.

more options

Milwauken:

The following is what solved the problem for adeh999.

Go to the following link and see what results you get --> https://support.mozilla.org/en-US/home