搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox 11.0/12.0 does not launch and provides no error message, how can I fix this? Windows 7/8

  • 14 回覆
  • 25 有這個問題
  • 697 次檢視
  • 最近回覆由 John99

more options

Running Windows 7 on one partition, and Windows 8 Consumer Preview on another, Firefox does not open for either. Firefox crashes upon opening without an error message. I have reinstalled and manually cleared profile information. If I create a new profile, it works until I close and try to relaunch requiring me to make a new profile. I have tried removing/reinstalling java as well (just in case), as I had been editing some of the java installation from my Windows 7 partition.

As I launch the Firefox, if I watch the task manager, Firefox.exe appears for a moment, but disappears almost immediately. No files appear in 'C:\Users\[Username]\AppData\Roaming\Mozilla\Firefox\Crash Reports' directory with the exception of the 'InstallTime*********' file.


  • Information posted in the "Troubleshooting Information" section below is from the Windows 8 Consumer Preview partition. There are some errors with my display driver not being updated properly, but Firefox -was- working on Windows 8 Consumer Preview until just recently, so I am assuming that is not part of the issue.

被選擇的解決方法

Why not instead of downgrading an existing Firefox to earlier versions, consider trying multiple installs.

Firefox portable is designed as an easy to install method of using Firefox as an additional browser.

With your expertise installing manually multiple versions of Firefox will also be easy, just use separate unique profiles for each version. Utilise the built in profile manager or the standalone version to help you. Such testing does not require any additional partitions, and need not include changes to the existing firefox installs and profiles.

從原來的回覆中察看解決方案 👍 1

所有回覆 (14)

more options

The fact that a new profile works normally suggests problems are in the profile.

  • Have you ever had firefox working on Windows 7
  • Is the firefox installation self contained within each partition
    or are you attempting to use some files off both partitions or an additional partition

I have only a limited understanding of Windows 7, having used XP mainly with Firefox. (At present I am on a linux multiboot machine that includes a Windows 7 partition.)

If you are not getting crash reports it may well be that firefox itself is not crashing, either it is hanging, or some third party software is interfering. Maybe security related software is blocking or reversing changes.

more options

That's my assumption as well, that it is a profile issue. So in response:

  • Yes, it was working on both Windows 7 and Windows 8
  • The installations are separate for each partition, installed under separate directories.

In regards to third party software, both installations are fresh as of a couple of weeks ago, and only have MSOffice, Mozilla Firefox, Google Chrome, iTunes, CCleaner, MATLAB, Microsoft Security Essentials and Skype installed at this time. So, as far as a security software, I only have Microsoft Security Essentials now since I'm fiddling with setup/installations, which should be sufficient, and I've not had it cause issues before.

Both accounts are Administrator accounts, however not the built in default (as this causes issues on Windows 8)

Also, if I install plugins to Firefox on Windows 8, and click "restart browser", it is able to restart the browser and apply the settings/addons (such as AdBlock Plus and AutoPager).

The plugins I was using before were: AdBlock Plus Download Statusbar AutoPager Persona Plus

Of which I have used for an extended period without issue (so I assume it isn't an issue with the plugins being attached to the profile).

Edit: I have imported my bookmarks from an older file, is it possible that there is corrupt data being imported that way? I don't think I've imported every time, but maybe there could be something there. [03/31/2012 11:55am UTC-6:00]

由 DanielBernard 於 修改

more options

I can not see that corrupt bookmarks would be likely to cause a problem. If in doubt rename the bookmarks database (places.sqlite) or try a new profile to rule out that possibility.

Microsoft Security Essentials seems simple but effective, and works ok on my Windows partition with the Release and Aurora channels of firefox. Skype has sometimes cause problems with firefox in the past IIRC, and I imagine CCleaner could potentially make unexpected changes to the firefox profile.

Try Firefox as a clean install on Windows 7 with a new profile. (do not delete the original) and with a new profile. Try to work out whether Firefox is being stopped by other software, hanging, or crashing see:

more options

Did you use the Bookmarks Manager to import the bookmarks or did you copy file to the new profile folder?

Does it also happen with a clean profile without modifications?

more options

RE: John99 I have tried removing Skype, and I have run a clean install after having run CCleaner, so I'm guessing they aren't a part of the issue (I removed CCleaner as well, even though it doesn't have a passive scan, just in case some of the registries are interfering or something).

In regards to whether or not it's crashing or hanging, the process disappears from the Task Manager (as described below), and so a Mozilla Crash Reporter window does not appear. Additionally, it is not able to launch a window after the initial launch/close, and so I have not seen it hang.

Oh, also, I had -not- been using the plugin from Skype, which I think had issues with Firefox, but I don't know if that was the issue that you were referring to or not, and so I simply removed it as it wasn't really necessary.


RE: cor-el I was using the Bookmarks Manager to import. I went through last night and tried a variety of completely removing all Firefox components from my HDD including registries, and done a clean installation of both 11 and 12 separately.

From first launch, it has me create a new profile, which I do, using the default name in case there is somehow a character issue not being handled. I let it load the window, with the initial Welcome tab and Home tab.

Upon verifying that one instance is running in the task manager. At this point, I closed the browser (so no modifications, no bookmarks, etc.) and make sure it's process in the Task Manager has stopped (no longer listed, not that I'm manually ending it).

As soon as I go to relaunch firefox.exe, it appears for a brief second in the task manager, and then disappears.

The only way I can reopen Firefox then from that installation, is by changing the profile settings .ini so that it requests which profile I would like to select at startup each time. At which point, if I select an already used profile, the process disappears, and if I create a new profile, it is able to launch the two initial tabs, but obviously it's a new profile every time then.


And just to verify, I have tested the aforementioned steps with both 7 and 8.


EDIT: I forgot to mention as well, but Firefox launches the same way with Safe Mode; appears for a moment, and then disappears in the Task Manager

由 DanielBernard 於 修改

more options

Sorry I have not really any more ideas. Although I am wondering if you ever tried a clean profile. If the Firefox Installer is creating a profile as you install Firefox, that will be based on the existing profile.

I was suggesting

  1. Use a clean install, having first removed the existing program files, or at least installing in a different location
  2. Using a new profile, specifically create a new profile, ensure it has no add-ons or bookmarks etc

From first launch, it has me create a new profile, which I do, using the default name in case there is somehow a character issue not being handled. I am not sure I follow that comment IIRC when Firefox installs it creates a default profile without needing user interaction.

more options

Well, I appreciate you throwing ideas around, any suggestion is always helpful.

Tried a clean install to no avail. Made sure to install in a new directory, made sure all previous files were cleaned out. It still prompts me to make a new profile at initial launch...Not sure if this is an issue somehow?

more options

Which security software (firewall, anti-virus) do you have?

A possible cause is security software (firewall) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

more options

As posted above, I'm using Microsoft Security Essentials for an anti-virus; there are no rules blocking Firefox. I'm using the default Windows (7) Firewall, in which Firefox is already being allowed through.

more options

Recently it has been discovered that some 3rd party software can crash Firefox instantly on startup. One program known to do this is Naomi Internet Filter.

It crashes Firefox even after creating a new profile or uninstalling then reinstalling Firefox. Even crashes Firefox Safe Mode as well.

I see that its program directory is in C:\Program Files\rnamfler

You may or may not have it installed. The solution if you have Naomi Filter installed is to uninstall it. That was the only fix found for that.

I'm thinking you probably have another odd software installed that could be causing this. Maybe a quick browse thru Add/Remove Programs would help you spot something? Maybe you have another program that filters internet or monitors your internet traffic in some way? Or system restore software like DeepFreeze?

Also the Covenant Eyes internet filtering service crashes Firefox as well but not as severely as Naomi does. You can at least surf around on the web before crashing. Just mentioning this in case you do have it or others who do read this reply.

New theory:
Honestly, after re-reading your original post I'm just convinced this is a problem with Windows 8 or how you setup your partition (as weird as that sounds). Or that Firefox hasn't been properly coded on Windows 8 and there are conflicts. I know you said it also doesn't work on your Win 7 partition on the same drive but Win 8 still may be responsible somehow.

Could you try a lower version of Firefox until you find one that does work? For example Firefox 10 or 9? Maybe even Firefox 3.6.28? Links below:

Or you could try the newer builds created every night from:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/firefox-14.0a1.en-US.win32.installer.exe

由 NoahSUMO 於 修改

more options

Noah_SUMO, Regarding Naomi Internet Filter, I verified that it was -not- something installed (I hadn't heard of it before, but I made sure nevertheless in case it piggybacked on something). As far as system restore software, I keep none =x Never have, and I change over OS's relatively often (I went from 7 this past fall to 7/Kubuntu/BTLinux, to 8DeveloperPreview/Kubuntu/BTLinux, to overwriting Kubuntu with 7 a few weeks later, overwrote 8DevPrev to 8ConsumerPreview, and then removed both linux partitions and remerged with a fresh install of two separate partitions for 7 and 8 (I help with some OS compatibility/stress testing for a friend's software development company). As far as software that monitors or interacts with online connections.. Adobe Flash Player 11 Plugin, Apple Application Support, Apple Software Update, Bonjour, Google Chrome (not that it's preferred over FF, just over IE ;]), Java(TM) 7 Update 3, Microsoft Security Essentials, Microsoft Silverlight (I started having issues not long after I installed Silverlight, however I don't feel like this is causing any issue, as I tried removing it and reinstalling everything from scratch, but no luck), Mozilla Firefox 11.0 (x86 en-US)/Mozilla Firefox 12.0 (x86 en-US), Mozilla Maintenance Service, No-IP DUC (tested this and found no difference or ability for it to hinder FF), (previously) Skype 5.8, TortoiseSVN 1.7.5.22551 (32 bit), and WinSCP 4.3.7.

None of which I've found to have issues with Firefox in the past, as well as FF was working with them until just recently. As far as I can tell, automatic updates were disabled for everything (including my OS), and no changes had been made to any of the software, with the exception of I had installed Silverlight, but as mentioned earlier, I didn't find any issues with this.

Like you say, my best guess at this point would be that there's something funky set up with my partitions, and so I may just do another fresh wipe and try again (it just takes forever to get everything installed that I need for school, so I'll probably just wait it out for a while). The only reason in which I would go against it being a partition setup issue, is that it -was- working. However, I do recognize that something could have come up after a while (not sure how, but I don't doubt it).

I hadn't thought about downgrading past 11, but it's definitely worth a shot, and I'm more than willing to try. once I'm done with stuff today I'll give it a shot and post the results here.

Thanks so much for your suggestions.

more options

選擇的解決方法

Why not instead of downgrading an existing Firefox to earlier versions, consider trying multiple installs.

Firefox portable is designed as an easy to install method of using Firefox as an additional browser.

With your expertise installing manually multiple versions of Firefox will also be easy, just use separate unique profiles for each version. Utilise the built in profile manager or the standalone version to help you. Such testing does not require any additional partitions, and need not include changes to the existing firefox installs and profiles.

more options

John, you're a lifesaver. The portable edition 11.0 works, and I am able to save my settings and relaunch.

I attempted the multiple profiles/multiple versions, however that didn't work unfortunately. Definitely worth a shot however. Oh well.

I may still end up reformatting from scratch, but I'll definitely use the portable version until that point.

  • I was clearing my W7 part last night, and accidentally set it to being the active part (must've misclicked at some point), right as I deallocated the drive...Sooo I had no accessible bootmanager...

Ended up installing puppylinux on the new part via usb, since for w/e reason I couldn't boot from disk (I -may- have messed up my MBR at that point), and installed grub from there...not optimal, but it's working again for now.

Anyways. Big mess. I'll fix it eventually, probably by starting from scratch. Until that point, the portable edition will work great =)

Thanks so much!

由 DanielBernard 於 修改

more options

Daniel,

Glad we helped.

Maybe we did not get to the bottom of the problem but at least you have a work around.

Separate installs on differing OS should stay that way, but it depends somewhat on how you do it. You may point Firefox at a profile almost anywhere on your computer if the filesystem is compatible and has permissions.

Off topic but Grub may presumably be anywhere that is bootable.

John