搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox no longer remebers login information from all websites

  • 9 回覆
  • 4 有這個問題
  • 9 次檢視
  • 最近回覆由 cor-el

more options

I have the security preferences set to remember passwords, I have the privacy set to remember history. None of that was changed. I believe it was right after updating to 10.0.2 that none of my login information is stored.

Some of the websites will remember the username and password. Some will remember the username, and some will display the username if I double click in the username box, but NONE of them will remember me if I check the remember me box.

I have removed and re-installed firefox, cleared my cache, cleared my history...not sure what else to do. Any help is appreciated.

所有回覆 (9)

more options

Hi Diethul,

Have you looked at the Usernames and passwords are not saved Knowledge Base article? There is a lot of useful information in there.

Hopefully this helps!

more options

Websites remembering you and automatically log you on is stored in a cookie.

  • Create an allow cookie exception (Tools > Options > Privacy > Cookies: Exceptions) to keep such a cookie, especially for secure websites and if cookies expire when Firefox is closed.

Make sure that you do not run Firefox in Private Browsing mode.

Do not use Clear Recent History to clear the "Cookies" and the "Site Preferences"

Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

more options

Yes, I have checked the Username and password not remember KB, and nothing there has helped.

No, I am not using Private Browsing mode. I do not use the Clear Recent History. I am not clearing history.

The only change that happened was Firefox updated to 10.0.2. Before, all passwords/cookies were being saved, now, none of them are.

I would say there is something wrong with the way firefox is saving the cookies.

more options

Just to be sure: you do mean websites automatically log you in and not saving names and passwords in the password manager?


"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

If clearing the cookies doesn't help then it is possible that the file cookies.sqlite that stores the cookies is corrupted.
Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox Profile Folder in case the file cookies.sqlite got corrupted.

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

more options

Actually, that is backwards...kind of.

I am NEVER being automatically logged in.

Sometimes the username and password is displayed in the log in window, but if I check the remember me box (or stay logged in, or whatever) it makes no difference.

Sometimes, the username is just displayed, with no password.

Sometimes, neither is displayed, but if I double-click on the username, then a drop-down box will appear and I can select the username. No password is shown.

I went ahead and tried all the things you mentioned above, and realized one site I am being logged into...yahoo, the yahoo toolbar, and yahoo mail.

Appreciate your help so far :)

more options

So just to test things out some more...I uninstalled firefox completely, restarted my pc, downloaded and installed FF 11. I am still having the exact same problem. I am not getting the prompt to save a password on most sites and when I check the "remember me" box, I close the browser and go back to that site, and nothing has been saved, no password, and I have to type my password in again. Interestingly, if I double-click the username box, my username will show in the box, and I can click it, but no password shows.

I checked the password exception list and the saved password list, nothing is shown in either place.

Wish I could get this fixed, I am getting tired of typing all my passwords in everytime I go to different sites...maybe it is time to check out chrome...

more options

If you click remember in the pop-up from the key icon to remember the password then Firefox should remember the name and password in the Password Manager.
If that name and password is gone after a restart of Firefox then check that you aren't using Clear Recent History to remove the passwords.
If you use cleanup software like CCleaner then check the settings for the Firefox application.


If only the name is filled and no password then the name is most likely stored as form data and not in the password manager.
In that case try to delete that name entry by highlighting it in the drop down list and press the Delete key.

Websites may be using autocomplete=off to prevent Firefox from saving and filling the name and password and form data.
You can remove autocomplete=off with a bookmarklet to make Firefox save data either as form data or in the password manager.

more options

The pop up box from the key icon does not appear.

more options

Try to disable hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

If disabling hardware acceleration works then check if there is an update available for your graphics display driver.