搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

i need firefox on cd rom

  • 6 回覆
  • 2 有這個問題
  • 558 次檢視
  • 最近回覆由 slass

more options

I was given an old Mac desktop G4 (system reinstalled) with Internet Explorer 5.2 which is too old to display the download pages for Flash, Explorer, and FireFox... all I see are blank pages, some artwork, only a few working links, no way to download. Looking at the same pages on my PC tells me that the page displays on the Mac are all screwed up. Since I want FireFox as my browser I thought I might as well skip the upgrade of IE, which I can't do anyway without an IE CD, and just order FireFox on CD-ROM for Mac OS X v10.2.3 (from my PC). I don't see anywhere that offers a CD version (which I am willing to pay for). All I need is a way to order a version of FireFox on CD-ROM that will work on Mac OS X v10.2.3

被選擇的解決方法

Actually Firefox 3.6.* will not work on the old Mac OSX 10.2.3

Firefox 3.0, 3.5 and 3.6 requires OSX 10.4 at minimum while Firefox 4.0 and newer requires OSX 10.5+

The last Firefox release to work on OSX 10.2.x was the old Firefox 2.0.0.20

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/2.0.0.20/mac/

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/2.0.0.20/mac/en-US/Firefox%202.0.0.20.dmg


http://www.mozilla.org/en-US/firefox/3.0/system-requirements/

http://www.mozilla.org/en-US/firefox/2.0/system-requirements/


Also your Firefox version on Windows is behind on security updates (you have 3.6.7) as the current version for 3.6. is 3.6.24 http://www.mozilla.org/en-US/firefox/all-older.html

從原來的回覆中察看解決方案 👍 0

所有回覆 (6)

more options
more options

選擇的解決方法

Actually Firefox 3.6.* will not work on the old Mac OSX 10.2.3

Firefox 3.0, 3.5 and 3.6 requires OSX 10.4 at minimum while Firefox 4.0 and newer requires OSX 10.5+

The last Firefox release to work on OSX 10.2.x was the old Firefox 2.0.0.20

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/2.0.0.20/mac/

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/2.0.0.20/mac/en-US/Firefox%202.0.0.20.dmg


http://www.mozilla.org/en-US/firefox/3.0/system-requirements/

http://www.mozilla.org/en-US/firefox/2.0/system-requirements/


Also your Firefox version on Windows is behind on security updates (you have 3.6.7) as the current version for 3.6. is 3.6.24 http://www.mozilla.org/en-US/firefox/all-older.html

由 James 於 修改

more options

Oops, I had missed that last part of the first post.

As for the OP's Firefox version: the user agent may be corrupted as we've seen a lot of those cases with an FBSMTWB (Fast Browser Search) in the user agent.

  • Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7 GTB7.1 ( .NET CLR 3.5.30729; .NET4.0C) FBSMTWB

See:

more options

Thanks everybody... James, I downloaded FireFox version 2.0.0.20, and before installing it I upgraded OS X from 10.2.3 to 10.2.5 - then installed FireFox 2.0.0.20. The OS upgrades didn't help to move to a newer FireFox, but guess it was a good idea anyway - OS X 10.2..6 wasn't available as a free download or I would have kept going until I hit the end of the road for my new old Mac.

Cor-el, I had started to act on your first post by downloading 3.6, then just happened to refresh my screen and saw Jame's post. Your second post didn't come until I had started with Jame's suggestion. Not so sure I understand what you were saying in the second post anyway... don't know what "OPs" is, and I'm hoping that my user agent isn't corrupted, whatever that is! Thanks.

more options

Actually you useragent is just stuck at Firefox 3.6.7 due to a extension adding the FBSMTWB on end, a issue that was fixed as of Firefox 4.0 and newer.

See the second or third link he mentioned on how to reset useragent to normal.

more options

James, we're not talking about the Mac with OS X anymore are we? Is this info about the user agent , Firefox 3.6.7 and the FBSMTWB in reference to the PC that I am accessing this forum with?

I haven't had any issues with my PC's Firefox, but then again I haven't upgraded it yet because my hard drive is partitioned, and the applications partition is almost out of room.

In reference to the PC (the Mac no longer an issue)... I will check out cor-el's third link to see if it has any possible future application for me. Thanks again.