搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Installed FF 8.1. It WIPED OUT MY ABILITY TO OPEN MHT filesUnable to

  • 13 回覆
  • 21 有這個問題
  • 368 次檢視
  • 最近回覆由 jgwirt

more options

I get so tired to this.

I just installed FireFox 8.0.1 and it wiped out my ability to open MHT files. I HATE WASTING DO MUCH TIME WITH THIS.

I downloaded Word Viewer 2007 and installed that but it doesn't work either. All I get are some of the icons on the page.

HOW CAN I OPEN MHT FILES IN FIREFIX 8.0.1

Yesterday, this was not a problem. I had an earlier version of Firefox 8 installed. I think I have solved this problem before but don't remember how I didi it.

Right now I have a lot of work to do and I do not like screwing around with this problem.

被選擇的解決方法

IE Tab 2 has an option called Sites Filter - you must delete / disable the filter for files "mht|mhtml" or IE Tab 2 blocks them and they never open.

從原來的回覆中察看解決方案 👍 1

所有回覆 (13)

more options

Try installing the Firefox add-on called Mozilla Archive Format:

https://addons.mozilla.org/en-US/firefox/addon/mozilla-archive-format/

more options

I installed the Mozilla Archive Format addon. It made no difference except that .mht files are no identified as Firefox MHTML documents. When I try to open one in Firefox the screen is blank.

On a couple of tries, something appeared from the document but it was in HTML (the code--displayed on my screen). But after a couple of seconds that went away.

I didn't have a problem before I installed FireFox v. 8.0.1. I have fixed this problem before with the MAFF add-on. Or at least, I have not had any trouble with this problem for months.

Now it is back and I have a LOT OF WORK to do this afternoon and I am dead in the water screwing around with XPS Viewer and all to try to open a bunch of .mht files I need to open. XPS Viewer and XPS Viewer Essentials are both installed. They do not work anymore either. Cannot open mht files with them either.

more options

Correction in second sentence of the above reply:

... It made no difference except that .mht files are not identified as Firefox MHTML documents. When I try to open one in Firefox the screen is blank.

more options

I'm really losing it.

... It made no difference except that .mht files are NOW identified as Firefox MHTML documents. When I try to open one in Firefox the screen is blank.

more options

If you select Tools -> Add-ons from the Firefox menu bar you will see a list of your add-ons. To the right of each add-on will be a button for Options, Disable, and Remove. (Some items do not have an Options button.)

If you click the Options button for Mozilla Archive Format you can set your preferred options for the add-on. Make sure you select on the Actions menu "Refresh File Associations", and you may need to reboot so Windows can apply the change.

There is a user manual located at:

http://maf.mozdev.org/documentation.html

Please report back if this was helpful to you.


edited to correct typo

由 sctl 於 修改

more options

Maybe the problem is that I installed Firefox to a separate directory on my E: drive. It is not installed to C:/Program Files.

I tried to upload a .bmp file showing the menu options in FF 8.0.1 but your website would not take it. How come? It's a .bmp file.

Anyway, there is no TOOLS option in FF 8.0.1.

由 jgwirt 於 修改

more options

Try disabling your add-on called IE Tab 2 Plug-in for Mozilla/Firefox, then restart your browser and report back on your progress.

Can you see the Firefox menu bar at the top of your Firefox screen? If not, right-click on the top Firefox toolbar and you should see a toolbar selections menu. Make sure that "Menu bar" is checked. Once it is showing, you should see a menu item entitled "Tools".

more options

I decided to install Internet Explorer 8 and now I think everything is working fine. All of the .mht links now have an Internet Explorer icon and when I click on it the page opens.

Previously, I only had IE 7 installed because according to all the text I've read when I look at IE 8 n the web is that it is only for Windows Vista up but not XP PRO SP3, which I have.

I can tell you for sure right now that I have installed IE 8, I only have XP Pro SP3, and IE 8 works fine.

No problems at this point.

more options

選擇的解決方法

IE Tab 2 has an option called Sites Filter - you must delete / disable the filter for files "mht|mhtml" or IE Tab 2 blocks them and they never open.

more options

jgwirt wrote: Anyway, there is no TOOLS option in FF 8.0.1.

Yes there is as you are using Windows. You have Windows XP which has the Menu bar visible by default, if not then right-click a toolbar and check [v] Menu bar.

On the Menu bar there is "File Edit View History Bookmarks Tools Help"

The Options is in the Tools menu.

more options

OK, this is very helpful. Now the row of open tabs is now visible on the FF menubar.

I then opened the "IE Tab Options" option on the Tools menu and disabled the mht/mhtml option.

But I have the UnHMT 5.7.0 Add-on installed and it is active. Should I leave it as is?

Everything seems to be working OK.

more options

If everything's working for you now, please mark the question as "solved" so that it might help others find a solution.

more options

Thank you. Good help support.