搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

I deleted the Flash plugin and now I cannot install it again

  • 4 回覆
  • 9 有這個問題
  • 24 次檢視
  • 最近回覆由 canac

more options

Hi, I deleted the Flash plugin and now I cannot install it again. I reinstalled Firefox (deleted all from the Program files folder and from the Application data folder) but it didn't help.

被選擇的解決方法

Flash is not in the Firefox Programs Files folder or the Applications folder for Firefox. This and many other Plugins (not Extensions) are "installed"/pointed to through the Windows registry and the actual files are in other locations on your hard drive.

Have you tried un-installing ALL Adobe Flash from your system and starting over?

  1. This will remove ALL Flash from your system -- Firefox, IE, all other browsers
  2. After the removal is complete, follow the previous instructions (see Install or update Adobe Flash above) for downloading and SAVE the installers to your hard drive for both IE and for other browsers (that includes Firefox)


My only other suggestion would be to try some of the suggestions from the Adobe site: http://kb2.adobe.com/cps/191/tn_19166.html


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

從原來的回覆中察看解決方案 👍 1

所有回覆 (4)

more options

There are 2 versions of Adobe Flash:

  • an ActiveX version for IE only
  • a Plugin version for most other browsers including Firefox
  • On a Windows system, you should always update both individually.

You do not appear to have the Plugin version for Firefox installed. If you did, in Add-ons > Plugins you would see "Shockwave Flash (version)". If "Shockwave Flash" is there and is disabled, click the "Enable" button.

Check your Plugins often --> http://www.mozilla.org/en-US/plugincheck/

  • only the most popular/used Plugins are known by this page
  • page will detect only installed, enabled Plugins

Install or update Adobe Flash

  1. Using Firefox, go to the following link and SAVE the download to your desktop so you can find it later. Un-check any items on that page that you do not want to download (i.e., "McAfee Security Scan Plus":
  2. When the download is finished, close Firefox (File > Exit OR Firefox button > Exit)
  3. Click or double-click on the file you just saved to your desktop
    • In the installation window that appears, click the box to the left of "I have read and...." to place a check mark in the box
    • The "Install" button in the lower right corner will now be highlighted, click it.
    • The installation is quick.
  4. Start Firefox and test your installation here: https://www.adobe.com/software/flash/about/
  5. To update/install the ActiveX version for IE only, repeat the process, but use IE to go to the above website.



If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

more options

Hi SafeBrowser, I did all that already and it doesn't work. When I try to do the installation, it just says "failed" without explanation.

I think I probably have disabled then deleted the neccessary add-ons, but I'm puzzled how come they don't return after the reinstallation of the program.

more options

選擇的解決方法

Flash is not in the Firefox Programs Files folder or the Applications folder for Firefox. This and many other Plugins (not Extensions) are "installed"/pointed to through the Windows registry and the actual files are in other locations on your hard drive.

Have you tried un-installing ALL Adobe Flash from your system and starting over?

  1. This will remove ALL Flash from your system -- Firefox, IE, all other browsers
  2. After the removal is complete, follow the previous instructions (see Install or update Adobe Flash above) for downloading and SAVE the installers to your hard drive for both IE and for other browsers (that includes Firefox)


My only other suggestion would be to try some of the suggestions from the Adobe site: http://kb2.adobe.com/cps/191/tn_19166.html


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

由 SafeBrowser 於 修改

more options

Thanks for your help SafeBrowser, I followed the instructions from the Adobe website and it worked. Apparently it was the firewall proxy server that created problems.