搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

after updating to Firefox 8, I lost almost all the icons associated with my bookmarks. Bookmarks will work, but they show an empty square instead of the icon associated with the website they are linked to. What's the bug here??

  • 57 回覆
  • 1040 有這個問題
  • 3235 次檢視
  • 最近回覆由 the-edmeister

more options

I had many sites bookmarked in Firefox 7. All these bookmarks were associated to icons linked to the sites. Almost all my bookmarks lost their icons (now replaced by an empty square) after updating to Firefox 8. Que pasa ??

所有回覆 (20)

more options

Unless a bug worked it's way into this release, those empty square dotted bookmark favicons do not look polished and professional befitting the overall great look of Firefox. Please give us the option of using the previous generic Firefox blank favicon.

由 johnf2 於 修改

more options

on a side note, we've had that BLANK ICON for years, if they wanted to change it why not throw a little MOZILLA FF ICON in the middle of the blank page? INTERNET EXPLORER has done that for years, for websites that don't have a FAVICON their default ICON has the little E wrapped around the blank sheet of paper, FIREFOX would be wise to do the same ... just a suggestion, and yes DELETE the DOTTED LINES, looks like poo poo.

由 heyyahblah 於 修改

more options

i hope there will be an update to fix this ... :)

由 Ahmad Maher 於 修改

more options

I have the same problem as the rest since updating.

more options

After having read the postings on the missing bookmark icons, two things emerge: 1 I'm not alone - always nice to have it confirmed 2 I'm shocked at the venom expressed in some posts.

Bugs do occur with the best of diligent testing. I support Firefox wholeheartedly and have every confidence that the developers will provide a fix asap. It's not as if v8.0 doesn't work, we are simply missing the pretty picture in some bookmarks.

If you want to sling-off at developers then purchasing a browser with real money gives you the right to complain. Even then rudeness is a last extreme.

Thanks firefox guys, you do a great job! I eagerly await the fix!

由 hhbentley 於 修改

more options

hhbentley, agree with your post, especially the tone and some rudeness which has occurred. Everyone, please give the Firefox engineers time to look into the problem. They have already responded they are looking into the change. Firmware is not perfect all the time, sometimes things are missed. or changed on purpose. We use this forum to let them know situation and they can response and will be more eager to listen to our suggestions if we respect everyone's opinions. Enough said.

more options

This is my last post on this thread. Again, there's nothing wrong with the "tone" in this thread. No one is yelling or screaming. All I am asking is for Mozilla to take the responsibility to fix something that was broken from 7.0.1 to 8.0. I did not yell or scream at them. It'll be more beneficial for you to post your posts in threads that are really rude. Go through the forum and you'll find a lot, and you are in the wrong thread for such post.

more options

For a while it seemed that changing my theme to something other than the default theme solved the issue. But later I started having cases where the custom bookmark image for a web site would not show up, the blank squares where back.

I believe that in my case I went to www.bbc.co.uk and did not see a custom image, although www.bbc.co.uk/favicon.ico did show the image that should have shown up.

After some searching I found Mozilla's "Latest Firefox issues" page at:

https://support.mozilla.com/en-US/kb/latest-firefox-issues

This page advised disabling icon picker add-ons. I did so and that solved my new problem for a while.

When I switched back to using the default theme, the blank square boxes problem came back. If I switched away from the default theme then things were fine once again.

So if you are getting the blank squares in your bookmarks, try Mozilla's advice to disable any icon picker add-ons. If that does not work, try changing your theme to something other than the default theme.

Although I do not speak for Mozilla in any way, here are some links that may help with these two tasks:

For help on the disabling add-ons, visit https://support.mozilla.com enter "disable add-on" into the search box, and select the arrow image.

For help changing themes, visit https://support.mozilla.com enter "change theme " into the search box, and select the arrow image.

A prior post of mine gives detailed reasons for suspecting that the default theme is corrupt.

more options

the temp fix is to create a userChrome.css text file and put this file in a folder you also create name it "Chrome" in your user profile. In Xp the folder would be in C:\Documents and Settings\xxxxx\Application Data\Mozilla\Firefox\Profiles\xxxxx.default

then paste this into userChrome.css: http://pastebin.com/raw.php?i=jquSx9YX

由 event3horizon 於 修改

more options

Thanks "event3horizon", works fine with some ... still some but this is better than nothing :)

由 Ahmad Maher 於 修改

more options

Hi Gavin -- thanks. But there is so much missing on my windows vista that I can't even see what is written on the page to which you have directed us. In addition, my internet connection icon (bottom right toolbar) has a red X through it although i am clearly online and the icons and photos on my google maps are missing although i can see them in internet explorer. Thanks again

more options

There appear to be two distinct "problems" with the update to FF8.

1. A large percentage (but not all) of my bookmarked sites have lost their icons and resorted to the default. This is fixed if I click on the link and visit the site - the icon is reinstated. To avoid opening 1700+ webites one-by-one just to fix the icons I installed the CheckPlaces addon and asked it to load all my favicons. Issue fixed; but it shouldn't have happened, has never happened to me before (and I've been using FF since 0.6). This is a problem.

2. The default favicon seems to have changed from the old "piece of paper with the corner folded over" to a square with a dotted border. From the reading I've done, this is deliberate but, in my opinion, is a bad mistake, made by someone with no understanding of man-machine interfaces. The new default looks like a problem as it screams "something's broken and your icons have gone missing". I nearly reinstalled FF8 from scratch, assuming that the update had somehow broken or deleted the default icon file - I'm glad I did the search. Poor show, Mozilla. Put the old one back, or, if you need something different (although "if it ain't broke, don't fix it" comes to mind), get someone to design something that looks like it was meant to be there. This is Mozilla shooting itself in the foot.

Should have added - Using FF8 on XP SP3

由 Paul S 於 修改

more options

For the default bookmark favicon see this thread:

more options

I don't know if this will help the developers solve the bug but my problem is eerily similar to this. All icons and LABELS - which are sml. images, on all pages, including this one, are blank. But, my Bookmarks have their usual 'file folder' icon. All pages are also WITHOUT ... IMAGES or ICONS. The similarity is "Images". Maybe look at the many parts of the ff8 code that refer to or change any 'images', 'labels' or 'icons' ...? Especially anything that 'could change or not call up an icon'! It is so pervasive on my new ff8, that I feel like I am using a Beta! Can't read/see half the links & labels!! That's pretty horrible! so I sincerely hope the fix comes quickly. IF you have to abandon "the New Look" to get this fixed DO IT. Can perfect the New Look Code & add it later! There are too many with this type problem!

由 sandiep 於 修改

more options

If images are missing then check that you aren't blocking images from some domains.

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check the permissions for all sites on the about:permissions page, via the location bar
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

Make sure that you do not block third-party images permissions.default.images


There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images.

more options

Disabled the "Tell websites I don't want to be tracked" feature and then visited each site without an icon and the icon now is displayed proper. On each one I tried this worked. Problem is, I've got hundreds of bookmarks.

more options

"Tell websites I don't want to be tracked" only makes Firefox send DNT=1 as part of the HTTP response headers and should have no effect on the favicon.

Try this extension:

more options

For the square and empty icons, there is a workaround in this comment to the bug. Comment number 17. It works. Restore the favicon as it was before. As it was in Firefox 7.

https://bugzilla.mozilla.org/show_bug.cgi?id=701287

more options

Thank you "teodorgant" ... the fix works :)

more options

This patch returned about 1/2 of the favicons. So I hope FF8 comes out with patch or version 8.1 soon.

T

  1. 1
  2. 2
  3. 3