搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

characters display as rectangles in some fields

  • 7 回覆
  • 9 有這個問題
  • 53 次檢視
  • 最近回覆由 malaus1

more options

On a few web sites, some of the words/sentences are displayed with all characters replaced by small rectangles. If copied and pasted into a word document they display correctly. eg. "Thanks for visiting our Web Site" appears in the website as a row of small rectangles. (I have pasted them here). It has to be a font problem but all settings are standard.

所有回覆 (7)

more options

PS - I have had this problem before with an earlier version of Firefox but at the time it went away with an upgrade of Firefox.

more options

The Courier Bold font is used for that text.
It doesn't seem to be working if you see little boxes with the hex code.


You can set try to the Boolean pref gfx.font_rendering.directwrite.use_gdi_table_loading to false|true on the about:config page.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.


You can do a font test to see if you can identify corrupted font(s).

more options

Thanks cor-el, You lose me when you mention fooling about with boolean so I left that alone but I used browserspy which listed my fonts and there were several fonts showing the rectangles including Courier. I have on-board font programs which show all fonts OK. As browserspy is a flash based program I had a thought. Maybe it's only flash that produces the errors. eg errors occur when I check passwords in LastPass. I now think it's in filled fields where it occurs in other web site pages. Go figure ? See screenshot.

由 malaus1 於 修改

more options

A Flash plugin is only used by the browserspy site because a plugin can access all locally installed fonts. A website can't get such a list via other (JavaScript) means and Flash is a commonly used plugin that most have installed.

There may be problems with some of the installed fonts if Firefox isn't able to show them.


You can still try to type about:config in the location (address) bar.
That will show a warning message that you can confirm and will take you to the about:config page.
That page has a Filter bar at to top that makes it easier to find a specific preference.
You can start typing (or paste) gfx.font_rendering.directwrite.use_gdi_table_loading in that bar until you see a pref with that name.
You can toggle the value of that Boolean pref from true to false with a double-click or via the right-click context menu.
You have to close (Firefox/File > Exit) and restart Firefox to make that change effective.

See also:

more options

I have accessed about:config and found the entry but haven't changed anything yet. It is showing true . What happens if I change that ?

more options

That changes the way that Firefox loads the font tables on startup.

You can try to toggle that pref to false and close and restart Firefox.
If it doesn't have effect on your problem then you can undo that change in the same way with a double-click on that pref on the about:config page.

more options

Tried that and made no difference. I should add that I run almost identical software on my lap top without any problems. Same fonts and all. Thanks for trying though. I guess I will have to live with it. Maybe the upgrade to Firefox 8 will fix it.

No, 8 didn't solve the problem but did seem to change things. Some of the characters now show OK. I might get something like "t⃞⃞ q⃞⃞c⃞ br⃞w⃞" (the rectangles are a little smaller in fact).

由 malaus1 於 修改