搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

favicons on tabs disappear

  • 12 回覆
  • 61 有這個問題
  • 695 次檢視
  • 最近回覆由 Terran21

more options

My pc Windows Xp SP2 firefox 8

All the favicon on tabs disappear, I try with firefox 3.6 with other user and there they are but on FF8 not, Before I saw tabs favicons to select tab I want to see, but now I have to read one by one tabs to know which one I want.

被選擇的解決方法

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

In Firefox 4 and later Safe mode disables extensions and disables hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"
從原來的回覆中察看解決方案 👍 0

所有回覆 (12)

more options

Are you using any cleanup software then can remove the favicons from places.sqlite?

You can try:

See also:

more options
more options

This is a misunderstanding I am not talking about bookmarks at all When I say Favicons I talk about Web site icon, URL icon Favicons en Firefox 8 does not appear on Address Bar nor Tabs I try with Aurora version 9.02.a and Firefox 3.6 and miraculously Favicons appear again, there is not a problem, the problem is only with Firefox 8

CCleaner only cleans cache and history it does not block anything if you use CClaener Firefox must by close and vice versa. When you use new session in Firefox , Favicons must by load from any webpage that have Favicons in that instant that not have nothing to do with memory nor cache. I hope Firefox 9 like Aurora 9.02.a that problem has been resolved.

由 Terran21 於 修改

more options

doesn´t work

more options

Did you check for a misbehaving extension or theme?

Are you using any code in userChrome.css that can cause this?

Make sure that you do not run Firefox in permanent Private Browsing mode.


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options
  1. I don´t use any code in userChrome
  2. I don´t use private browsing
  3. In Firefox Safe Mode favicons works fine
  4. I use DEFAULT theme
more options

選擇的解決方法

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

In Firefox 4 and later Safe mode disables extensions and disables hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"
more options

I try one by one and found the troublemaker add-on Favicon Picker 2 0.6.2.15 https://addons.mozilla.org/en-US/firefox/addon/favicon-picker-2/?src=api

It is supposed that Firefox to warn when an add-on is not compatible, in this case it appear this add-on sneak through mozilla control filters, but 3 more people has this problem too, there could be more add-ons causing this.

thanks for your advice.

more options

You're welcome.

I remember having seen that extension mentioned before with causing favicons to disappear.

Did some searches:

more options

I have the same problem after upgrading to 8.0

more options

Terran21, check these prefs on the about:config page.

  • browser.chrome.favicons
  • browser.chrome.site_icons

and chang it into 'true'!

more options

they are true already the problem was add-on Favicon Picker 2 0.6.2.15 https://addons.mozilla.org/en-US/firefox/addon/favicon-picker-2/?src=api