搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Windows not showing. Page source and library windows open but not showing.

  • 14 回覆
  • 6 有這個問題
  • 31 次檢視
  • 最近回覆由 cor-el

more options

I select View --> Page Source and no window appears. Under the Window menu, the item Source: . . . shows but no window. If I close the main window then the item is ticked but still no actual window. I have disable all extensions and plugins, safe mode, revert all preferences. the same happens with Show all Bookmarks. This is why I posted this under bookmarks problems originally - see below. I now find the same happens to downloads and Error console windows. No problems in Safari or MS Word (usually the worst performer)

Bookmarks are all present, but show all bookmarks produces no window, even though the window menu shows an item and I can select it. Mac OS 10.6.8 FF 5.01 Show all bookmarks shows no window, even if I close the main window. Under window menu the 'Library' item is ticked but still nothing. I have restarted, and renamed places database. recently installed some of these addons

由 mikejn1@btinternet.com 於 修改

所有回覆 (14)

more options

paste this into the location bar and press "enter" when you have a webpage displayed to see if it will show you the source.

javascript:location="view-source:"+location

If that works you have probably messed up trying to use some editor to view source.

If it doesn't work make sure you have JavaScript turned on, and if off then activate and retest.
more options

When noscript ennabled then your javascript:location="view-source:"+location shows source in same tab, same window. Nothing to do with messed up trying to use some editor since it is not just the source window that doesn't show but the 'show all bookmarks' , the error console, and other windows.

more options

Corrupt localstore.rdf

Check and tell if its working.

more options

I deleted localstore.rdf. No change. Funny thing is before your post I got the windows back briefly. First I was able to select the bookmarks or source window from the window menu, but there was just a thin vertical line - 1 or 2 pixels insted of the window. Then if I selected window zoom, there was the window! Then after editing bookmarks and turning on 'mybookmarks' extension the windows went again. Turned off mybookmarks, only extensions on are NoScript and Google shortcuts. Still same problem. Windows don't appear: library, source, error console, downloads.

more options

Troubleshooting extensions and themes

Check and tell if its working.

more options

I had already done that. All extensions off, I always used the basic theme.

I have also found that when I log in as another user, so another profile, this time an admin user, there is no problem. When I right-click on a link and 'open in new window' the same happens - no window, though it appears on the window menu. Open in new tab is fine.

If i drag a tab off the window the same happens, and also if I open a new window, so it is something to do with not being able to show more than one window.

more options

Curiouser and curiouser. I created a new profile.

Now other windows appear, including 'open link in new window'; source; downloads; error console; but not the show all bookmarks Will try admin profile again.

more options

Where can I find my Bookmarks?

Check and tell if its working.

more options

Nothing to check, I have the bookmarks, but it's the windows that were not appearing, then only the library.

Now they are all back, I copied the profile folder from another login and chose that at startup. So something in the profile! SOLVED.

由 mikejn1@btinternet.com 於 修改

more options

Glad to hear it

由 Hasan 於 修改

more options

The one that solved it was my own last post, which does not have a Solved it.

I copied the FF profile folder from another login and started with that. However. . . the problem is back. I installed extensions, NoScript and MyBookmarks and it seemed OK after that.

Then I installed Download Youtube videos + 3.3.51, then DownThemAll! 2.0.7, Google Shortcuts 2.1..6, ImTranslator, QuickWiki and Read It later. No Plugins ennabled.

when I disable all extensions then the windows for downloads, error console and 'open link in new window appear OK, but not the source or Library windows. 

As before they are on the window menu but no way to make them visible.

more options

由 Hasan 於 修改

more options

I have exact the same problem.

When I open a page (this one for instance) and I select View Source from the context menu, no Source window appears. The name of the Source window does come up in the windows menu and it comes up in the context menu of the Firefox icon in the Dock.

Same thing for the Downloads window, the Bookmarks window, the Page info window (and more?)

OSX 10.7.2, Firefox 7.0.1

I tried starting up in Safe mode to reset toolbars. I also deinstalled all extensions, both with no effect.

由 TicoDeBladder 於 修改

more options

That can happen if you have a multiple monitor setup and you are not on the first monitor.