搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox fails to save homepage setting selected in Tools/options.

  • 1 回覆
  • 11 有這個問題
  • 13 次檢視
  • 最近回覆由 Xircal

more options

Firefox fails to maintain the homepage I select in Tools/Options. I type in my desired homepage in the address bar, select Tools/Options, save current page as my default homepage, and it saves it for that session, but when I close out F/F and bring it back up, it fails to go to the saved homepage, instead going to a default page http://www.searchqu.com/406 which I do not desire to use.

Firefox fails to maintain the homepage I select in Tools/Options. I type in my desired homepage in the address bar, select Tools/Options, save current page as my default homepage, and it saves it for that session, but when I close out F/F and bring it back up, it fails to go to the saved homepage, instead going to a default page http://www.searchqu.com/406 which I do not desire to use.

所有回覆 (1)

more options

Please do the following.

  1. Press CTRL+SHIFT+A to open the Firefox Extensions menu. You can also click the orange Firefox button, click Add-ons, then Extensions if you prefer using the mouse.

  2. If "Extensions" is not selected in the left hand menu already, click the link to open it.

  3. Look for Searchqu Toolbar. If you see it, or any reference to a toolbar with the name "Searchqu", click the Remove button

  4. Next, in the Search Bar (that's the small one on the right of where you normally type in a web address), click the small arrow on the left of the field to open the dropdown menu.

  5. Scroll down to the bottom of the list and click Manage Search Engines. In the menu which appears, find the search engine called Web Search. Click it to highlight it and then click the Remove button. I've included a screenshot to help you out with this step. Obviously, I don't have searchqu installed myself, so I've used another one as an example of how to remove it.

  6. Next, use Windows Explorer to navigate to C:\Programs Files\Windows Searchqu Toolbar

  7. In there, double click the file called uninstall.exe

  8. Reboot and then start Firefox again.


If the problem persists, these are the additional steps to take.

  1. in the location bar where you normally type in a web address, type about:config and hit Enter.

  2. If you see a window which says "This might void your warranty!", click the button which says "I'll be careful, I promise" so you can continue with the next step.

  3. In the filter immediately underneath where you typed in "about:config", type: keyword.URL to isolate that single entry.

  4. Right click it and choose Modify.

  5. Delete hxxp://www.searchqu.com/web?src=ffb&systemid=406&q= and replace it with http://www.google.com/search?q= and then click OK. Since the google URL becomes a link in this forum, you can right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then press CTRL+V to paste it after you delete the "searchqu" web address. Saves you having to type it all

  6. In the filter at the top again, remove "keyword.URL" and then copy/paste the following: browser.startup.homepage
  7. Right click it and choose Reset from the menu.

  8. Remove "browser.startup.homepage" and then copy/paste the following: browser.search.selectedEngine

  9. Likewise, right click it and choose Reset from the menu.

  10. Close the tab and then restart Firefox.


To reset your home page, do the following.

  • Go to the site you want to set as your homepage.

  • Click the Firefox button, go to Options | Options | General.

  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.


If this suggestion resolves the problem for you, please click the Solved it button next to this post after you log in into the forum. This will help others searching for a solution to the same problem.

Thanks.

由 Xircal 於 修改