搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Sometimes Firefox opens with a Google page; how do I get it to stop?

  • 12 回覆
  • 1 有這個問題
  • 7 次檢視
  • 最近回覆由 Hasan

more options

My Firefox preferences are set for it to open to a blank page. But sometimes (not all the time) it opens to a Google search page. What's worse: I may be in the middle of typing something into the Google search window in the toolbar, but half of what I'm typing ends up in the search window in the Google page. Unlike just about all of the users I have seen in the forums, I would like NOT to go to the Google page, but rather just open to a blank page. How can I do so?

所有回覆 (12)

more options

I put settings that I want to keep into a user.js file which is in the Firefox profile directory. If you copy the line in prefs.js that sets the home page into user.js, it will be changed back to that if it gets changed somehow.

more options

Thanks. I wish I knew what a user.js file is, or where to find the Firefox profile directory. Are these Windows things? I'm running on Mac OS.

more options

How to set the home page

https://support.mozilla.com/en-US/kb/How%20to%20set%20the%20home%20page

Check and tell if its working.

more options

You need to create the user.js file yourself, and put it into the profile directory. An easy way to do that is to use a chrome editor, which will do that for you. MR Tech Toolkit contains a chrome editor, and does many other useful things as well.

https://addons.mozilla.org/en-US/firefox/addon/mr-tech-toolkit/

more options

> How to set the home page > https://support.mozilla.com/en-US > /kb/How%20to%20set%20the%20home%20page


Like I said, I did set my preferences to open to a blank page, and sometimes it does that (which is what I want), but sometimes it opens to the Google search page (which is what I don't want). Thanks for trying.

由 jraoul 於 修改

more options

Sometimes it opens to the Google search page (which is what I don't want).

Next time this happen check if your Homepage settings get changed or not ..

more options

>> Sometimes it opens to the Google search page (which is what I don't want).


> Next time this happen check if your Homepage settings get changed or not ..


I did; they did not.

more options

-> click Firefox button and click Exit

Start Firefox in Safe Mode by Holding down the Option key while starting your Mozilla application.

As an alternate method, go to Utilities (in the Applications folder) and open Terminal, then run:

    /Applications/Firefox.app/Contents/MacOS/firefox-bin -safe-mode 

-> Firefox Safe Mode window will appear. DON'T SELECT ANY OPTIONS, just click Continue in Safe Mode

Firefox will open up with just basic Firefox. Now do this:

-> Update ALL your Firefox Plug-ins https://www.mozilla.com/en-US/plugincheck/

-> Right-click on Tab Strip and unselect All Unwanted/Incompatible Toolbars

-> click Firefox button, go to History Menu and click Clear Recent History... -> Time range to clear: select "EVERYTHING" -> click Details (small arrow) button -> place Checkmarks on Cookies, Cache -> click Clear Now

-> click Firefox button, click Options -> go to General section -> in Startup section click Reset to Default button

-> go to Content section -> place Checkmarks on:

1) Block Pop-up windows 2) Load images automatically 3) Enable JavaScript

-> go to Privacy section -> History section -> Firefox will: select "Remember History"

-> go to Security section -> place Checkmarks on:

1) Warn me when sites try to install add-ons 2) Block reported attack sites 3) Block reported web forgeries

-> go to Advanced section -> General -> Remove Checkmark from Warn me when websites try to redirect or reload the page

-> go to Advanced section -> Network -> Offline Storage (Cache): click Clear Now button

-> Click OK on Options window

-> click the Favicon on SearchBar -> click Manage Search Engines -> select all Unwanted Search Engines and click Remove -> click OK

-> click the Firefox button, click Add-ons -> Extensions section -> REMOVE All Unwanted/Suspicious/Incompatible Extensions (Add-ons)

-> click the Firefox button, click Add-ons -> Appearance section -> REMOVE All Unwanted/Suspicious/Incompatible Themes (Persona)

-> Restart Firefox

You can enable your Known & Trustworthy Add-ons and Themes later. Check and tell if its working.

由 Hasan 於 修改

more options

Hey, mha007, thanks so much for that extremely thorough reply. Some of your instructions didn't match the version of Firefox I'm running (3.6.17 on Mac OX 10.4.11) but I did the things I could. And my problem persists: just now Firefox opened to "Firefox Start Page" with a Google search window in it. Sigh.

more options
more options

Thanks, cor-el. I will try to follow some of the ideas in that link. But I have to say that I don't think that's the problem. My preference to open with a blank page appears to be saved; anyway, that's how it looks every time I open the preferences. (It does also show that Google thing as my home page, which I didn't ask for, so I've tried deleting that. But it shouldn't matter what's in the home page field if I set "blank page" as my preference, should it?)

more options

-> click Firefox button and click Exit/Quit

Start Firefox in Safe Mode by Holding down the Option key while starting your Mozilla application.

As an alternate method, go to Utilities (in the Applications folder) and open Terminal, then run:

   /Applications/Firefox.app/Contents/MacOS/firefox-bin -safe-mode 

-> Firefox Safe Mode window will appear -> select Reset Toolbars and Controls and Reset All User Preferences to Firefox Defaults -> click Make Changes and Restart

Check and tell if its working.

由 Hasan 於 修改