搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How do I change Google to DuckDuckGo when doing CTRL+K or CTRL+J? (I already changed about:config > keyword.url)

  • 3 回覆
  • 14 有這個問題
  • 11 次檢視
  • 最近回覆由 jjnova

more options

Hi. I have something I want to change in the default behaviour, but I can't do it.

Here's what I want to do: I want to change www.google.com to www.duckduckgo.com. However, when I do CTRL+J or CTRL+K it keeps sending me to www.google.com.

Here's what I did: I found that the search bar is now useless. Indeed, the "awesome bar" is so awesome that I basically don't need the search bar any more. So, some time ago, I removed it.

There's a benefit to that. When the search bar is gone, the shortcut that was supposed to put focus on the search bar got another behaviour. When I use CTRL+K (CTRL+J), the page would automatically change to www.google.com.

I liked this behaviour because at the time I used google as my search engine.

But now that I want duckduckgo, I'm kind of annoyed by this, especially since I cannot modify this behaviour. I re-enabled the search bar, and changed the top search option to DuckDuckGo, hoping that would change the behaviour. It did not.

Moreover, as DuckDuckGo said, I did modify about:config's keyword.url and keyword.enable.

But I'm still having www.google.com when I press CTRL+K/J

Hi. I have something I want to change in the default behaviour, but I can't do it. Here's what I want to do: I want to change www.google.com to www.duckduckgo.com. However, when I do CTRL+J or CTRL+K it keeps sending me to www.google.com. Here's what I did: I found that the search bar is now useless. Indeed, the "awesome bar" is so awesome that I basically don't need the search bar any more. So, some time ago, I removed it. There's a benefit to that. When the search bar is gone, the shortcut that was supposed to put focus on the search bar got another behaviour. When I use CTRL+K (CTRL+J), the page would automatically change to www.google.com. I liked this behaviour because at the time I used google as my search engine. But now that I want duckduckgo, I'm kind of annoyed by this, especially since I cannot modify this behaviour. I re-enabled the search bar, and changed the top search option to DuckDuckGo, hoping that would change the behaviour. It did not. Moreover, as DuckDuckGo said, I did modify about:config's keyword.url and keyword.enable. But I'm still having www.google.com when I press CTRL+K/J

被選擇的解決方法

I posed the question to my Diaspora stream ( http://diasp.org ) and was able to get a solution within the day. Go figure. Before doing this, you will have to already have DuckDuckGo added to your search engine list (in the drop box).

Here is the solution. Courtesty of ilyse na'omi kazar

in the location bar type about:config. You'll need to confirm when you're advised that "this will void your warranty". You'll see a slew of preferences that, if you've never done this before, you have never imagined exist under the hood of FF.

In the filter bar type browser.search.defaultenginename. In the "Value" column it says Google. Double click on the word Google and a dialogue will pop up allowing you to re-specify the default engine. Type in DuckDuckGo exactly as it appears in the drop-down of available search engines in your browser. On my Mac the magic string is "DuckDuckGo (SSL)" w/o the quotes.

Close about:config and check it out, worked for me!

從原來的回覆中察看解決方案 👍 1

所有回覆 (3)

more options

選擇的解決方法

I posed the question to my Diaspora stream ( http://diasp.org ) and was able to get a solution within the day. Go figure. Before doing this, you will have to already have DuckDuckGo added to your search engine list (in the drop box).

Here is the solution. Courtesty of ilyse na'omi kazar

in the location bar type about:config. You'll need to confirm when you're advised that "this will void your warranty". You'll see a slew of preferences that, if you've never done this before, you have never imagined exist under the hood of FF.

In the filter bar type browser.search.defaultenginename. In the "Value" column it says Google. Double click on the word Google and a dialogue will pop up allowing you to re-specify the default engine. Type in DuckDuckGo exactly as it appears in the drop-down of available search engines in your browser. On my Mac the magic string is "DuckDuckGo (SSL)" w/o the quotes.

Close about:config and check it out, worked for me!

more options

Thank you, that's great.

more options

i had the problem for a long time, but seeing other people with it made me actually research it again.Nice having connections. you're welcome.

maybe Google trying to embarrass Firefox will cause the default search engine to change.  :)