搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Network settings won't save, always set to useless manual proxy setting.

  • 4 回覆
  • 35 有這個問題
  • 5401 次檢視
  • 最近回覆由 undonesxudus

more options

Upon opening Firefox, going to any website brings up an error message saying that the proxy server is refusing connections. Manually adjusting the network settings fixes the problem, but only for as long as firefox is open. Already gone through all of the "Preferences won't save" troubleshooting fixes with no results.

由 Meaux 於 修改

被選擇的解決方法

Thank you SOOOOO much cloudlift. I've had this problem for so long now and finally was able to resolve it with your help. My problem wasn't with foxmarks, but personas.

從原來的回覆中察看解決方案 👍 0

所有回覆 (4)

more options

I had the same problem & found this reply by paronigor in another thread that solved it for me:


https://support.mozilla.com/en-US/que.../810425#answer-190766


"I looked for files modified at the time I thought a similar Malware acted on my PC.

Found 3 lines added to the:

C:/users/xxxxxmyprofile/appdata/roaming/mozilla/firefox/profiles/xxxxx.default/extensionsfoxmarks@kei.com/default/preferences/prefs.js

I removed them, and I saved the prefs.js file again. They were like: user_pref("network.proxy.http", "127.0.0.1"); user_pref("network.proxy.http_port", 58505); user_pref("network.proxy.type", 1); More or less.

My suggestions: Check all *.js files in firefox/ subfolders, plugins included (in my case, as you can see, it was in foxmarks subfolder).

Took me a while, finally solved. "

more options

@ go to Help Menu -> select "Restart with Add-ons Disabled"

Firefox will close then it will open up with just basic Firefox. You can enable the Add-ons later.

If @ solution doen't work then try following solutions and whichever setting works, keep it Permanent:

1) go to Tools Menu -> Options -> Advanced -> Network -> click "Settings..." button infront of Connection -> select option2 -> Click OK -> OK

2) go to Tools Menu -> Options -> Advanced -> Network -> click "Settings..." button infront of Connection -> select option3 -> Click OK -> OK

3) go to Tools Menu -> Options -> Advanced -> Network -> click "Settings..." button infront of Connection -> select option1 -> Click OK -> OK

Check which solution works.

由 Hasan 於 修改

more options

Get an add on called Foxy Proxy Basic (works with all versions) from Mozilla, install it and restart. Go to the advanced connection settings tab and you will see it's been replaced with the add on. Open it and on the drop down box select "default". This will work if you don't use a proxy. Solved my problem, hope it works for all. Good luck!

more options

選擇的解決方法

Thank you SOOOOO much cloudlift. I've had this problem for so long now and finally was able to resolve it with your help. My problem wasn't with foxmarks, but personas.