搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why have you removed @font-face support from Firefox5 (Yes, tested on multiple machines, works fine in all other browsers & firefox4!)

  • 22 回覆
  • 86 有這個問題
  • 1821 次檢視
  • 最近回覆由 d_a__0

more options

.....

由 rmwebs 於 修改

被選擇的解決方法

@callumw, you have these rules:


@font-face{font-family:"Tiger Rag LET";src:url("/font/tigerrag.ttf")} @font-face{font-family:"Tiger Rag LET";src:url("/font/tigerrag.eot")}
@font-face{font-family:"Century Gothic";src:url("/font/gothic.ttf")} @font-face{font-family:"Century Gothic";src:url("/font/gothic.eot")}
@font-face{font-family:"Lithos Pro";src:url("/font/lithospro.ttf")} @font-face{font-family:"Lithos Pro";src:url("/font/lithospro.otf")}

Firefox is retrieving the second of the two font files in each case. Because Firefox doesn't support the .eot format, those two fonts are not going to work in Firefox. Can you try switching the order on those two and see whether that helps?

Edit: Century Gothic already is on my system, so the first one is the most critical.

從原來的回覆中察看解決方案 👍 1

所有回覆 (20)

more options

Can you provide a link to a site that doesn't work so others can test?

It's possible that some features that caused problems in Firefox 4 were turned off in Firefox 5. However, it appears that font downloading is still enabled by default (in about:config, gfx.downloadable_fonts.enabled=true).

more options

I have this problem too, but on 1 of 3 custom fonts my site loads.

The 1st of the 3 fails, the other 2 render fine

My website (www.CallumW.com) It currently works in V3, V4, but not in V5.

Nothing's changed in my site - just the install of Firefox 5 on my laptop. My desktop still has V4 and it's showing fine.

Any advise welcome.

CW

more options

選擇的解決方法

@callumw, you have these rules:


@font-face{font-family:"Tiger Rag LET";src:url("/font/tigerrag.ttf")} @font-face{font-family:"Tiger Rag LET";src:url("/font/tigerrag.eot")}
@font-face{font-family:"Century Gothic";src:url("/font/gothic.ttf")} @font-face{font-family:"Century Gothic";src:url("/font/gothic.eot")}
@font-face{font-family:"Lithos Pro";src:url("/font/lithospro.ttf")} @font-face{font-family:"Lithos Pro";src:url("/font/lithospro.otf")}

Firefox is retrieving the second of the two font files in each case. Because Firefox doesn't support the .eot format, those two fonts are not going to work in Firefox. Can you try switching the order on those two and see whether that helps?

Edit: Century Gothic already is on my system, so the first one is the most critical.

由 jscher2000 於 修改

more options

Tried that and it's the same :(

more options

I guess you better change it back; it's failing in Firefox 3.6 now.

Might it work to give the two fonts different names, like "Tiger Rag LET TTF" and "Tiger Rag LET EOT" and then list both of them in the font-family rule?

---

I experimented with that tigerrag.ttf file in various ways and never got it to render in 3.6 on WinXP or 5 on Win7. Is it possible that your desktop PC has this font installed as regular system font, and that's why it works there?

由 jscher2000 於 修改

more options
more options

I was working on my site and upgraded to FF5.0. When FF restarted, my fonts gonne to default "Times New Roman". I was working offline with XAMPP. When i updated files at the webserver where the site is hosted, it simply works as expected. The fonts are there, "gracefully showed". Maybe some option in about:config. Some help?

Thanks. Claudio Pinho My site in construction (in portuguese - english later)

由 m3lg4ss0 於 修改

more options

I was having this issue as well and turned to the stylesheet within my fonts folder (a web font kit downloaded from Font Squirrel) and when I copy pasted from that stylesheet my custom font began working again! Also I think you have to use no spaces when naming your font (i.e. ChunkFiveRegular instead of Chunk Five) and the font-weight and font-style have to be present. Here is what I used!

@font-face { font-family: 'ChunkFiveRegular';

   src: url('fonts/Chunkfive-webfont.eot');
   src: url('fonts/Chunkfive-webfont.eot?#iefix') format('embedded-opentype'),
        url('fonts/Chunkfive-webfont.woff') format('woff'),
        url('fonts/Chunkfive-webfont.ttf') format('truetype'),
        url('fonts/Chunkfive-webfont.svg#ChunkFiveRegular') format('svg');
   font-weight: normal;
   font-style: normal;

}

Hope this helps!

由 hananab 於 修改

more options

@m3lg4ss0, there are some restrictions on references to files "above" or "outside" the current directory in locally hosted sites. You could try changing the setting described in this article: Security.fileuri.strict origin policy - MozillaZine Knowledge Base. Does that help?

more options

@jscher2000, i´ve tried that. Not much success. I'll leave it as it is. For now i will simply upload my files to the server and reviewit from there. Thank's any way.

@hananab, my css is this:

@font-face { font-family: "Distro"; src: url("/bin/fonts/DISTRO_.ttf") format("truetype"); font-weight: bold; }

@font-face { font-family: "Distro"; src: url("/bin/fonts/DISTROL-LIGHT.ttf") format("truetype"); }

Cumps.

more options

After so much trial and error, this problem is down to plugins within FF. I have tested this on a fresh install of FF5 and it is working fine. The problem is on my other install I have disbaled all plugins one by one and I still have the same issue.

Seems I may have to start with a fresh install and add the plugins one after the other to see which causes the problem.

由 virtualburn 於 修改

more options

@virtualburn, did you find what the problem was?

由 svit6 於 修改

more options

jscher2000, Thank you for the link! http://kb.mozillazine.org/Security.fileuri.strict_origin_policy Once I had all my files in the correct directories I was good to go! I found the plugins had nothing to do w/it. I am a happy designer....

more options

I also encountered this problem needs solution?

由 anwarsoft 於 修改

more options

I was having a similar problem and found that when referencing font files from within a css file using a direct link, the src domain must be exactly the same as the domain name of the web page.

So, for the site http://example.com

using: @font-face { font-family: 'font-name'; src: url('http://example.com/fonts/...) }

This works if you visit example.com but not if you visit www.example.com - (because there is no www in the font-face src declaration).

Using .htaccess you can remove the www from the domain so the linked font will always work in ff5.

If you're using a direct link, make sure the domain names are exactly the same.

I hope this helps somebody.

more options
more options

@font-face {

   font-family: alkatip tor tom;
   font-style:  normal;
   font-weight: normal;
   src: url(/ALKATIP0.eot);
 }

My website address www.anwar.cn

Font address www.anwar.cn/ALKATIP%20Tor%20Tom.TTF

Firefox 4 can be used

Firefox 5 can not

由 anwarsoft 於 修改

more options

Firefox doesn't use the EOT specification.
If the font is stored locally then add a local rule for that font to make it work in Firefox 5.

So if the name of the font is "alkatip tor tom" then use this:

@font-face { 
 font-family: "alkatip tor tom";
 font-style:  normal;
 font-weight: normal;
 local("alkatip tor tom");
 src: url("/ALKATIP0.eot");
 src: url("/ALKATIP Tor Tom.TTF");
}

由 cor-el 於 修改

more options

Thank you for your reply

I know that Firefox does not use the EOT specification. However, 50% browse the site staff using "internet Explorer" browser

EOT because I do not have this font can display

Font is stored locally, Firefox4 can display the font

Font is stored locally, Firefox5 can not display the font

I'm sorry my English is not good

由 anwarsoft 於 修改

more options

Firefox 5 needs an explicit local rule if you want to use the local font.

That is the consequence of this bug fix.

  • Bug 637157 - @font-face family names should hide system fonts
  1. 1
  2. 2