X
點擊此處開啟此網站的行動版。

技術支援討論區

Is there back-support for FF 4.x? If not, why not?

已張貼

I'd like to roll back to FF4.x until my add-ons are updated for 5.0, but I can't find 4.0 on the mozilla website (even though I can find 3.6.x). Is there a plan to have 4.0 support, or has it been so completely superseded by 5.0 that it's actually unsafe to use?

As general feedback, I'd like to suggest that the compatibility check for add-ons happen *before* confirming the update: it's just unnecessarily frustrating when something breaks and it's too late to go back.

I'd like to roll back to FF4.x until my add-ons are updated for 5.0, but I can't find 4.0 on the mozilla website (even though I can find 3.6.x). Is there a plan to have 4.0 support, or has it been so completely superseded by 5.0 that it's actually unsafe to use? As general feedback, I'd like to suggest that the compatibility check for add-ons happen *before* confirming the update: it's just unnecessarily frustrating when something breaks and it's too late to go back.

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 10.3 r181
  • 4.0.60531.0
  • NPWLPG
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0

更多資訊

the-edmeister
  • Top 25 Contributor
  • Moderator
5419 個解決方法 40422 個答案

Sorry, the "plan" is for 5.0 to replace 4.0.1, with no further support for 4.0.* versions.

95% of the Add-ons hosted at the official Add-ons website are compatible with Firefox 5.0 - https://addons.mozilla.org/en-US/firefox/compatibility/report For extensions that are hosted elsewhere, you can try using this extension - https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/ - to force "incompatible" extensions to be enabled in 5.0 and see for yourself if they work. Then there's a "compatibility" button in the Add-ons Manager tab to report if each extension is working properly or to tell the developer of each extension what problems you're having.

Sorry, the "plan" is for 5.0 to replace 4.0.1, with no further support for 4.0.* versions. 95% of the Add-ons hosted at the official Add-ons website are compatible with Firefox 5.0 - https://addons.mozilla.org/en-US/firefox/compatibility/report For extensions that are hosted elsewhere, you can try using this extension - https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/ - to force "incompatible" extensions to be enabled in 5.0 and see for yourself if they work. Then there's a "compatibility" button in the Add-ons Manager tab to report if each extension is working properly or to tell the developer of each extension what problems you're having.