X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox won't save tabs.

已張貼

I can no longer save tabs when I go to exit firefox. For some reason I can't restore previous session from the history menu and there is no restore session button on the default home page. I've also gone to about:config and made sure that 'browser.tabs.warnOnClose', 'browser.warnOnQuit', and 'browser.warnOnRestart' were set to true but nothing is working. I still only get the warning that I'm about to close tabs, but not the option to save them or not.

And I don't want to change the default settings to show previous tabs and windows on start up because I like firefox starting up on the default page, unless I needed to save tabs. Anyways, when I tried that option last it didn't seem to work.

I'm using firefox 4 on a macbook.

I can no longer save tabs when I go to exit firefox. For some reason I can't restore previous session from the history menu and there is no restore session button on the default home page. I've also gone to about:config and made sure that 'browser.tabs.warnOnClose', 'browser.warnOnQuit', and 'browser.warnOnRestart' were set to true but nothing is working. I still only get the warning that I'm about to close tabs, but not the option to save them or not. And I don't want to change the default settings to show previous tabs and windows on start up because I like firefox starting up on the default page, unless I needed to save tabs. Anyways, when I tried that option last it didn't seem to work. I'm using firefox 4 on a macbook.

額外的系統細節

已安裝的外掛程式

  • iPhoto6
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.2 r152
  • 4.0.60310.0

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

更多資訊

cor-el
  • Top 10 Contributor
  • Moderator
17529 個解決方法 158478 個答案

Make sure that you not run Firefox in permanent Private Browsing mode.

  • https://support.mozilla.com/kb/Private+Browsing
  • You enter Private Browsing mode if you select: Firefox > Preferences > Privacy > History: Firefox will: "Never Remember History"
  • To see all History and Cookie settings, choose: Firefox > Preferences > Privacy, choose the setting Firefox will: Use custom settings for history
  • Deselect: [ ] "Permanent Private Browsing mode"
Make sure that you not run Firefox in permanent Private Browsing mode. * https://support.mozilla.com/kb/Private+Browsing * You enter Private Browsing mode if you select: Firefox > Preferences > Privacy > History: Firefox will: "Never Remember History" * To see all History and Cookie settings, choose: Firefox > Preferences > Privacy, choose the setting <b>Firefox will: Use custom settings for history</b> * Deselect: [ ] "Permanent Private Browsing mode"

提出問題者

It's not in private browsing and I checked the custom history settings. Everything's the way it should be.

It's not in private browsing and I checked the custom history settings. Everything's the way it should be.
cor-el
  • Top 10 Contributor
  • Moderator
17529 個解決方法 158478 個答案

Check that session restore is still working.

It is possible that there is a problem with the files sessionstore.js and sessionstore.bak in the Firefox Profile Folder.

Delete the files sessionstore.js and sessionstore.bak in the Firefox Profile Folder.

If you see files sessionstore-##.js with a number in the left part of the name like sessionstore-1.js then delete those as well.

Deleting sessionstore.js will cause App Tabs and Tab Groups to get lost, so you will have to create them again (make a note).

Check that session restore is still working. * http://kb.mozillazine.org/Session_Restore It is possible that there is a problem with the files sessionstore.js and sessionstore.bak in the Firefox Profile Folder. Delete the files sessionstore.js and sessionstore.bak in the Firefox Profile Folder. * Help > Troubleshooting Information > Profile Directory: Open Containing Folder * http://kb.mozillazine.org/Profile_folder_-_Firefox * http://kb.mozillazine.org/sessionstore.js If you see files sessionstore-##.js with a number in the left part of the name like sessionstore-1.js then delete those as well. Deleting sessionstore.js will cause App Tabs and Tab Groups to get lost, so you will have to create them again (make a note).

提出問題者

Er, does App tabs and Tab Groups have anything to do with bookmarks?

Er, does App tabs and Tab Groups have anything to do with bookmarks?
cor-el
  • Top 10 Contributor
  • Moderator
17529 個解決方法 158478 個答案

It has to do with restoring tabs via session restore on the next start. If you delete the file that stores session data in case of problems with it then you lose App Tabs. That may not apply to you if you do not use them, but may apply to others who read this.

It has to do with restoring tabs via session restore on the next start. If you delete the file that stores session data in case of problems with it then you lose App Tabs. That may not apply to you if you do not use them, but may apply to others who read this.

提出問題者

Well, I tried what you said, deleted those files, and now firefox won't open at all. When I click it it jumps once - all applications do this except they usually jump a couple more times first - and the nothing. It simply won't do anything now.

Well, I tried what you said, deleted those files, and now firefox won't open at all. When I click it it jumps once - all applications do this except they usually jump a couple more times first - and the nothing. It simply won't do anything now.
cor-el
  • Top 10 Contributor
  • Moderator
17529 個解決方法 158478 個答案

Which files did you remove and from which location (folder)?

If they are still in the trash then try to restore them.


Create a new profile as a test to check if your current profile is causing the problems.

See:

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)

See:

Which files did you remove and from which location (folder)? If they are still in the trash then try to restore them. ---- Create a new profile as a test to check if your current profile is causing the problems. See: * [https://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile Basic Troubleshooting: Make a new profile] If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files) See: * http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

提出問題者

The files I deleted were the ones you told me to delete. sessionstore.js, sessionstore.bak, sessionstore-1.js. I deleted those files in the profile folder that I had renamed to 'search.sqlite' for another problem I was having, and then there was another folder named 'Profiles' that hadn't been there before so I deleted those files from there too.

There's one file I can't get back. It was a sessionstore.js. The reason why I can't get it back is because it replaced the other sessionstore.js that I had pulled out of the other folder.

That link you gave me for creating a new profile doesn't give instruction for how to do it on a mac.

The files I deleted were the ones you told me to delete. sessionstore.js, sessionstore.bak, sessionstore-1.js. I deleted those files in the profile folder that I had renamed to 'search.sqlite' for another problem I was having, and then there was another folder named 'Profiles' that hadn't been there before so I deleted those files from there too. There's one file I can't get back. It was a sessionstore.js. The reason why I can't get it back is because it replaced the other sessionstore.js that I had pulled out of the other folder. That link you gave me for creating a new profile doesn't give instruction for how to do it on a mac.
cor-el
  • Top 10 Contributor
  • Moderator
17529 個解決方法 158478 個答案

You can't rename or delete folders like that. That will corrupt the Firefox Profile Folder

If you have a file profiles.ini then delete that file to make Firefox create a new default profile.

You can't rename or delete folders like that. That will corrupt the Firefox Profile Folder If you have a file profiles.ini then delete that file to make Firefox create a new default profile. * http://kb.mozillazine.org/profiles.ini_file * http://kb.mozillazine.org/Recovering_a_missing_profile

提出問題者

I renamed the profile folder before because of a link you gave me in another thread for another problem and it worked. I also haven't deleted anything you haven't said to.

I deleted the profiles.ini file. I also went through terminal to try and get to profile manager, like it said to in your link, but it said there was no such file or directory.

Is there a way that I can just reinstall firefox and get all my bookmarks to it? It seems like there's too many things wrong with the firefox on my computer. Maybe if I reinstall I won't have to go through all this extra stuff. Might that work?

I renamed the profile folder before because of a link you gave me in another thread for another problem and it worked. I also haven't deleted anything you haven't said to. I deleted the profiles.ini file. I also went through terminal to try and get to profile manager, like it said to in your link, but it said there was no such file or directory. Is there a way that I can just reinstall firefox and get all my bookmarks to it? It seems like there's too many things wrong with the firefox on my computer. Maybe if I reinstall I won't have to go through all this extra stuff. Might that work?
cor-el
  • Top 10 Contributor
  • Moderator
17529 個解決方法 158478 個答案

I would never ask to rename a folder that way.

It was probably suggested in a support article or by me to rename a file in the Firefox Profile Folder to test for file corruption.

Was this about a corrupted file places.sqlite?


Did you try to create and use a new profile?

See:

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)
See:

I would never ask to rename a folder that way. It was probably suggested in a support article or by me to rename a file in the Firefox Profile Folder to test for file corruption. Was this about a corrupted file places.sqlite? ---- Did you try to create and use a new profile? See: * [https://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile Basic Troubleshooting: Make a new profile] If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)<br /> See: * https://support.mozilla.com/kb/Recovering+important+data+from+an+old+profile * http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

提出問題者

I do not know how to create a new profile. The link you gave me for making a new profile tells me to use the instructions in Managing Profiles to open profile manager, but it only gives instructions on how to do it on windows, not mac which is what I have.

I do not know how to create a new profile. The link you gave me for making a new profile tells me to use the instructions in Managing Profiles to open profile manager, but it only gives instructions on how to do it on windows, not mac which is what I have.
cor-el
  • Top 10 Contributor
  • Moderator
17529 個解決方法 158478 個答案

There is a menu in the bar at the right on the page with the KB article that allows to select the Operating System and the Firefox version, so make sure that you get the content for Mac OS X and Firefox 4.

There is a menu in the bar at the right on the page with the KB article that allows to select the Operating System and the Firefox version, so make sure that you get the content for Mac OS X and Firefox 4. *https://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile

提出問題者

Oh okay, can't believe I didn't see that.

I made absolutely sure that firefox was completely closed, that it wasn't running in the background or anything, then entered terminal and typed in what it said to but it said there was 'No such file or directory'.

I made sure that I typed in precisely what it said to but still nothing.

Oh okay, can't believe I didn't see that. I made absolutely sure that firefox was completely closed, that it wasn't running in the background or anything, then entered terminal and typed in what it said to but it said there was 'No such file or directory'. I made sure that I typed in precisely what it said to but still nothing.

由 Kivusa 於 修改

提出問題者

Well, a few minutes ago I accidentally clicked on firefox out of habit, not realizing that it wouldn't work. Except, well, this time it did work. For one moment I was all excited until I saw that all my bookmarks were gone and then nearly had a heart attack.

So I looked and saw that firefox had somehow made itself a new profile and then I figured out how to restore my bookmarks from the other profile and everything is pretty much back in order.

It still won't ask to save tabs though. I went back into about:config to check that all those things were set to true but still no luck.

Well, a few minutes ago I accidentally clicked on firefox out of habit, not realizing that it wouldn't work. Except, well, this time it did work. For one moment I was all excited until I saw that all my bookmarks were gone and then nearly had a heart attack. So I looked and saw that firefox had somehow made itself a new profile and then I figured out how to restore my bookmarks from the other profile and everything is pretty much back in order. It still won't ask to save tabs though. I went back into about:config to check that all those things were set to true but still no luck.
cor-el
  • Top 10 Contributor
  • Moderator
17529 個解決方法 158478 個答案

Firefox 4 saves the previous session automatically, so there is no longer need for the dialog asking if you want to save the current session.
Use "File > Exit" or "Firefox > Exit" (Mac: "Firefox > Quit Firefox") if you want to restore multiple windows.
You can use "History > Restore Previous Session" to get the previous session at any time.
You may need to click the orange/gray Firefox button to see History.
There is also a "Restore Previous Session" button on the default about:home Home page.

Another possibility is to use:


You can set the warn prefs on the about:config page to true via the right-click context menu or toggle the value with a double left-click.

Firefox 4 saves the previous session automatically, so there is no longer need for the dialog asking if you want to save the current session.<br /> Use "File > Exit" or "Firefox > Exit" (Mac: "Firefox > Quit Firefox") if you want to restore multiple windows.<br /> You can use "History > Restore Previous Session" to get the previous session at any time.<br /> You may need to click the orange/gray Firefox button to see History.<br /> There is also a "Restore Previous Session" button on the default <b>about:home</b> Home page. Another possibility is to use: * [http://kb.mozillazine.org/Menu_differences Firefox/Tools > Options] > General > Startup: "When Firefox Starts": "Show my windows and tabs from last time" ----- You can set the warn prefs on the <b>about:config</b> page to <b>true</b> via the right-click context menu or toggle the value with a double left-click. * browser.showQuitWarning, see http://blog.zpao.com/post/3174360617/about-that-quit-dialog * browser.tabs.warnOnClose, see http://kb.mozillazine.org/About%3Aconfig_entries * browser.warnOnQuit , see http://kb.mozillazine.org/browser.warnOnQuit * browser.warnOnRestart , see http://kb.mozillazine.org/browser.warnOnRestart
buenobs 0 個解決方法 1 個答案

有幫助的回覆

Firefox 5 include a new style of tabs save. You can restore the previous session doing: Edit->Preferences->General->When Firefox starts: (then three options)

  1. Your fixed home page.
  2. A blank page.
  3. Windows and tabs that where opened last time you accessed the net.

In order to restore last session you must select option number 3.

I hope it helps good fellows.

Firefox 5 include a new style of tabs save. You can restore the previous session doing: Edit->Preferences->General->When Firefox starts: (then three options) # Your fixed home page. # A blank page. # Windows and tabs that where opened last time you accessed the net. In order to restore last session you must select option number 3. I hope it helps good fellows.

由 buenobs 於 修改

提出問題者

Yeah, I know I can restore tabs like that. I'd just rather it be through the dialog like before. So that it doesn't restore tabs every time I log in. And so that when I log in next time it'll automatically come up so I don't forget about it.

Guess I'll have to try to get used to it though, if there's no way to get the dialog back. Thanks for your help guys.

Yeah, I know I can restore tabs like that. I'd just rather it be through the dialog like before. So that it doesn't restore tabs every time I log in. And so that when I log in next time it'll automatically come up so I don't forget about it. Guess I'll have to try to get used to it though, if there's no way to get the dialog back. Thanks for your help guys.

由 Kivusa 於 修改

okar 0 個解決方法 1 個答案

有幫助的回覆

I believe you can replace the previous functionality with a plug-in, I'm on the same boat and looking for it. There are several of them and will need to try and see which one is the best.

I believe you can replace the previous functionality with a plug-in, I'm on the same boat and looking for it. There are several of them and will need to try and see which one is the best.
djwinger 0 個解決方法 2 個答案

This problem has to do with your history settings. If you are already getting the "Save and Quit" dialog box, temporarily turn off "Clear history when Firefox closes" (Tools > Options > Privacy) to see if it now works.

If it does work, turn it back on and click the "Settings" button next to it. Untick the box for "Browsing History". This setting is not needed if you have the main option "Remember my browsing history for at least X days" unticked.

Remember: this solution is only for people who are already getting the "Save and Quit" dialog box, but the tabs are not opening when you start Firefox.

This problem has to do with your history settings. If you are already getting the "Save and Quit" dialog box, temporarily turn off "Clear history when Firefox closes" (Tools > Options > Privacy) to see if it now works. If it does work, turn it back on and click the "Settings" button next to it. Untick the box for "Browsing History". This setting is not needed if you have the main option "Remember my browsing history for at least X days" unticked. Remember: this solution is only for people who are already getting the "Save and Quit" dialog box, but the tabs are not opening when you start Firefox.