搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

YouTube does not switch to hd in full screen mode

  • 14 回覆
  • 5 有這個問題
  • 3744 次檢視
  • 最近回覆由 GBarnes

more options

Hi I have YouTube set to 'Always switch to HD when switching to full screen (when available)' but when using the current version of Firefox (4.0.1), this doesn't happen. I've tried it in Chrome, and it works there so it may be an issue with Firefox. Any suggsions?

被選擇的解決方法

Clear cache and cookies (for that site) and try again.

從原來的回覆中察看解決方案 👍 0

所有回覆 (14)

more options

選擇的解決方法

Clear cache and cookies (for that site) and try again.

more options

Well, that was a simple one. After my comically large cache has gone (freezing Firefox in the process) the videos work as expected. Thanks!

more options

Actually, no. It works when I tested on a music video, but doesn't work in a channel. Odd...

more options

There may be more than one cookie for the site.

more options

I got rid of everything returned by searching for 'youtube' in 'remove individual cookies' - could they not be searchable by this?

more options

If it is in fact the "YouTube" site then there will be a cookie folder on the left bearing that name and there will be a + sign next to it. Clicking the + will expand the folder revealing all of the cookies relative to YouTube. And yes, YouTube is searchable as you indicated. However, removing just cookies labled YouTube may not remove all related cookies if there is another server being accessed within the YouTube server farm,etc.

由 JayGarcia 於 修改

more options

OK, I deleted the folder called 'youtube.com' for good measure and that hasn't solved it. I also enabled my 'HD Suite' scripty addon thing on a whim, and that has the same problem - it can't auto-play the video in a channel at the highest quality, but can do it for a normal video...

more options

Have you updated your video drivers? And I assume you have an HD capable video card? If so have you enabled HD or reset the preferences back to default?

由 JayGarcia 於 修改

more options

I don't know what you mean by enable HD, but I'm fairly sure my reply should be in the affimative. I updated my drivers a couple of hours ago (not to fix this, just because I hadn't done it in a couple of months) for my Radeon 5770 and it plays HD content - videos and games, anyway - really quite well.

This video http://www.youtube.com/watch?v=ZFHxtnacFV8 automatically changes to 720p in fullscreen, and works fine. When played in the channel window @ http://www.youtube.com/user/delphicmusic it only automatically changes into 480p in fullscreen.

由 GBarnes 於 修改

more options

I just tried the delphiemusic link and it started in 480p but when I switched to full screen and then back it was in 1080p - mystery, don't know but it appears to not be a Firefox issue.

more options

Mystery indeed. And irritating in a really minor way. Thanks very much for your time, though.

more options

Just tried it again and it's behaving as intended. It starts in 480p and using the drop-down I changed it to 1080p, switched to full-screen and still in 1080p and back to normal screen, still same 1080p. Also the same using the old Navigator 9 that I keep around for just this sort of testing.

more options

Yeah, mine'll maintain resolution once I set it. Apparently having high quality video presented to me on demand and within a few seconds just isn't enough for me. I want it to be automatically unreasonably high quality without having to press a button to say so. Kids today...

more options

I just tested in Chrome again, and it has the same issue. I must've only tested a non-channel video earlier. Bit of a waste of both our time, this. Over to Youtube support I suppose. Woops. Sorry.

由 GBarnes 於 修改