搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

favicons suddenly disappeared from most, but not all app tabs

more options

Running Windows XP Pro and Firefox 4.0.1. On a recent restart of Firefox, most of the favicons for my app tabs had disappeared; in their place it just shows the blank page icon.

I have unpinned and repinned with no change. I cleared cookies and then restarted the various websites, with no change. In a couple of cases when I bookmarked the sites in question, the favicons appeared on the bookmark bar, but still won't appear on the app tab; in other cases I get the blank page icon on the bookmark as well as the app tab. No items previously on the bookmark bar lost their favicons. I had previously been able to see the unique favicons for all sites on app tabs.

所有回覆 (14)

more options

Do you have all those App Tabs bookmarked?

Are the App Tabs that still have a favicon bookmarked?

Did you clear the cache recently (e.g. via Delete browsing, search and download history on Firefox)?

more options

No, none of the App Tabs are/were bookmarked.

I did clear the fairly cache recently, but that was a two or three days before the favicons disappeared.

Since I originally posted, another favicon has disappeared. It was the only one that had disappeared in the first round that came back when I unpinned, reloaded, and repinned.

more options

Does it help if you bookmark an App Tab?

Are you running any cleanup software like CCleaner?

more options

A little confused---how do I bookmark an App Tab? When the problem started, I unpinned those site that had lost their favicon on the App Tabs and bookmarked them instead. Of 9 sites that were unpinned, 3 show their favicons on the bookmarks toolbar, and 6 show the blank page. If I open one of the bookmarks that currently shows it favicon and pin it as an App Tab the favicon will still appear on the bookmarks tab, but still doesn't show up on the Apps Tab. If I open a bookmark that doesn't show it's favicon and pin it as an App Tab it still won't show the favicon in either place.

I ran Advanced System Care (it's not always on, but rather started manually on occasion) around the same time I cleared my cache (due to another problem that seems concurrent with installing Firefox 4, but unrelated to the favicons issue) but the favicons didn't disappear at that time.

more options

Did you try to reload such a tab and bypass the cache?

Reload web page(s) and bypass the cache.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)

You can bookmark a (pinned) tab via the right-click context menu of that web page or via Firefox > Bookmarks > Bookmark This Tab

more options

No change when bookmarking an App Tab, and no change with reloading web page(s) and bypassing the cache.

more options

Make sure that you not run Firefox in (permanent) Private Browsing - Use Firefox without saving history mode.

  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Uncheck: [ ] "Permanent Private Browsing mode"
more options

I checked, and I am not running in Permanent Private Browsing Mode.

more options

I had the same problem, I lost the favicon for my facebook app tab, but not for my gmail one. I also lost favicons on most of my normal tabs (but not on my bookmarks). I had the favicon picker 2 (0.6.2.15) addon enabled, and disabling it fixed my problem.

more options

Thanks for the suggestion. Unfortunately it doesn't solve my problem as I don't have a favicon picker among my addons.

more options

Had the same problem with favicon picker 2 (0.6.2.15) in FF 6.0. The icons will only refresh when I open them.

more options

Disabling Favicon Picker 2 in FF 5.0.1 fixed this for me and I now have the site favicons back on the tabs. I'm hopeful that this add-on [that I don't want to live without] can overcome this soon, but for now I will just 'keep it disabled' until I want to use it and maybe one day an update will fix Favicon Picker 2.

more options

I had the same issue. Had Favicon Picker 2 in FF 5.0.1. Disabled it and got my favicons back in the tabs. I installed Bookmark Favicon Changer 1.5.1 and that does not give me any issues but still allows me to manage favicons.

more options

Thanks for the fix! I now use this add-on if anybody is interested

https://addons.mozilla.org/en-US/firefox/addon/bookmark-favicon-changer/

It works perfectly with FF8