搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Why is firefox suddenly denying access to reliable websites calling them "untrusted"?

  • 14 回覆
  • 101 有這個問題
  • 3901 次檢視
  • 最近回覆由 cor-el

more options

My husband has been using a reliable medical site for years...suddenly the message popped up "untrusted site." We contacted the site--they connected us to their tech support--he tried everything with us over the phone (cleaning cookies, downloading latest version of firefox) but the only way to solve it was to give firefox the go-ahead to ignore their warning. We then got the site. Today, the same message popped up on another site he uses regularly. Any ideas why this should suddenly happen on reliable sites used successfully for years?

被選擇的解決方法

STOP THE PRESSES! I finally found the windows update--it turned out that the date and time on my computer were out of sync (we had a blackout a few days ago that must have triggered it!). Thank you sooooooooooooooooooooooooo much!

freebie

從原來的回覆中察看解決方案 👍 2

所有回覆 (14)

more options

Are these errors relating to the security certificates? Firefox first checks them to make sure they haven't expired and were issued by a trusted authority. It then checks whether they have been revoked. You can set Firefox to block sites whose certificates have been revoked, and, for maximum safety, to block sites when it is not possible to check whether their certificates have been revoked.

If you think those settings might be relevant, you can experiment with them here:

Tools > Options > Advanced > Encryption sub-tab > Validation button

If the lower checkbox is checked, try unchecking it. This does create a slight exposure to sites masquerading as something they are not, but that might be preferable to what you have now.

If that makes no difference, I wonder whether you might be missing a newer root certificate. You may want to check for Windows updates, since Firefox may use certificates included with your OS.

more options

Thanks for your response--I"m not very computer savvy but I tried what you suggested. There were three boxes--the top was checked but the lower two were not checked. For some reason, I couldn't figure out how to check for Windows updates. Nothing has popped up as an update. It's weird--more sites have popped up now that are called "untrusted"--all sites he goes to regularly. I appreciate your help.

more options

選擇的解決方法

STOP THE PRESSES! I finally found the windows update--it turned out that the date and time on my computer were out of sync (we had a blackout a few days ago that must have triggered it!). Thank you sooooooooooooooooooooooooo much!

freebie

more options

I always forget about the time problem. Glad you found it.

more options

I would like to block this site. Kindly help me to block this site.

more options

Hi Tarakesh, can you start a new question and include a list of your add-ons?

https://support.mozilla.com/en-US/kb/ask

more options

I keep getting the untrusted connection message. IE doesn't get it. It is NOT a clock issue for me. I wasn't getting this message until a couple of days ago. I'm really tired of trying to find a solution.

由 dlco 於 修改

more options

@dico

Please "ask a new question".

https://support.mozilla.com/en-US/kb/ask

more options

Rename the file cert8.db to cert8.db.old in the Firefox Profile Folder to remove all intermediate certificates that Firefox has stored by visiting secure websites.
If that helped to solve the problem then you can remove the renamed file cert8.db.old unless you have user certificates that you may want to export first and import them in the new file.
Otherwise you can restore the certificates by renaming (copying) the file back to cert8.db
Firefox will automatically store new intermediate certificates when you visit websites that send them.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder
more options

@the-edmeister I'm not sure why I should ask a new question. My problem was the same as the OP. Then you have duplicate questions and multiple solutions for others with the same problem to sort through. That doesn't make sense.

It might have something to do with version 10. I went back to an older version 3.6.26 and I'm not having the "untrusted connection" problem anymore.

由 dlco 於 修改

more options

disregard

由 dlco 於 修改

more options

It says: 0 out of 2 people found this reply helpful

If you had clicked Helpful then you would have seen: 2 out of 2 people found this reply helpful

more options

You are right my error.

more options

Your security software (firewall) can also cause such problems if you are not specially allowing the current (updated) Firefox version.


A possible cause is security software (firewall) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See: