搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

I downloaded iMesh and I can't stop it from automatically popping up each time I request a new tab. I have uninstalled the program, but I want to stop it from defaulting as a new tab. I tried uninstalling, but it is no longer installed as an add-on

  • 9 回覆
  • 261 有這個問題
  • 1196 次檢視
  • 最近回覆由 Darsten5555

more options

I downloaded iMesh and I can't stop it from automatically popping up each time I request a new tab. I have uninstalled the program, but I want to stop it from defaulting as a new tab. I tried uninstalling the add on and plug in, but it is no longer installed as an add-on or plug in. How do I get the "new tab" request to simply open with a blank address in the address box instead of www.imesh.com.

所有回覆 (9)

more options

Type about:config in the URL bar and hit Enter.
If you see the warning, you can confirm that you want to access that page.

Type iMesh or imesh in the Filter: line at the top, right-click each Preference that remains in the window and select Reset, then restart Firefox.

more options

So far every solution has failed. When I open Firefox, iMesh is there.

more options

You can't find iMesh in the about:config prefs / values?

Or, when you Reset the prefs you find they are set to iMesh all over again after a Firefox restart or an Windows restart?

more options

Hello. I have the same problem. I followed the-edmeister's instructions but it didn't work. Everytime I restart Firefox, I go to about:config and type in 'iMesh' again. extensions.installCache comes out EVERY SINGLE TIME, even after I reset it. Surprisingly, the home page in my options is not the imesh search website.

When I already have a Firefox window running and I open another one, the second one opens the home pages that I want. However, when I open a new window (which means previously none opened), the stupid imesh search comes out.

SOMEBODY HELP US. >.<

more options

To revert to Google as your preferred search engine, please do the following.

  • In the location bar, type about:config and hit Enter.

  • In the filter at the top, type: keyword.URL

  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.


To reset your home page, do the following.

  • Go to the site you want to set as your homepage.

  • Go to Tools | Options | General.

  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

After you complete the above steps, install this add-on to prevent another search engine from modifying your preferences: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/


N.B. Update Firefox via Help | Check For Updates. There was a security breach at Comodo which is an SSL certificate provider recently whereby a number of fraudulent certificates were inadvertently issued. These allow a hacker to impersonate any site including online banking and the Firefox version you're running at the moment will not warn you that the site is a fake. The fraudulent certificates were blacklisted in v3.6.17 and beyond.

See http://blogs.comodo.com/it-security/data-security/the-recent-ra-compromise/

more options

every time I try either solution a message comes up saying " an attempt to change your search engine or homepage was blocked."It's like imesh tried everything in the book to keep us from uninstalling it.

more options

Ok, I finally managed to get rid of it. First I did the thing with the about:config but I flitered for imesh instead and managed to reset two thing but when I got to the keyword.URL I got the same thing as lolbabe98 did with the "An attempt to change your search engine or homepage was blocked."

Then I did a search on my C: drive for iMesh and discovered some things that hadn't been removed even though I had unistalled both the toolbar and the actual program. After that it worked fine and I now have a regular "untitled" tab when I open a new tab.

One last thing, when I tried to remove some of the files there was one that said it was in use, it was called datamanagerUI or something rather. The only thing I had to do there was to open Task Manager and kill a process called DATAMN~1 and I was able to remove it. Hope this helps.

more options

Thank you for the solution on a chronic concern...

more options

It seems iMesh is very determined, I had to uninstall iMesh using the control panel, then run a search on my C drive and delete all files associated with iMesh, and then open up the control panel uninstall option and search for iMesh. There were 2 files that didn't show up previously, uninstalling them made the new tab problem go away (thank god, I am OCD about these things)

Hope this helps anyone experiencing difficulty.